Won't stop trying to install device driver

By malamute20 ยท 29 replies
Oct 28, 2010
Post New Reply
  1. [Solved]


    Every time I boot Windows (7), I get a message about how installation of device driver has failed. This has happened ever since I installed PDANet - uninstalling / reinstalling that program has not resolved the issue, however.

    It's been about a month and the darn thing hasn't gone away. I've searched google etc and it seems this isn't an easy / common fix.

    I saved some files that Windows' "Action Required" indicated were associated with the file. They're huge text strings, but seem to indicate that the IEEE PCI Host Controller is responsible.


    ; johci.inf
    ; Installation inf for the 1394 Filter driver
    ; Copyright (c) JMicron Technology Corporation

    Signature = "$Windows NT$"
    Class = 1394
    ClassGUID = {6BDD1FC1-810F-11D0-BEC7-08002BE2092F}
    Provider = %JMICRON%
    DriverVer = 03/31/2010,

    DefaultDestDir = 12



    [Device Install Log]
    OS Version = 6.1.7600
    Service Pack = 0.0
    Suite = 0x0300
    ProductType = 1
    Architecture = amd64


    [Boot Session: 2010/08/07 13:20:34.421]

    >>> [Setup Plug and Play Device Install]

    I've got the files those "headers" are saved from, it's more an annoyance to see the popup every startup and know system performance is being wasted on an automatic task, not really getting in the way of anything, but still I'd love to get some help resolving it. Thanks a lot in advance.

  2. Macboatmaster

    Macboatmaster TS Member Posts: 75

    When did you install it.
    If not too long ago I would use system restore to a point before installation.
    That all said I would not have installed it in the first place.

    I do not have any real knowledge of PDANet but a very quick look would have been sufficient for me to keep away from it especially on Windows7.

    If after restore to a date before the installation of PDANet, the problem still exists I would do a malware, virus, spyware scan and then if anything is found go to the Malware Forum.
  3. malamute20

    malamute20 TS Rookie Topic Starter Posts: 17

    I installed it a couple months ago, end of August. Restoring to previous isn't really an option, but that shouldn't really be necessary to make it stop trying to install a driver, should it?

    It's not a MalWare issue though. The App allows me to tether my phone as a wireless access point essentially, without dealing with an extra fee on top of my data plan. Nevertheless, I ran the scans and nothing turned up - for the record, they run automatic full scans twice a week, so I'm reasonably certain anything along those lines woulda turned up before. Out of curiosity, why'd you say you'd stay away, "specifically with Win 7"? Running a Google search doesn't turn up any red flags that I can see, I checked before using the app and again when you said that.

    I'm still looking for a solution for this. I've gone through a huge amount of system updates since then as it's a relatively new system, so it would basically be a factory reset, which would not be my preference.
  4. Macboatmaster

    Macboatmaster TS Member Posts: 75

    This desktop client is for the iPhone version of PdaNet only and will not work for an Android phone. Please make sure iTunes has been installed before installing PdaNet Desktop Client.

    Slight changes were made in 1.54 build to fix compatibility issue with iTunes 9.1/9.2. Please download again if you have upgraded iTunes.

    Download PdaNet Desktop 1.54 for 32 bit Windows

    Download PdaNet Desktop 1.54 for 64 bit Vista/Windows 7

    Download PdaNet Desktop 1.10 for Mac

    Desktop version number may not be the same as PdaNet version on your phone side.

    Update History (Windows desktop client only, see updates on Mac version or phone software):

    Version 1.54 (built 4/8/2010)

    * Fixes iTunes 9.1 compatibility.

    Version 1.54

    * Fixes iTunes 9.0 compatibility.
    * Pops tray message when iPhone is attached.

    Version 1.53

    * Adds an option to automatically connect PdaNet when your phone is attached to the computer.
    * Fixes compatibility issue with iTunes 8.2.
    * Fixes access to http://my.iPhone
    * Adds command line option "/c" to run and connect PdaNet at the same time. Also exits when connection is dropped.

    Version 1.50

    * Initial release.

    NO OF COURSE System Restore would not be necessary just to stop the driver installation. IF that was the real cause of the problem. I am not sure it is.
    The reason I say I would stay away from it is I do not like the website. I make no comments regarding the program it may be excellent. It is your choice, because of course it is your computer.
    I still opine that there is a greater problem than the symptom may suggest and as Windows7 is ONLY one year old on the general market, I would not install anything that was not tried and tested software from a well known producer. (This is not in anyway to suggest that JUNE FRABRICS TECHNOLOGIES products are unrelaible in anyway)
  5. malamute20

    malamute20 TS Rookie Topic Starter Posts: 17

    <snip>Ah, I just realized that the only reason yours said Android incompatible was because of the specific link you took on their homepage. </snip>

    What I think is interesting here is that the device driver issue is referring to the IEEE PCI Bus Controller... When I installed PDANet it was also the first time I tethered my phone to my laptop (or any computer.) I'm thinking that when I tethered, it attempted to install device drivers from the phone? Which ran in the background and failed, without me realizing it. Then I removed the device after finishing what I was doing, and got stuck with an infinite loop driver installation attempt which initiated and failed the first time I plugged the phone in.

    The problem with that scenario is I would have expected it to resolve the next time I tethered my phone, which I've done dozens of times now, and it hasn't...

    Thanks for the explanation re: PDANet by the way. I only asked because your comment raised warning signs in my brain that said maybe I missed something when I checked them out in the first place. It's a bit reassuring to know it's merely opinion based... not to discredit that, but I was worried some greater red-flags were extant.

    So... still need a solution. I'm not trying to be stubborn by not rolling back, I'm just looking for a more 'optimal' solution.
  6. malamute20

    malamute20 TS Rookie Topic Starter Posts: 17

    Bump still looking for ideas.
  7. jamesodriscoll

    jamesodriscoll TS Rookie Posts: 91

    Hi Malamute20,
    Welcome to TS.

    Random suggestion here but do you have HotSync installed on your PC?

    Not sure but THINK it needs than installed first as its an andriod app primarily so you can use your iPhone etc as a wireless router.

  8. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Pls do this:

    • Click Start->Run, enter: msinfo32. Click the + sign next to Components to expand it
    • Click Problem Devices. Anything appear?
    • If yes, click on it, Ctrl-A to select all, Ctrl-C to copy it, Ctrl-V to paste into next post
    • On the other hand, if no devices are listed, tell me so

    /* EDIT */
    Let's go for the gusto while we're at it! In addition to above, see [post=939115]How To Report Your Computer's Device Manager Data[/post] and attach the report
  9. malamute20

    malamute20 TS Rookie Topic Starter Posts: 17

    No, I don't. I think I probably shouldn't have mentioned PDANet in the OP; I did because of the timeframe in which it was installed, but it seems unlikely that it's the culprit, and I wasn't sure if it would shift much of the focus to PDANet as the source of the problem.

    Re: LookinAround, I'll attempt those steps now, and post results.
  10. malamute20

    malamute20 TS Rookie Topic Starter Posts: 17

    MSInfo Problem Devices:

    facap, FastAccess Video Capture ROOT\IMAGE\0000 This device is disabled.
    ST Micro Accelerometer ROOT\SYSTEM\0001 This device is not working properly because Windows cannot load the drivers required for this device.

    DevManView file had to be compressed as the size as a .txt doc exceeded my max upload of 200kb. I used 7zip to compress, I doubt there will be compatibility issues but if you have trouble accessing the file let me know, I don't compress things often.

    **EDIT: Woops. TABULAR text. Riiight... one sec.

    Attached Files:

  11. malamute20

    malamute20 TS Rookie Topic Starter Posts: 17

    Redid DevManView file as tabular. Doh!

    Here it is:

    Attached Files:

  12. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Hmmmm... Well i haven't looked through your output in detail yet but my first impressions:

    Might your computer be a Dell Lattitude???? In any case, please tell me the exact make / model of your computer.

    Appears you have an accelerometer connected to your computer (And i'm also guessing this is the primary culprit!)
    > Does your computer have a free-fall sensor?
    > Accelerometers are also sometimes found within in-vehicle GPS navigation systems as well. But i'm guessing not likely your computer is connected to a vechicle nav system??

    In any case, giving your computer specs will help: computer make and model. What type of disks??

    /* EDIT */
    btw.. Accelerometers are sensors which detect and report the rate of change in motion in any of all 3 planes (up/down, left/right, front/back)
  13. malamute20

    malamute20 TS Rookie Topic Starter Posts: 17

    My computer does have a freefall sensor. I also remember installing a new accelerometer driver a few weeks ago when I updated my system, and I believe it was around the same time I noticed the driver install issue as well - updated a lot of drivers at the same time. As soon as I pulled up that MSInfo I saw that error, and it looks like almost the exact message I get when the laptop boots. So great -- looks like we've identified the culprit. Now, how to fix it?

    Alienware M11x R2 laptop.

    PROCESSOR Intel Core i7 640UM (4M Cache, 2.266 GHz Max Turbo Frequency)
    MEMORY 4GB Dual Channel DDR3 at 800MHz
    HARD DRIVE Seagate 500GB SATAII 7,200RPM
    VIDEO CARDS Integrated: Intel HD Graphics
    Dedicated: 1GB NVIDIA GeForce GT 335M

    Or if you prefer I can post DXDiag logs.
  14. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Try a uninstall/reinstall. As the other odd thing i noticed about that accl. driver. Your driver data shows: the current accelermeter driver version # is v1.0.0.3. Tho Dell web site has a different (and more recent) version for download

    Suggest you
    1. Open DevMgr. Look under System Devices for the accl. probably named ST Micro Acceleromet
    2. Rt click, Uninstall
    3. Next, in DevMgr, click View->Show Hidden Devices, check under System Devices again to be sure. If another instance appears, uninstall it as well

    Now download and save the dell driver. Once saved, run it to redo the reinstall

    /* edit */
    don't recall if dell gives you the option to Run vs. Save, but my experience is always best (safest) to Save the driver download to a file. Then run the file. Of course, you can delete the download file once driver is installed
  15. malamute20

    malamute20 TS Rookie Topic Starter Posts: 17

    When I went to uninstall the drivers in device manager, there were 2 instances. Only one showed up with a yellow ! triangle, but I uninstalled both anyhow. Removing the one that DIDN'T have the yellow ! triangle returned this:

    error: handle

    But after that popped up, it was gone from the device list, so I am assuming the error was simply to indicate that it was already gone and the icon was just an artificial remnant. So, I went to the site, got the newest driver, tried to install it...... and when I did that, it asked if I wanted to completely uninstall it. That was strange, since I was under the impression it was already uninstalled. But I went with it; uninstalled, rebooted: the error message did not come up when I rebooted. So that's good.

    Very strangely, after the reboot, ST Micro Accelerometer is now showing up in the device manager list again. So, apparently the "UNinstaller" actually REinstalled it? That's my only point of confusion at this point. It had specifically said "this installer will now uninstall ST Micro Accelerometer and all components" prior to running.

    **EDIT: It is also showing up as the earlier driver version ( again, even though the one I downloaded and ran was the newest driver on the site.
  16. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    I'll add some comments below tho i guess the first bottom line questions:
    > Does everything seem to be working ok now?
    > If you re-run the PRoblem device report, is accel. now gone?

    You actaully had 2 accel. devices showing in your DevmgrView data before so i'm not surprised 2 showed up when you manually went looking. (That's why i also had you check Hidden devices as i wasn't sure just where that 2nd one would appear!)

    The Accel. is not a Windows plug and play (PnP) device. There's some oddities about how Windows handles some non-PnP device installations i don't fully understand so can't explain everything you describe and that you saw

    Tho looks like the Dell driver install package cleaned up the old install itself (which is good) before doing the reinstall this time. Don't know why you had problems last time

    Yes, certainly agree that's good! :grinthumb

    Then i dunno :confused: Maybe Dell has the driver version # wrong on their website??? :suspiciou In any case, if the message no longer appears and it's no longer a problem device i think whatever was corrupted before is at least now good! :)
  17. malamute20

    malamute20 TS Rookie Topic Starter Posts: 17

    Actually, no. I just booted it up to check MSInfo, and it is STILL trying to install a driver upon boot. Maybe it was too fast or I didn't notice last time -.-

    MSInfo no longer lists Accelerometer as a problem device, however, so we eliminated that particular issue. Apparently it was not the culprit =(
  18. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    whaaaat???? :confused: :suspiciou

    1. So when you run Problem Dev Report is this the ONLY problem device listed now?
    facap, FastAccess Video Capture ROOT\IMAGE\0000 This device is disabled.
    2. Post a copy of recent Windows Event Log entries. [post=936481]See here[/post]

    3. When the driver re-installs is it a single error message? Can you capture a screenshot of the error message that pops up so i can see the exact error message? (Hit Print Screen - or key might be labeled PrScrn or something similar, paste into MS Paint, save as JPG and attach to a post)

    /* EDIT */
    And pls generate a fresh copy of DevManView. thanks :)
  19. malamute20

    malamute20 TS Rookie Topic Starter Posts: 17

    1. Yes that is all that shows up under MSInfo problem devices.
    2. VEW came up with a blank sheet, no entries. I have screenshots of the process I'm uploading along with the other info. Labelled "VEW Screen 1 & 2"
    3. Yes. Screenshots taken on reboot while it tries to install and after install fails, this morning. Uploading now. Labelled "error screen 1 & 2"
    4. DevManView refresh incoming as well.

    Attached Files:

  20. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    AH-HA! Well, at least now i know why you first reported the problem might be your 1394 controller! Because that's your error message! ;)

    Looks like fixing your Accelerometer was a freebie! :D

    Now back to your 1394 controller (1394 is also referred to as "firewire")...

    I don't think windows is detecting the hardware anymore when the machine boots. Check your BIOS options. Could the 1394/firewire controller be disabled in BIOS?

    I'm also going to guess the 1394 controller's not displayed when you look in Device Manager. The 1394 controller IS a Plug and Play device. By default, DevMgr only displays PnP devices that are present and detected.

    btw.. If you;re curious to find out...(as well as perhaps learn another Windows "trick")
    The 1394 device will probably appear when you look in DevMgr if you enable display of non-present devices (also called "Ghost Devices" - as Ghost device icons are semi-transparent in DevMgr)

    To view ghosts, see here: http://articles.techrepublic.com.com/5100-10878_11-6176798.html. Link is about XP but same is true for Vista and Windows 7. Set the Environment variable to view non-present devices then open DevMgr and View->Show Hidden
    /* EDIT */
    btw.. don't know why VEW output should be blank.. but i don't need that info for the moment so we won't look into that for now
  21. malamute20

    malamute20 TS Rookie Topic Starter Posts: 17

    It's showing up in Device Manager (without enabling ghost or hidden views). See the attached SS.

    I haven't gone into the BIOS yet, but the only changes I made to the BIOS were two months ago when I got it from the factory, to verify the service tag and check the OC/turbo settings, get the HDD serial number, etc. I'll check it now to make sure that the firewire port settings weren't changed, but I'm the only user, and I haven't checked the BIOS since I flashed it with the updated driver way back then.

    **EDIT: It is enabled in the BIOS. I didn't make any changes.

    As per your last post, I'm not sure what all info you needed me to grab, aside from checking whether it was showing up in Device Manager and/or the BIOS. Did I miss anything?

    Attached Files:

  22. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Nope, you did good :)

    Your DevManView data showed the JMicron 1394 controller as Connected=No so i guessed its hardware not detected but your DevMgr snapshot clearly shows otherwise. Hmmm.. :confused:

    So i would do the following
    > Still check BIOS (even tho it should be enabled since it shows up in your DevMgr)
    > Then i would go to Dell website to reinstall the chipset drivers. Reboot
    > If problem still exists, check for any 1394 driver downloads as well to install

    /* EDIT */
    I just looked at the Dell site. And they do list JMicron 1394 drivers. So do try reinstalling the them as well
  23. malamute20

    malamute20 TS Rookie Topic Starter Posts: 17

    Okay, I reinstalled the chipset and firewire drivers. Both were a clean boot before start, and a reboot after finish. I still get that annoying little pop up when the laptop boots, nothing changed.

    Both installations showed successful on completion, no errors appeared except that little popup after the PC boots saying "driver installation failed."
  24. malamute20

    malamute20 TS Rookie Topic Starter Posts: 17

    I just uncovered a bit more info looking at the "action center" details which I had to root around a bit to find as they don't pop up for easy access when the error appears:

    Driver Management concluded the process to install driver FileRepository\johci.inf_amd64_neutral_b4debe9d56148fa5\johci.inf for Device Instance ID PCI\VEN_197B&DEV_2380&SUBSYS_04651028&REV_30\4&27026504&0&00E4 with the following status: 0x436.

    This helps me not at all, however, as I can't decode the message. :(
  25. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Your 1394 controller problem is quite a puzzle! Not the least of which is the fact that
    1) You're getting driver installation failed errors for the 1394 controller YET
    2) I see from your snapshot, the 1394 controller appears in Device Manager without any error icons AND it's not listed as a Problem Device

    Which makes me wonder if the driver installer that's failing is the result of a driver installation program configured to run when Windows bootsup (vs. being a driver install invoked by the Windows Device manager itself. Could be a reason device manager, itself, isn't complaining by showing any error icons)

    Try this quick experiment first. Disable the 1394 controller in Device Manager and reboot a couple times. Do you still see the installation failed error even when the controller has been disabled???

    /* EDIT */
    Uggh. I googled the most recent error message you posted. I don't know what error status 0x436 indicates :(

    Try disabling the device tho per above. Is easy and at least let's see what happens.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...