Tech Stocking Stuffers: 18 awesome gifts under $50

Xbox 360 can't connect through belkin FSD8635-4 v1

By technoheckno ยท 4 replies
Jun 15, 2009
  1. Hi,
    I don't know whether to ask this here or in the storage and networking forum, but it goes like this. As my old router seemed to be getting a bit shaky, I got a new router on Saturday based on it getting good reviews in a PC magazine. It seemed to set up OK and I thought I had no problems apart from those I'd expect from networking computers with different OS, all the computers can connect to the internet and those I want to see each other seem to be able to do so. Then I tried to connect the Xbox360, but using either wireless or hardwired connection, when I test the connection it seems it can access the internet but can't connect to Xbox Live. I tried updating the firmware to the latest version, opening all the ports that are advised, and putting the Xbox in DMZ but nothing works. Reverting to the old router it connects to Xbox Live no problem but as it's unreliable reverting to it on a permanent basis is not an option.
    Anyone got any ideas? I've tried to get in touch with the technical support at Belkin, but no joy so far.
  2. sw123

    sw123 TS Rookie Posts: 595

    Did you set up your router correctly?
  3. technoheckno

    technoheckno TS Rookie Topic Starter

    Yes - as the instructions detailed.
  4. technoheckno

    technoheckno TS Rookie Topic Starter

    I followed the guide several times, but despite the fact that the router seemed to update and accept the settings I was entering it didn't seem to work. However after numerous resets, restarts, and a lot of delving it works now. Just in case anyone has a similar problem and looks here this is how it went.

    1. The router sometimes doesn't seem to update with the info that is entered so I've had to reset it back to factory settings and reinstall a few times before it worked.
    2. log into the router home page at you've altered the ip)
    3. On the system settings page - Disable UPNP
    4. On the DHCP Client list page - Reserve an IP address for the Xbox360's MAC address
    5. On the Virtual Servers Page Open these ports(i.e. put the port number in both left hand columns and the ip address that was reserved for the Xbox360 in the ip address column):
    * TCP 80
    * UDP 88
    * UDP 3074
    * TCP 3074
    * UDP 3330
    * UDP 53
    * TCP 53
    Probably need to restart the router after doing this.
    Mine works now anyway - just need to get the XP laptop and the printer to connect wirelessly and to see the vista pc. By the time this kit is obsolete I should have it figured :)
  5. technoheckno

    technoheckno TS Rookie Topic Starter

    I reinstalled the firmware update. Reset to factory settings. re-entered the ISP settings and now the Xbox360 connects without disabling Upnp and doing all the Virtual Server stuff.
    As I'd tried that before doing all the Virtual server stuff I'm baffled - but it works.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...