XP pro freeze at boot screen, transferred HDD from old laptop

By beastice9 ยท 23 replies
May 8, 2008
  1. I had an Acer TravelMate 4220 WLMi. Core 2 Duo. The motherboard is fried after the fourth time I resoldered the DC connector back on but nevermind that.

    I acquired a HP compaq nx9010. Pentium 4, for cheap from a friend because the HDD went bad in it. So I replaced it with my own. My HDD is a 2.5 inch Hitachi TravelStar 120GB IDE ATA-7 (NTFS). The HDD I replaced looks to be exactly the same.

    but when I boot up I'm taken to the "Windows failed to start successfully, blah blah this may be due to recent hardware changes blah blah." I can't boot normally. it freezes as soon as I hit enter. and if I try safe mode it freezes after loading AGPCPQ.SYS.

    I don't have an XP CD from my old Acer but my friend included the HP's discs and it has an XP cd so booted into the recovery console and I've got CHKDSK /R running right now.

    I've been reading this topic: techspot.com/vb/topic21511.html

    but all I can tell is that this seems to be a very specific issue and has a different resolution for everyone so I'm hoping that by posting my specific situation that a solution can be found.

    EDIT: I forgot to mention that I never had a single problem with the HDD in the Acer. so I'm not really sure why I'm still running chkdsk, just for good measure I guess.

    but I'm starting to believe the problem is with ACPI. The HP laptop could / probably does, have different power management settings than my Acer? I still have no idea what to do though.
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Run a Windows Repair using the HP Discs (if they allow a Windows Repair)

    This page describes how the Repair works normally: http://www.windowsxphome.windowsreinstall.com/installxpcdrepair/part3.htm

    Basically you have changed Motherboard chipsets, so therefore you must either run a Repair or clean install of Windows (using the product key of the HP restore discs)

    Otherwise you need to track down that XP CD of yours, and your original product key.
  3. beastice9

    beastice9 TS Rookie Topic Starter

    I did the repair install. it no longer goes to the boot screen but to the windows loading screen and freezes after a minute or so. I tried booting in safe mode and it still freezes after AGPCPQ.SYS and eventually restarts.
  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    That was quick!

    AGPCPQ.SYS: cpu to agp controller driver

    Check in CMOS for "Intel SpeedStep" and disable it
    Also check Power Management AHCI and change it to ATI
    Or possibly do a Bios update

    If you can get to Safe Mode:
    In device manager- update driver of computer/ACPI-uniprocessor

    Also read this:
  5. beastice9

    beastice9 TS Rookie Topic Starter

    I replaced Kernell32.dll from the XP disc.

    I created a boot disc with the latest BIOS for the notebook from here: h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=321957&prodSeriesId=321850&prodNameId=321852&swEnvOID=1093&swLang=8&mode=2&taskId=135&swItem=ob-31521-1

    and flashed them.

    I can't get to SafeMode.

    There are no Intel SpeedStep or Power Management AHCI settings in the BIOS Setup. I looked under every tab.
  6. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Wow quicker than me, with all that.

    By the way, do you actually want to save any data on it?

    ie. you could do a clean install
  7. beastice9

    beastice9 TS Rookie Topic Starter

    haha YES. That harddrive has my life on it. I have an external case for it on the way, bought it before I got the "new" laptop, just hasn't shipped yet.
  8. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Resolved :)

  9. beastice9

    beastice9 TS Rookie Topic Starter

    I suppose. but there's no way to boot to USB is there? I'd prefer to get it working within this laptop because I'm tired of using this slow desktop all the time.

    Whatever you do, don't replace hal.dll with one from the XP CD unless you want a flickered blue screen and then restart instead of the windows loading screen. I backed up the old one, no worries. I just thought I'd try it since a few things I've read elsewhere suggest that the problem lies with the driver that gets loaded after APGCPQ.DLL.
  10. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    ok then, actually I'm the same, I wouldn't give up ever actually.

    Go back to CMOS, turn everything off (disabled) everywhere! (except harddrive ofcourse!)

    Try safe mode again

    Otherwise do a repair, with everything disabled in CMOS
  11. beastice9

    beastice9 TS Rookie Topic Starter

    this laptop has Pheonix BIOS and the only thing I can find to turn off is Legacy USB Support.

    I'm going to edit boot.ini to disable the splash screen and save a bootlog.

    EDIT: nevermind, my plan was to copy boot.ini to floppy but the recovery console doesn't allow you to copy to removable media. Now I need a way to edit/read files from within the recovery console.
  12. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Like edit do you mean?
    Edit exists in the recovery console
  13. beastice9

    beastice9 TS Rookie Topic Starter

    I read about bootcfg but I didn't like it so now I'm going to edit boot.ini using this method: http://support.microsoft.com/kb/243067

    and then use that same method to retrieve a bootlog.
  14. beastice9

    beastice9 TS Rookie Topic Starter

    I've edited boot.ini to include /noguiboot /sos /bootlog but it doesn't appear to be saving a bootlog in C:\WINDOWS\ntbtlog.txt

    EDIT: I added the line: multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Safe mode with bootlog" /safeboot:minimal /bootlog to boot.ini and now when I choose that option I get the error message Windows could not start because hal.dll is missing or corrupt.

    also after choosing the normal safe mode option, it now still stops after apgcpq.dll but the HDD stays active and then displays a BSOD before restarting.

    I need a way to disable auto reboot from the recovery console?
  15. beastice9

    beastice9 TS Rookie Topic Starter

    I'm guessing this was my hal.dll problem: http://support.microsoft.com/kb/314477 . Edited boot.ini again to fix it so no more corrupt/missing hal.dll error for "safemmode with bootlog."

    but normal safemode BSOD is not gone and still freezes during normal boot. How can I edit the registry through the recovery console?

    Using my "safe mode with bootlog" it successfully loaded safemode but I then got a popup error message "setup cannot run under safemode, setup will restart now."

  16. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Normally you get Safe mode (gui) working first

    In the link you supplied
    Also thanks for the continual feedback between my visits!


    There was a really good guide someone posted on this, and I can't find it!
    It was either by Raybay or Jobeard, but there's too many posts to search through.
    And sometimes TechSpot slows right down to a crawl for me, very annoying.
  17. beastice9

    beastice9 TS Rookie Topic Starter

    I'm convinced this is being caused by the ACPI mode.

    I assumed ntbtlog.txt wasn't being written but after accidentally forgetting to type the destination of my floppy in my batch command I discovered that is was very long haha, and I was only getting the first page batched.

    Now that I have a successful bootlog, I have discovered that the next driver that fails to load after agpcpq.dll is ACPI Multiprocessor PC. The Hal type ACPI Multiprocessor would be for the dual core. I believe I need to change it to ACPI Uniprocessor.

    Many of the ppl having the same problem as me report creating virtual PCs and ghost images, they have no chipset, where as I changed chipsets (Core 2 Duo to Pentium 4)

    I think if I can change the ACPI mode / HAL type, then it may work? any idea how to do this? What mode would a Pentium 4 use?

    I've been reading these three things and might try the included suggestions:


    EDIT: Yes. after reading this:

    "One of the biggest problems with ghosting dissimilar machines is when they require different Hardware Abstraction Layers (HALs). For instance, an older Pentium 4 machine will use the Uniprocessor HAL, while a newer Pentium 4 machine likely has a hyperthreading processor or even a Pentium D Dual-Core Processor, both of which qualify for the Multiprocessor HAL..

    Switching between Uniprocessor/Multiprocessor HALs is only possible if BOTH machines will be using the ACPI version of the HAL, OR if they are BOTH using the non-ACPI version of the HAL."
  18. beastice9

    beastice9 TS Rookie Topic Starter

    I'm going to try doing another repair install but this time forcing the HAL type as this article describes: http://support.microsoft.com/kb/299340

    EDIT: Still freezing after AGPCPQ although it no longer complains about ACPI.

    Here is a list of the drivers that failed to load.

    Audio Codecs
    Legacy Audio Drivers
    Media Control Devices
    Legacy Video Capture Devices
    Video Codecs
    WAN Miniport <L2TP>
    WAN Miniport <IP>
    WAN Miniport <PPPOE>
    WAN Miniport <PPTP>
    Packet Scheduler Miniport
    Direct Parallel
    Microsoft AC Adapter
    Microsoft ACPI -Compliant Control Method Battery

    EDIT: also..

  19. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Yes, I use Ghost all the time, and fully aware of this issue.

    In all cases (hundreds of Ghost images) I have successfully restored on a different CPU chipset (just to be brief) and then Repaired Windows before it loads for the first time.

    If Windows is allowed to load, from a Ghost image made from another chipset, it will usually corrupt either the data or system files. Therefore Repair is done immediately. (before startup)

    Regarding the missing drivers
    This may be due to the above (here we go, another Restore, then another Repair by you!) or it may be because CMOS has those devices turned off (please confirm)
  20. maxglover1989

    maxglover1989 TS Rookie Posts: 53

    have you got an external hardrive case for 2'5 if you have stick your hdd in there and copy everything off of it and then do a clean install of xp, i had the same problem and that was the only solution that i found worked.
  21. beastice9

    beastice9 TS Rookie Topic Starter

    I have one coming in the mail. I'm afraid that's what I might have to do but until it gets here I'm going to try everything I can.

    listsvc displays most of those sys files set as service_system_start so they're not disabled. I've yet to check if they all exist but I could not find lbrtfdc.sys in the system32/drivers folder.

    I'm trying to do another repair install forcing HAL type ACPI Uni but that causes freezing when Windows Setup says "Setup is starting Windows" at the bottom. I don't hear or see any HDD or CDROM activity going on.

    EDIT: the following seem to be missing:


    and when I try to disable them, after I boot once and check the log it still says failed to load so I did listsvc again and it showed them as not disabled. Why would it not save those settings?
  22. beastice9

    beastice9 TS Rookie Topic Starter

    I did another repair install. Didn't force any particular HAL type. booted into recovery console. expanded halacpi.dll and ntoskrnl.exe from XP CD to windows\system32.

    and put this option in boot.ini:

    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="hal ACPI" /HAL=halacpi.dll /kernel=ntoskrnl.exe /noexecute=optin /fastdetect /noguiboot /sos /bootlog


    setup will complete in approximately: 34 minutes


    EDIT: Files Needed dialogue just appeared. "The file 'kuser.dll' on windows driver cabinet is needed. Type the path where the file is located, and then click OK." the default path given is "C:\i386" I clicked ok and nothing happened so I clicked cancel,

    it went for a little longer and now it popped up a Copy Error dialogue. "Setup cannot copy the file irda.sys. Ensure that the location specified below is correct, or change it and insert '(Unkown)' in the drive you specify." Path given is same as before. Hit ok did nothing so I tried cancel again, then it said do you want to continue without copying this file, clicked yes.

    now I got another copy error for the following:

    EDIT2: Rest of setup finished smoothly. it rebooted. Chose my same boot option. loaded drivers pausing at the usual agpcpq but hdd activity kept going and now its showing the splash screen except no loading bar it just says Please wait... and I have a pointer, mouse works, but it doesn't seem like its doing anything now.

    normal safemode still BSOD's but this boot setup loaded:

    multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Safe mode with bootlog" /safeboot:minimal /noguiboot /sos /bootlog

    and I'm logged in. Any suggestions what to do from there? Right now I plan on disabling auto reboot so I can read that BSOD.

    EDIT3: The BSOD that occurs when booting normal safe mode reads problem detected windows shut down to prevent damage


    EDIT4: booted up normally again. got logged in. working great!

    I discovered another problem was the main boot setup listed a kernel flag as "kernel1.dll"

    but now I'm afraid to update to SP2. I had it and then my recovery discs were SP1.

    Also why would it take several minutes for the control panel System options to open? I even tried run --> control sysdm.cpl

    maybe I'm just not used to having only 512MB ram. ughhhh
  23. beastice9

    beastice9 TS Rookie Topic Starter

    The problem now isn't that it takes awhile for the System control panel to open, the computer just won't do almost anything until several add new hardware dialogues popup? I have no idea what causes this to happen but it still hasn't popped up and until it does I can't go to the network connects settings system control panel, add/remove programs list never populates. and if I try to click add hardware it says "you can install only one device at a time. another device installation is underway"
  24. beastice9

    beastice9 TS Rookie Topic Starter

    The new hardware detected bubbles pop up for:

    Microsoft Kernel DLS Synthesizer
    Modem Audio Device
    Multimedia Audio Controller
    ALi Fast Infrared Controller
    Conexant AC-Link Audio

    In device manager, except for that last one (it doesn't show up, possibly the unknown device that has an error), they all have drivers that need to be reinstalled. Would these be on my XP disc or the HP driver recovery CD that came with the laptop because I already ran that?

    these alerts are followed by File Needed alerts for:

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...