XP x64 BSOD Writing to Mapped Drive?

Status
Not open for further replies.
XP x64 BSOD Writing to Mapped Drive? [SOLVED]

I've been tracking this problem down for months on end but can't seem to find a cause, let alone a resolution.

I'm running XP x64 on a 2-processor Dell Workstation with a few mapped drives. I've been getting lots of blue screens, often in clumps. I'll get 2 one Tuesday, be fine for a week, and then get 6 the next Tuesday.

The minidump files include a bunch of different bug check strings and codes and a variety of "caused by" drivers. The bug check codes include 0x1000007E, 0xC2, 0x9C, 0x50, 0x3B, and others. I've attached a .zip of the last 10 minidumps. By far, the most common "caused by" is ntoskrnl.exe.

The recurring theme about these crashes is that they all seem to happen when I'm writing files to a mapped drive. It's hardly deterministic too. I wrote a batch script that writes a small text file to any one of my network drives, sleeps for a half second, and does it again. Sometimes, the script will write 100 times before crashing. Sometimes, it get through 8 iterations. I should point out that this is caused by any network drive, and it makes no difference whether or not the server is running Linux or Windows.

I've tried replacing the network card in the PC, thinking perhaps there was something funky going on there, to no avail. I've also done multi-day passes (Friday evening to Monday morning a few times) with Memtest86 with no errors.

Is there anyone out there who can give me some further insight? Appreciated.
 

Attachments

Route44

Posts: 12,015   +81
I read the minidumps in your first Zip file. Two were unreadable due to corruption. The other three are helpful in finding a cause for your issues.

One error is 0x0000007E: SYSTEM_THREAD_EXCEPTION_NOT_HANDLED
A system thread generated an exception which the error handler did not catch. There are numerous individual causes for this problem, including hardware incompatibility, a faulty device driver or system service, or some software issues.

The other two errors are 0x000000C2: BAD_POOL_CALLER
A kernel-mode process or driver incorrectly attempted to perform memory operations. Typically, a faulty driver or buggy software causes this.

All three cite the same driver as causing your issues: Prot6Flt.sys. It took some digging to find out what it is because there is almost nothing online concerning this driver but it belongs to your Panda security software.
 
  • Thread Starter Thread Starter
  • #3
That's good news! I'll have to try to re-install and see if that solves my issue. How did you find out that Prot6Flt.sys was the root cause? I've been using BlueScreenView but find no mention of that driver anywhere.

Strange about the corruption... those files read fine on my PC.

Thanks a ton.
 

Route44

Posts: 12,015   +81
Many of us who read Blue Screens use Microsoft's WinDebugger tool and their Symbol Packages.

As for the corruption the issue was between your files and the WinDebugger.
 
  • Thread Starter Thread Starter
  • #5
Thanks for the insight... now I should be able to solve these problems myself. I've uninstalled Panda and upgraded to a different version and everything is golden.

Thanks again.
 
Status
Not open for further replies.

Latest posts