XP3. My Book Essential Edition SLOW transfer speed

By guinnyss · 21 replies
Apr 14, 2009
  1. I have a Sony Vaio PCV-RS520 and it comes standard with 8 USB 2.0 ports. I bought a Western Digital My Book Essential Edition 1 TB around november 2008 and it worked great including transfer speed. i recently reboot my PC to manufacture status and upgrade back to Microsoft SP3 and now my External HDD transfer rate it slow from all 8 ports. When i connect the USB im now getting a message that "This USB device can perform faster if you connect it to a High Speed USB 2.0 Port".

    #1. The device MGR shows no ENHANCED controllers. I have uninstalled and reinstalled them, to no avail.

    #2. I have checked the BIOS settings and any mention of USB is NON EXISTENT.

    #3. I have tried to update the drivers but, have no windows XP disc but, DO have the Sony recovery DVD and dont know if I can pull a driver from it?

    EDIT: the External HDD work on other PC.
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

  3. guinnyss

    guinnyss TS Rookie Topic Starter

    i already went to the esupport site. got the lastest BIOS etc. but the problem is still there. And the back ports i get the same issues.
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Determine if the USB 2.0 device controller is even running

    Open Device Manager, look under the USB devices. Find the USB controllers (usually 3-4 different controller entries). Important point being ONE of them should include the word "Enhanced" controller. If the word Enhanced doesn't appear on any, then you don't have a 2.0 USB installed. (Which means all your ports are running as USB 1.1)
  5. guinnyss

    guinnyss TS Rookie Topic Starter

    all it's showing for all 4 ports are Intel (R) 82801EB USB Universal Host Controller 24D2,24D4,24D7 AND 24DE. I dont have any Enhance. How do i install the Enhance/USB 2.0 ports?
  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    OOps. just noticed you had mentioned the "Enhanced" issue in your first post...

    To be specific, do you try to re-install the motherboard chipset drivers from the web site (boy, tho i see they're all pretty old drivers on the site)
  7. guinnyss

    guinnyss TS Rookie Topic Starter

    In device manager, i changed from ACPI (something like that) to Standard Pc, then reboot and everything got reinstall the same way it was before.

    If i choose update, then advance, then uncheck "show compatible device" i see allot of Enhance USB 2.0 controllers. But if i install any one of them i get the (!)
  8. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    In Device Manager?? Or you mean (it sounds like you mean and could be the source of the problem, if the case) that you changed the BIOS settings??
  9. guinnyss

    guinnyss TS Rookie Topic Starter

    Yeah in Device Manager under +Computer i changed ACPI to Standard PC hoping that would fix my problem.

    Any idea how to get the 2.0 USB installed?
  10. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    I'm sorry but i'm missing something. Please explain the steps you used to change from ACPI PC to Standard Computer using Device manager :confused:
  11. guinnyss

    guinnyss TS Rookie Topic Starter

    I went in to Device Manager---->+Computer---->ACPI, right click and choose update drive----> Yes, this time only----> Install from a list or specific loaction (advance)---->dont' search, i will choose the driver to install------> here i choose "Standard PC" then roboot the pc.
  12. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    oh! well

    1) Thanks for teaching me something new (didn't realize you could switch ACPI to Standard PC via Device Manager as opposed to in the BIOS)

    2) Why did you switch to Standard PC?
    Understand i'm not expert on the the topic of ACPI but it's been my understanding you need an ACPI-compliant computer in XP (as reflected under Computer in Device Manager) in Device Manager to
    => Allow for Power Management functions to work
    => Provide full support for windows plug and play features and
    => Allow windows to work with your BIOS to configure / setup your computer

    I also don't recommend immediately switching back to ACPI (as i vaguely recall there can be issues when switching).
  13. guinnyss

    guinnyss TS Rookie Topic Starter

    i swtich because i read somewhere else that if you switch IRQ might change but for my case it didnt. So any good news on the USB issue?
  14. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Sorry, i don't have any specific details to help but you might want to check my recent post about usb issues. USB Device Problems? Check for Windows Updates you'll also find a link in it about USB 2.0 XP support.

    btw.. your description of seeing all those Enhanced controller drivers on your disk but they don't seem to get installed would imply (but i don't know all your facts or for certain) that for whatever reason, Windows doesn't think you have 2.0 capable hardware (so it doesn't install 2.0 Enhanced drivers)
  15. guinnyss

    guinnyss TS Rookie Topic Starter

    Well just to make sure it wasn't Windows XP that was messing with my USB. I went ahead and install Windows 7 on another partition for dual boot and Windows 7 shows the same problem with the USB.
  16. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Did you ever re-install the motherboard chip set drivers?
  17. guinnyss

    guinnyss TS Rookie Topic Starter

    to make sure ima do it right now. then ima edit with my response. in the mean time, can you check this link out. "http://support.microsoft.com/kb/312370" and i got the EHCI host controllers from this site "http://icrontic.com/forum/showthread.php?t=10999" but dont have a clue how to install it.

    EDIT: No luck with the Motherboard chip set drivers "Intel® 865PE Chipset Driver "

    EDIT: You know if this software is a good or any with the same features you recommend "Amidiag Suite 2.0"
  18. guinnyss

    guinnyss TS Rookie Topic Starter

    okay i fixed it. it was simple but you have to do it in oder or it wont work. uninstall all usb controllers, then install your LATEST chipset then restart your pc. DONT DO IT ANY OTHER WAY>>>>>NO OTHER WAY. This site coulnt help, 3 other sites couldnt help, sony esupport didnt know crap, WD agents didnt know crap, not even microsoft support (6 different agent didnt freaking help)
  19. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Chipset drivers must always be installed before any other drivers are installed on a new Windows installation

    It would seem that your chipset drivers were never originally installed, and therefore any other drivers (ie USB) may not have worked properly. (This confirmed by yourself in this process)

    Your "Intel® 865PE Chipset Driver" as noted via Post#2 of this thread, originally released: 10/06/2003, are not the latest drivers for XP or Vista (seeming Vista was not even thought of back then)

    Here is the most up to date "Intel® 865PE Chipset Driver" directly from Intel for your model: http://downloadcenter.intel.com/Product_Filter.aspx?ProductID=816

    Or you may download the most up to date "Intel® 865PE Chipset Driver" (for all Windows versions, ie XP and Vista) directly here: http://downloadmirror.intel.com/16026/a08/infinst_autol.zip

    Some things are assumed when you are installing the latest drivers:
    1. Windows is installed with latest Service Pack (or Minimum XP SP2 or Vista SP1)
    2. All the latest drivers are installed ie Post#2
    3. Chipset drivers were also installed (this driver should always be installed first)

    Why didn't I mention No. 3 above in Post#2 ? Because your driver came out in 2003, and I thought that this must have been installed by now :rolleyes:

    Next time you do a fresh install of Windows, make sure to also let others know, ideally in Post#1

    Also, as we (and other sites it seems) have been all trying to help you for free. Next time say thanks ;) (even if it didn't help) Instead of stating your crap (using your words with poor spelling to top it off) Every support member knows to install Chipset drivers first, after a clean install

    Have a nice day
  20. guinnyss

    guinnyss TS Rookie Topic Starter

    well i did install the lastest chipset, microsoft updates but the problem for my PC rely on which order i did it. Like i said, i uninstall the usb controllers then install the latest chipset then reboot and my baby got installed :)

    and i am thankful for lookinaround and everyone that try to help, but i was just stating the fact that no one had the proper fix. i actually found the fix on another sites but the person problem was different, something about there usb not picking up there external device with enhance controller showing (!) exclamation mark, i was desperate so i tried it anyway LOL and it worked. it was all in the right order. thanks n lata
  21. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Hi guinnyss

    Thanks for posting and letting us know how it all finally worked out. (And I'm glad it did finally all work out for you!) :) Thanks as well for noting the specific order of "to-do's" you found necessary to get your problem resolved.

    I've been working on updating my USB Troubleshooting Guide posted in Tech Spot and will be certain to note that the order of things you tried was one of the keys to success in your case. :grinthumb

    Hope you have error-free computing for a good long while.. :approve: but should you have a problem again, I also hope you come back to ask the questions... Or for that matter, just hang-out here till then, read through the forums and help answer some of the many user questions yourself. Sounds like you're getting plenty of your own "real-world" experience as well! :D
  22. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    I did it again didn't I LookinAround, I came across too harsh :(
    Anyway thanks for possibly neutralizing that with your excellent words

    Thanks to guinnyss as well for taking the time to come back to let us (and others) know the outcome :grinthumb
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...