1 GB Iomega USB 2.0 HDD errors

By baly2u2000 · 8 replies
Dec 7, 2009
  1. Hi All,

    I desperately need ask for your help to solve my problems with an Iomega external HDD. As it is right now I cannot use my brave new storage because it simple does not work the way it is supposed to.
    I hope we can remedy this problem..

    I've recently purchased an 1TB Iomega Select Desktop Hard Drive (PC/Mac) that connects with an USB 2.0 port to my laptop. I have formatted the drive to NTFS.

    I have the following issues with the drive:

    A, When I'm using the drive under Windows XP SP3, I encounter with the following problems:
    I. If I'm downloading several files with torrent (filesize <= 50MB) and the download destination is the Iomega storage, and the download speed is around 2-3 Megabytes / sec, after a some minutes (not more than 30 minutes), Windows XP pops up the following Delayed Write error message:

    "Delayed Write Failed : Windows was unable to save all the data for the file [name_of_the_file_you_want_to_save].
    The data has been lost. This error may be caused by a failure of your computer hardware or network connection. Please try to save this file elsewhere."

    Furthermore, I cannot access the drive anymore after the error message. The drive seems to be recognized but the folders seem to be empty. If I restart the PC, Windows does not recognize the drive connected.
    The drive is recognized again if I disconnect and reconnect the power supply of the Iomega drive.

    - I have tried disabling caching (Windows setting for optimal performance) and delayed disk write (torrent client setting) but no use. The error still persists.
    - I have tried using another USB cable but did not make any difference, I still get the error message.
    - I have tried all 3 of the USB ports available on my laptop. No use.
    - I have connected the drive to an USB Hub (DLink 4-Port Hi-Speed USB Hub but that does not make any difference either.

    II. If I'm extracting large (6GB+) files (e.g with total commander) on the Iomega Drive I get a "Read Error" message and the may fail. The rest of the error symptoms are the same as described above. This error occurs 2 or 3 times from 5 tries.

    Copying large files from the Iomega drive to my laptop's HDD works fine without error.

    B, When I'm using the drive under Windows 7 (x86) , I encounter with the following problems:

    I. If I'm downloading several files with torrent (filesize <= 50MB) and the download destination is the Iomega storage, and the download speed is around 2-3 Megabytes / sec, after a some minutes (usually not more than 30 minutes), Windows hangs. The mouse pointer freezes and I cannot do anything with the Operating System, so I have to hard reset the computer.
    The Iomega drive is not recognized afterwards and I must replug the power cable (just as with A/1) to get the drive recognized again.
    Windows 7 does not always hang up in case of downloading through torrent to the Iomega Drive.

    I've just seen another kind of error symptom which did not freeze my Operating System , however the drive was unaccessible afterwards:
    - "Error: The system cannot find the file specified" error message from utorrent client during download. In this case Windows can see the folders and SOME of my files on the drive but most of the folders are empty, even those which have nothing to do with the torrent (e.g. my documents folder.)
    The drive cannot be written, "scandisk-ed", or unmounted, files cannot be accessed or transferred (not even those visible.) So the files seem to be there but actually they aren't.
    After pulling out and plugging back the power cord of the storage , Windows recognizes the drive and I can access my files.
    The torrent download cannot be resumed, not even after a windows restart + storage drive power replug. It says at the hash check that "The system cannot find the file specified." This may happen with completed downloads as well , which I have been seeding for hours.

    II. Same as described under A/2.

    I'm using a Fujitsu (Siemens) Amilo L7320gw laptop. Its specs are as follows:
    Processor Manufacturer: Intel
    Processor Type: Celeron M
    Processor Speed: 1.7 GHz
    Chipset: VIA VN800
    Bus Speed: 400 MHz
    Installed RAM: 1024 MB
    RAM Technology: DDR2 SDRAM
    RAM Speed: 533 MHz
    HDD Storage Controller Type: IDE (PATA)
    Expansion Ports: 3 x USB 2.0, VGA out, RJ-11 (modem), RJ-45

    Please help me to solve this before I go crazy! :)

    Please tell me what to check if further investigation is necessary for giving an advice.

    Thanks in advance for every helpful word.
  2. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +422

    Typically I would guess that the drive isn't getting enough power, but since it is a 1TB drive (and there currently aren't any laptop drives that size) that it is a regular full size external with its own power supply.

    So given that, I would download SeaTools for Windows and run the short and long DST on it and see if it passes. You've tried the Windows settings I would have also suggested.
  3. baly2u2000

    baly2u2000 TS Rookie Topic Starter

    Correct. That is a full size drive with own power supply.
    I've downloaded the tool you recomended, I'll check back with the result.

    Addition to the above stated symptoms:

    On my Fujistu Siemens Amilo L7320GW notebook, currently running Windows 7:
    - Legacy support is Enabled in BIOS
    - The drive is configured for quick removal, no caching
    - In device manager I've disabled the power off option for all USB Hubs
    - Write cache is disabled in utorrent

    The drive is showing the disconnect symptoms more often (or I'm just getting more anxious)

    I write it in the order of events..

    1. Downloaded about 60 GB to the drive without the error symptoms and started seeding. I've moved about 200GB of my data to the drive (I don't know why i thought it would work.)
    2. The drive hung up during the copy but did not freeze the OS.
    3. I've disconnected and then reconnected the drive's power supply.
    4. The drive is now freezing when I'm copying data from it. No write operation is made in the mean time.
    5. I've tried to run a chkdsk /R on the drive but it stopped at 10% of Stage 4 of 5 (Verifying file data).
    6. I decided to lose the 200+ GB data and tried to format the drive. It hung up..
    7. I've removed the drive and connected it to another laptop (HP Compaq 6710b).
    8. The HP laptop recognized the drive as an unformatted drive and I formatted it.

    9. I'm going to check it with chkdsk on this laptop and with the program you recommended.

    It's strange that I could format it on the HP and could not on the Fujitsu.
  4. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +422

    It very well could be that the drive itself is bad, SeaTools should be able to tell you if its bad. Drives can be bad and still pass, but thats pretty rare..
  5. baly2u2000

    baly2u2000 TS Rookie Topic Starter

    I've completed the drive check. Iused the HP Compaq 6710b notebook that i also used for formatting the drive.
    SeaTools for Windows results:
    Short Generic - Pass
    Long Drive Self Test - Pass

    Read and Write operations seems to work fine on this laptop.
    The next step will be to attach the drive to the Fujitsu (where it caused problems) and see what it does on it.
  6. baly2u2000

    baly2u2000 TS Rookie Topic Starter

    The drive has passed the Seagate tests and now I'm checking the drive on the Fujitsu notebook.

    Additional checks made:
    I've checked the USB controllers in device manager.
    I see here:
    - 3 USB Hubs,
    - 2 VIA rev 5 or later USB Universal Host Controller
    - 1 VIA USB Enhanced Host Controller

    Is that possible that not all my USB ports can handle this drive appropriately as an USB 2.0 drive? I mean, is 1 enhanced Host controller enough for serving 3 usb ports if there are other devices attached as well?

    I've tried so many things by not that I became suspicious that I might have not tried all the USB ports(there were other devices connected too and I'm unsure whether I've checked those ports too.)
    So i decided to make sure I'll check all USB ports this time.

    Today's events:
    Today I've connected the empty drive to my Fujitsu laptop, to a (supposedly) different USB port, without my external powered USB Hub and without any other USB device (mouse, keyboard, dvd) and tested it for 30 minutes. The drive seemed to work OK.

    PORT 2:
    I've removed the drive, attached it to the USB Hub and put connected the hub to the port used in my early tries (the supposedly bad one.)
    Besides the Iomega Drive, there was a mouse , a keyboard and an external DVD drive connected to the HUB as well. All devices were recognized by Windows properly. It did not take more than 30 minutes to reproduce the problem (read and write errors.)
    Reboot and HDD power supply replug was required to proceed.

    I've plugged the Hub to the third USB Port with the above listed devices.
    All devices were recognized, the Iomega drive halted the OS in 30 minutes. Reboot and HDD power supply replug was required to proceed.

    USB PORT 1, Second run:
    I've plugged the Hub to the third USB Port with the above listed devices.
    The mouse is not recognized, the keyboard and the DVD works OK and now I'm going to test the Iomega drive now for 30 minutes to see what happens.
    The first thing I noticed at first glimpse is that copy speed is slower than in any previous case and the speed jumps up and down (I'm copying a single large file.) Slower means max 12000 kbytes and about 8000 kbytes per sec in average, while these values were around 20.000 with the other USB ports.

    I'll check back with the results.

    Thanks for the help!
  7. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    I haven't gone through all the detail you've offered in your posts wrt to your specific situation/setup but here's some general info that can help when that error message occurs

    First, see [post=753513]How to Avoid Problems with USB Storage Devices[/post]. In particular
    > Try setting the disk policy to Optimize for Removal (i.e. Disable write caching) and
    > Don't allow Windows to turn off the device to conserve power

    Also see You receive an error message when you save or move documents in Windows XP: "Delayed Write Failed"
    While this KB addresses internal disks (vs. a USB disk) i think some suggestions may still apply. Including
    > Make sure that System Cache is not selected for memory usage
    > Increase the number of page table entries

    /* edit */
    Also, do you run Custom when you do Windows updates?? Make sure you do and you have all Hardware Optional updates installed. See [post=744411]USB Device Problems? Check for Windows Updates[/post]
  8. baly2u2000

    baly2u2000 TS Rookie Topic Starter

    Thanks for your reply.

    Already done: Caching is switched off, the drive is optimized for removal, In device manager I''ve set USB to give power constantly (does not turn off.)
    System cache is not applied.
    By page table entries did you mean the virtual memory page file?
  9. tovaritx

    tovaritx TS Rookie

    Same problem in Linux

    Hi all! (sorry for my bad English)

    I have the same problem, same disk but I use Linux (Fedora 12)

    The disk disconnect suddenly, some times the light of the disk go off... it is like the power is off!!! But in this cases I listen the HD plates how spins, stops and starts again. Then, the system recognize the disk again in another device port. That is, it is like if I turn off the hd without unmounting the disk and immediately after turn on.

    This is the log (Linux is great giving information):

    usb 1-6: reset high speed USB device using ehci_hcd and address 113
    usb 1-6: USB disconnect, address 113
    sd 13:0:0:0: Device offlined - not ready after error recovery
    sd 13:0:0:0: [sdb] Unhandled error code
    sd 13:0:0:0: [sdb] Result: hostbyte=DID_ABORT driverbyte=DRIVER_OK
    end_request: I/O error, dev sdb, sector 2044706879
    EXT3-fs error (device sdb1): ext3_find_entry: reading directory #63889409 offset 0
    Aborting journal on device sdb1.
    journal commit I/O error
    EXT3-fs error (device sdb1): ext3_find_entry: reading directory #33382401 offset 0
    usb 1-6: new high speed USB device using ehci_hcd and address 114
    usb 1-6: New USB device found, idVendor=059b, idProduct=0370
    usb 1-6: New USB device strings: Mfr=10, Product=11, SerialNumber=5
    usb 1-6: Product: External HD
    usb 1-6: Manufacturer: Iomega
    usb 1-6: SerialNumber: 911FFFFFFFFF
    usb 1-6: configuration #1 chosen from 1 choice
    scsi14 : SCSI emulation for USB Mass Storage devices
    usb-storage: device found at 114
    usb-storage: waiting for device to settle before scanning
    usb-storage: device scan complete
    scsi 14:0:0:0: Direct-Access ST315003 41AS PQ: 0 ANSI: 2 CCS
    sd 14:0:0:0: Attached scsi generic sg2 type 0
    sd 14:0:0:0: [sdc] 2930277168 512-byte logical blocks: (1.50 TB/1.36 TiB)
    sd 14:0:0:0: [sdc] Write Protect is off
    sd 14:0:0:0: [sdc] Mode Sense: 34 00 00 00
    sd 14:0:0:0: [sdc] Assuming drive cache: write through
    sd 14:0:0:0: [sdc] Assuming drive cache: write through
    sd 14:0:0:0: [sdc] Assuming drive cache: write through
    sd 14:0:0:0: [sdc] Attached SCSI disk

    My disk is under warranty (only 6 month). In the first 4 month never fails... I think Iomega 1Tb is a very bad disk...

    ¿Any suggestions?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...