1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

ACER, UEFI, No Boot Device network concerns

By PhilipMoore62 ยท 15 replies
Aug 30, 2015
Post New Reply
  1. When searching verifying the correct version for my BIOS update I ran into an insidious website that rather than providing me any type of info of a potential updat rather provided me with redirects, PUP's and all types of junk that was challenging to rid the computer of.
    After I found the correct version to update my BIOS I flashed the download and the BIOS is now updated correctly.

    I don't know exactly if the attack is still pestering my system or I may be dealing with something else Point being if this is in the wrong Forum category I apologize in advance.

    This is stats as to my Acer Aspire Es-711.

    The issue I'm having is that when I Configure the BIOS such that the computer will search for the Hard Drive (C:\) I get an obtrusive message stating that there is no bootable device found.
    This is using the UEIF and Hard drive configuration.
    I get this message directly after booting the machine in this configuration.
    This would lead one to think that there was an issue with the HDD and that one would follow that
    Rabbit hole (as I did ) for a resolution.

    What I learned in researching this is that when setting the BIOS to boot to the USB/CD/DVD The machine that happily takes me to a screen asking me to push the "any key" to load the Windows Program.
    My immediate thought when this first came up was it was absurd as the computer was not able to find the bootable device.

    To my surprise the machine not only loaded windows 7 Ultimate but I'm now currently typing this post using the computer in which it can't find the bootable device????

    Things I've tried:
    I read in a Post that if one was to remove the HDD from the computer unplug from MB many times just this action would change things for the computer to find the HDD.
    .I did that and still no joy finding the missing bootable device.

    After installing Windows I was then able to run (using the Administrator CMD prompt)
    Chkdsk /f C:\ In which was completed successfully indicating that all sectors were scanned and accounted for without signs of errors.

    I would truly appreciate whatever assistance available.

  2. Broni

    Broni Malware Annihilator Posts: 53,868   +370

    I'm moving this topic to appropriate forum.
  3. PhilipMoore62

    PhilipMoore62 TS Booster Topic Starter Posts: 316

    Is it possible that you could move it again to another forum that is actually being monitored:?
    Thank you.
  4. Broni

    Broni Malware Annihilator Posts: 53,868   +370

    What do you mean by monitored?
  5. PhilipMoore62

    PhilipMoore62 TS Booster Topic Starter Posts: 316

    I wrote my first post on this subject Last Sunday with you as the only reply.
    I'm assuming that's due to no one monitoring the forum in which I was placed..
    Today is Wednesday 9\02 with no contact made re: my issue. More than 36 hours has passed without contact.
  6. Broni

    Broni Malware Annihilator Posts: 53,868   +370

    There is not much I can do about it.
    People reply if they have something to say.
  7. B00kWyrm

    B00kWyrm TechSpot Paladin Posts: 1,436   +37

    1. You said you had dealt with malware.
    Are you certain you are now malware free?
    If so, how did you arrive at that certainty?

    2. Googling, I discover you are not alone (ACER, UEFI, No Boot Device).
    Have you tried...
    If secure boot is greyed out,
    1. temporarily set a supervisor password
    2. disable "secure boot"
    3. clear supervisor password.
    3. Changing the topic title may help get more attention...
    It looks like your issues developed because you downgraded from Win8 to Win7
    and/or because you got a sketchy file for flashing your bios.

    4. as far as I can discern, Acer Aspire Es-711 is not the same as EA70_BM.
    And, I am wondering if it should even be Acer Aspire Es1-711

    5. If your system is booting with USB etc as primary boot device,
    perhaps it is booting from the removable media?
    If so a repair install may be indicated.

    BTW... Never found full system specs, so...
    I still don't know if you have a stock system,
    or if you have modded, say with an SSD.
    I ask about ssd's, because some have firmware quirks.
    Since this seems to deal with the intricacies of UEFI,
    I will back away and let others more qualified step in
    if they feel they may have something to offer.
  8. PhilipMoore62

    PhilipMoore62 TS Booster Topic Starter Posts: 316

    Thank you so much for your reply.
    I ran an anti virus rescue disk on the hard drive removing all instances of found infestations.

    While the system was up and running on one of the rare occasions I was able to run Eset online virus scan which successfully removed found infestations.

    When booting to any of the different options other than Hard drive UEFI the computer will boot (inconsistently) as if it's boots from the conventional Hard drive\UEFI. I've seen it boot successfully to the Hard Drive using the legacy configuration. And mind you I have nothing in the CD\DVD or USB ports.

    I did download grade to Win 7 but then re-installed Win 8 with no resolution.
    I Downloaded the bios update straight from the ACER Manufacturers website. Using the exact Model/userid number.The update was downloaded and I was successful flashing the BIOS. Do you think it's possible that this BIOS update is sketchy?

    As far as any modifications I haven't done any changes hardware wise. I'm using a straight 5400 RPM drive with no SSD's connected.

    I look forward to your reply.
  9. B00kWyrm

    B00kWyrm TechSpot Paladin Posts: 1,436   +37

    Okay... I misunderstood on the BIOS update.
    I misinterpreted it to mean that you got malware
    while getting your bios update file... eg from the same site.
    From the ACER website you should be good!
    Given that you have had malware, and
    that your boot problems seem to originate from the time you got the malware,
    may I suggest starting another topic, in our Malware forum.
    Broni may be able to help you prove
    whether your cleanup was as complete as you hope.
    Given no ssd... right now I am suspicious of a damaged mbr...
    which may be an indication of a rootkit.
    I think it is worth checking, and once your system is proven healthy, then go on.
    Another approach might be to make your system a Linux dual boot system.
    This might make the UEFI issue with recognizing your drive go away.
    Another approach might be just to get a new hdd for your system
    and then just to a full install on it.
    Like I said last time...
    others with better understandings of UEFI may be able to better direct you.
    Also someone might be able to say that my concern about your MBR is a non-issue.
    I am kind of grasping at straws here.
  10. PhilipMoore62

    PhilipMoore62 TS Booster Topic Starter Posts: 316

    Again thanks for the reply.
    The post originated in virus infection forum which was moved to where it's currently at. (n)

    (Broni moved the post)
    What is my best process for requesting broni to take a look? I seem to be suffering from foot and mouth disease it seems.
  11. B00kWyrm

    B00kWyrm TechSpot Paladin Posts: 1,436   +37

    Hmmm... I don't know.
    Did you post having first followed the instructions for the Malware forum?
    Maybe start a new thread there, being careful to follow the instructions.

    Since (it seems?) you started your cleanup without his direction,
    it may complicate matters.
    You may have eliminated some important traces for the work to be done.
    If you have the logs from your AV scans, they will be important, I suspect.
    OR... maybe Broni felt there was no need to pursue Malware questions?
    The only way to know is to follow the instructions there and ask for the help.
    Again... no one is paid, but my observation is that
    in spite of that Broni really stays on top of that forum.
    If you don't want to do that, then...
    Maybe attempting a clean install on a new drive is the way to go...
    A new 500 gb hdd will set you back about $45 (US) at Newegg, or Microcenter.
    BUT... I am no expert on UEFI, and so...
    I may be missing something that would make that unnecessary.
    So... as I said last time, I will step back now.
    Best wishes!
  12. mailpup

    mailpup TS Special Forces Posts: 7,103   +422

    If Broni moved your post out of the V & M Removal forum, that means Broni doesn't think it is a malware problem.
  13. PhilipMoore62

    PhilipMoore62 TS Booster Topic Starter Posts: 316

    The change of venue came from a helper referring me back to virus removal.
  14. B00kWyrm

    B00kWyrm TechSpot Paladin Posts: 1,436   +37

    Following your other thread Philip,
    I am glad you found the UEFI issue! Good to know that bit.
    But I would urge you strongly to stay with Broni through the process.
    If you quit in the middle, he may not let you come back.
    And... your recent scans are making many fixes.
    I think it is important to get a clean bill of health, and not stop half way.
    Last edited: Sep 7, 2015
  15. PhilipMoore62

    PhilipMoore62 TS Booster Topic Starter Posts: 316

    I haven't heard anything from broni but have no problem going at till the end.
    Thanks for the reminder!
    B00kWyrm likes this.
  16. B00kWyrm

    B00kWyrm TechSpot Paladin Posts: 1,436   +37

    By the way... for others following the thread...
    Good information on UEFI and System partitions can be found here.
    UEFI requires the System partition to be Fat32, not NTFS.
    There are other important considerations as well.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...