Add and remove programs not working

By NDCCMediaGuy ยท 4 replies
Apr 6, 2012
Post New Reply
  1. So here's my issue,

    I am on a work system that is as follows:

    Windows XP Pro Version 2002
    Service Pack 3

    Intel Core 2 Quad CPU
    @2.66 GHz, 2.75 GB RAM

    I have to uninstall .NET 4 using Add and Remove Program Files so that I can re-install it. After starting up, clicking Add and Remove Program files either in Explorer or the control panel brings up the interface but the program files never populate. It doesn't state that it is populating or give any kind of error. Once I close that window I cannot get it to come back without restarting and it still won't populate.

    I've tried Start/Run regsvr32 appwiz.cpl but other than the hourglass flashing a few times next to the cursor, it has no effect.

    I do not have access to the XP install disk so I'm a bit limited on my troubleshooting. Any assistance is greatly appreciated.
  2. khill0930

    khill0930 TS Rookie

    As a workaround, you can try installing the free version of Ccleaner from Piriform, it has several nice tool including an add/remove programs tool.

    Hard to say what might be causing the list to not populate, especially since you've tried the M$ fix. Fixing registry errors (Ccleaner has a tool for that too) might give you some help with it
  3. NDCCMediaGuy

    NDCCMediaGuy TS Rookie Topic Starter


    Installed Ccleaner. Seems to work just fine as a workaround.

    Thanks a bunch.
  4. khill0930

    khill0930 TS Rookie

    Glad to hear it :)
  5. orkun1675

    orkun1675 TS Rookie

    solved the same problem the same way

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...