Asus P5E3 BIOS won't update and needs CMOS reset to boot every time

I am very very frustrated since I waited a while to get this motherboard from china. My last DFI board randomly died on me and I ordered this as a replacement because I wanted a decent 775 board. I worked on it all night tonight and despite it reading all the hardware... it will not boot unless I reset the cmos every time. On top of that... I can not get the bios to update... it doesn't read any of the 5 usb drives I tried (fat/fat32). Also I tend to get this grey screen when trying to flash it sometimes. I am beside myself at this point after fussing with it for hours on end and I really need some help.


Posts: 4,840   +1,267
Sounds like either the BIOS is corrupted or the motherboard battery is a goner.

Have you tried burning the new BIOS to a bootable CD ?
  • Thread Starter Thread Starter
  • #3
I will try to use a CD tomorrow... if the bios is corrupt or the battery bad... what do you suggest? Getting the board replaced is going to be a huge headache :/


Posts: 4,840   +1,267
If the BIOS IC (chip) is shot then the board is unusable.

A motherboard battery costs a couple of dollars- no big deal. I would replace it if you can't flash the BIOS or the new BIOS won't hold the settings.

The BIOS flash should take fine (if the BIOS chip is OK) if you use a bootable .iso CD. On older boards I tend to keep an older IDE CD/DVD drive handy as some boards have problems with SATA drives as first boot. I don't think Asus X38/X48 falls into that category.
If the BIOS is corrupt, reflashing the BIOS should correct the fault

You might also gently press down on the BIOS chip (take the usual antistatic precautions). Sometimes, during shipping, the board can suffer a jolt or two and the BIOS chip an become loose on the board - a lot of BIOS chips are basically socketed with just enough solder to keep them in place.
  • Thread Starter Thread Starter
  • #5
Thanks for all the useful information I'm going to see what I can do with it. Do you feel a corrupt bios or bad battery sounds closest to the cause of my issues? Or is there a good chance the chip is bad?


Posts: 4,840   +1,267
Corrupt BIOS or failing mobo battery are more usual causes. I wouldn't rule out physical damage - kind of depends where you sourced the board from, and what kind of treatment it received in transit (assuming the board isn't a refurb).

Probably not worth speculating to any great degree when you will have a clearer picture once you attempt the reflash and/or replace the battery if the flash isn't stable.
  • Thread Starter Thread Starter
  • #7
Well I tried another battery in the board (I had a working one from another motherboard which I checked the voltage to make sure it was good) and it didn't help I sill have to reset the cmos every time I want to boot. I am going to try flashing the bios to update via a CD. My question is do I burn it as a data cd with the rom and the exe? Then I can alt + f2 to flash from post screen? Or is there another way I should burn the cd. Thanks!


Posts: 4,840   +1,267
Bootable .iso

Use ImgBurn of similar.

>So download the appropriate BIOS from Asus.
>Open ImgBurn
>Select "Write image file to disc"
>Select disc image file ".iso" under "Source"
>click Write

Load the disc into the P5E3 system CD/DVD
Power up, hit Delete to get into the BIOS
Select the CD/DVD drive as first boot device, F10 to save and exit
Re-power up the system and the BIOS file should initialize.

I gather the Asus utilities aren't working? (CrashFree BIOS etc.)
  • Thread Starter Thread Starter
  • #9
The only problem with setting the cd to boot first is I can't get back into bios without resetting the CMOS. So any settings I were to change would be reset. I can only get the computer to post after each reset. I really don't understand. I tried flashing the bios again and updating with USB but I'm getting this grey screen. I don't know what that means.

Is there any way I can use cd to upgrade bios from the bios or with alt f2? Or do I need to have it set to boot from cd first? If that's the case it won't work.

I haven't tried Asus utilities yet... Asus boards are new to me what should I do to troubleshoot further? Any Insteuctions would be helpful.


Posts: 4,840   +1,267
Yes, you can use CD with the Alt+F2 (EZ Flash 2).

Bear in mind that the new downloaded BIOS should have the same name as the BIOS that the board shipped with when making the CD image- so check your mobo support disc ( the one with the drivers and utilities on it). In fact, you could use that disc as the EZ Flash utility should look for the appropriate .ROM BIOS file - although it might be an older BIOS version.
I quickly checked the Asus site. The newest BIOS is named P5E3-1503.ROM -so just rename to whatever the mobo support dvd BIOS is ( Browse the DVD root directory and you should happen across the P5E3.ROM (or similar) BIOS.

I'm assuming (possibly wrongly) that you have already cleared CMOS via the jumper as well as using the CMOS button. If you have not, then I would strongly advise that you do this before reflashing just in case the CMOS button isn't doing it's job- there should be a small 3-pin jumper (CLRTC) just above the front panel connectors on the mobo (somewhere in the bottom right-hand corner). Check your mobo manual under "Jumpers" - but basically:
>Turn off the computer, unplug from the wall outlet, hit the power button a few times to discharge any residual charge
>Move the jumper cap from pins 1 & 2 across to 2 & 3. Leave for a short time -half a minute or so.
> Move the jumper back to pins 1 & 2
> Power up > hit Delete during POST to enter BIOS
  • Thread Starter Thread Starter
  • #11
Well I have good news... and I could have sworn I tried this already but I guess not. I unplugged all of my drives except my primary... and BINGO! The dang thing took the usb no problem and updated the bios. To one up that... once I plugged everything back in as it was before.... it booted up just fine. No reset needed... nothing. I suspect the one IDE hard drive could have been the culprit? I have absolutely no idea as i'm not exactly the most tech savvy person there is.

Needless to say it seems I have solved my problem... so let's call this one case closed! I really appreciate all your help. Having someone to go to about this kept me from completely losing my mind. Cheers! :)