1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

BSOD Corsair 128GB SSD SATA 3

By Poppa Bear ยท 7 replies
Apr 30, 2011
Post New Reply
  1. I recently built a new PC with the following components:

    OS: Windows 7 Ultimate 64bit
    Mobo: Intel DX58SO2
    CPU: i7 960
    Hard Drive: Corsair SSD 128GB SATA 3
    Graphics Card: Gigabyte GTX 550 Ti
    RAM: 3 x 2 GB Corsair Dominator C7 latency DDR 1600
    Burners: 2 x Pioneer DVD SATA x 1600

    Initially it ran fine. Then I started getting odd BSOD. It became particularly noticeable when I ran Nero 10 Burning ROM Trial version.

    I used the following link here to disable auto restart after a BSOD so I could copy the exact data for the error.

    Attached are 3 notepads which show:

    1. The exact error message
    2. The Windows error report.
    3. HiJackThis log

    I'm also including the error message and Windows report in the body of this text.

    1. BSOD Error Message after running UDF format multissession DVD disc with Nero 10 Burning ROM Trial version.

    *** STOP: 0x0000003D (0xFFFFF80000B9C090,0X0000000000000000,0X0000000000000000,0XFFFFF880011A367B)

    *** mv91xx.sys - Address FFFFF880011A367B base at FFFFF88001171000, Datestamp 4be3b5a1

    2. Windows Error Messge:

    Log Name: System
    Source: Microsoft-Windows-Kernel-Power
    Date: 29/04/2011 6:41:49 AM
    Event ID: 41
    Task Category: (63)
    Level: Critical
    Keywords: (2)
    User: SYSTEM
    Computer: Genesis
    The system has rebooted without cleanly shutting down first. This error could be caused if the system stopped responding, crashed, or lost power unexpectedly.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <Provider Name="Microsoft-Windows-Kernel-Power" Guid="{331C3B3A-2005-44C2-AC5E-77220C37D6B4}" />
    <TimeCreated SystemTime="2011-04-28T22:41:49.778819800Z" />
    <Correlation />
    <Execution ProcessID="4" ThreadID="8" />
    <Security UserID="S-1-5-18" />
    <Data Name="BugcheckCode">0</Data>
    <Data Name="BugcheckParameter1">0x0</Data>
    <Data Name="BugcheckParameter2">0x0</Data>
    <Data Name="BugcheckParameter3">0x0</Data>
    <Data Name="BugcheckParameter4">0x0</Data>
    <Data Name="SleepInProgress">false</Data>
    <Data Name="PowerButtonTimestamp">0</Data>

    I have updated all drivers for my system and the BIOS; Ran in-depth scans with Avast, Malwrebytes and Super Anti-Spyware with no infections found; Ran registry clean with Glary Utilities.

    Any help would be very much appreciated.

    Attached Files:

  2. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    As per your information the issue is with with your Marvel Contoller driver mv91xx.sys A number of people have had trouble with this, Intel should supply an updated driver.
  3. Poppa Bear

    Poppa Bear TS Enthusiast Topic Starter Posts: 237   +7

    Thank you for this information. :)

    Is it possible to disable this storage device or is it essential to operate the SATA 3 port which is used by the Corsair SSD hard drive?

    There are 3 entries under Storage Controllers:

    1. Generic Marvell 61xx RAID controller.

    2. Marvell 91xx SATA 6G Controller.

    3. Marvell RAID Console

    I never use RAID, but these drivers were loaded as part of the installation disc that came with the motherboard.
  4. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Go to Intel's website and find your exact motherboard model then go ahead and update the Marvell 91xx SATA 6G Controller drivers . It won't hurt to update all of the Marvell drivers.
  5. Poppa Bear

    Poppa Bear TS Enthusiast Topic Starter Posts: 237   +7

    I manually found all the Marvell drivers for my specific mobo on the Intel site, and downloaded them. But when I tried to install them Windows would not let me and said: "Drivers are up to date." I then tried the interenet update search engine for each Marvell item separately using search from Device Mangager, and got the same result.

    Finally I went back to the Intel site and installed the online driver auto check program and it said all drivers for my motherboard were up to date, except the LAN and Audio. I hadn't installed the Intel ones because Windows 7 auto installed them on loading. Anyway, to be on the safe side I installed both of them.

    However, I then found something which solved part of the problem. Bubbles screen saver wouldn't work and said my graphics card was not 3D capable. I'm embarassed to admit it, but when installing the drivers for the graphics card the installation options window showed 6 drivers and I installed all six. However, I missed seeing the small scroll bar and when I pulled it down there was a 7th driver for "3D Control Panel", that has been missing from the get go.

    I installed this and when Nero 7 is run in compatibility mode for XP SP2, it works flawlessly. I then uninstalled Nero 7 with Revo, ran a registry clean with Glary, and installed Nero 10 Burning ROM Trial version, but as soon as I ran it, not only did the burn fail, but got BSOD.

    Even after Nero 10 Trial was uninstalled I still kept getting intermittent BSODs. Did a clean install of Windows from an Acronis back-up image; and then a clean reinstall of all graphics card drivers; and installed Nero 7 run in XP SP2 compatibility mode.

    Since doing that Nero runs fine and no BSODs ... yet! But it's early days. Will see how I go. I contacted Nero tech support and emailed them the log reports of BSOD and burn failure. Am waiting reply from them.
  6. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Thanks for this; very well explained. From a personal point I will be building a Windows 7 system (possibly two) later this year. I have Nero 7 myself so my question is are there no drivers for Win 7 64 provided?
  7. Poppa Bear

    Poppa Bear TS Enthusiast Topic Starter Posts: 237   +7

    I forgot to mention in my original post, I have two operating systems installed on the same hard drive. On the first partition I've got 32bit WinXP Pro. Strangely enough, Nero 10 Burning ROM Trial, ran flawlessley on WinXP using the same: Motherboard; CPU; burners with the same firmware versions; 3rd party programs and burning media. So it has to be in Windows 7 or maybe the 64bit as distinct from XP 32bit?

    I'm sorry but I don't quite understand what you mean when you say: "Are there no drivers for Win7 64 provided?". Do you mean Win7 providing drivers for Nero 7?

    I am using an OEM version of Nero 7 that came with a Pioneer DVD burner, and simply loaded the latest update of Nero 7, (obtained from Nero home site), using the OEM installation key. Win 7, similar to Vista, inisists on loading it's own drivers for a lot of 3rd party programs, however, most of these can be over ridden by the installation of the native drivers for the particular program.

    Even so, when I loaded the graphics drivers for the Gigabyte card, (Nvidia engine), from the installation CD ... when a re-boot was required to enable continuation of the drivers from the disk, on load up, Win7 took over and started to load it's own drivers. A message came up from the Gigabyte program saying it could not continue to load the drivers until the generic drivers being installaed by Win7 was stopped. This was easy to do by just cancelling the Win7 installation from the icon in the Notification area.

    As mentioned above, Win7 auto loaded generic drivers for the onboard LAN & Audio on the first boot up, but these could be overwritten by the native drivers installation. However, Win7 did not attempt to install generic drivers for Marvell, and this showed as a yellow warning triangle in Hardware Devices, until drivers were installed from the Intel installation CD.

    I hope I've answered your question?
  8. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Sorry, yes, I was asking about Nero 7. And you did answer my question. Thanks.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...