BSOD, Driver irql no less

By Big Dan ยท 8 replies
Jan 20, 2009
  1. Hi to all...

    Just made a fresh install (WinXp Sp3) with all updates, most recent drivers, etc...
    All was fine until i upgraded the firmware on a Lg DVD-Ram (with their auto program) i get this error:
    "DRIVER IRQL NOT LESS OR EQUAL" with the code:
    stop 0x000000d1 (0x00000000, 0x000000ff, 0x00000008, 0x00000000)
    So I strongly suspect the Lg burner, i did a BIOS upgrade just in case (hasn't made a difference)
    Used Memtest86+ (1 pass) memory seems ok but before doing anything else
    could someone be kind enough to analyse the 3 minidump files a have so far ?

    Here are the system specs:

    AMD Athlon 3200+ (socket 754)
    Asus K8V-SE Deluxe with latest BIOS (tried this but to no avail)
    1Gb Kingston DDR 400
    320Gb Western Digital SATA II drive (jumpered for 150mb SATA I operation)
    PNY GeForce 6200
    Lg DVD-ROM GDR8163B
    Lg DVD-RAM GSA-4167B
    Antec True380s (380w) P.S.U.

    Any help would be greatly appreciated !
  2. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    All three minidumps were 0xD1 errors and they are caused by faulty drivers or buggy software.

    2 of the dumps cited the driver viamraid.sys which is a driver for the SATA/150 and RAID capabilities on Mother Boards using the VIA chipset. I have researched that you should either reinstall said driver or update.

    Also, what was interesting in my research was that even though it was a D1 error and it was this driver, RAM was the culprit. I don't believe at this point that it is your problem, but if you ever run memtest again keep in mind that it must be run for a minimum of 7 Passes.

    The other dump cited nv4_disp.dll which is a Nvidia driver.
  3. Big Dan

    Big Dan TS Rookie Topic Starter

    Hi Route44 and thanks for the quick reply...

    When first installing Windows, i got problems getting the system to detect SATA drivers on the floppy (press F6) with my Sp3 CD, (by the way windows asked for "viasraid.sys" not "viamraid.sys"), but strangely it only worked with an older Sp1 version, wich i upgraded to Sp3 afterwards. After first complete boot-up i've then installed Via's own drivers (Hyperion v5.22a) not the ones from Asus. Then, after getting 2 BSOD's i've re-installed the chipset drivers again, just in case and then i got the last BSOD again when windows started its 3d fish screensaver (the last minidump: nv4 error, wich figures). I had done the same with the Nvidia drivers, i didn't use the one from PNY, i went for Nvidia's latest. There are more drivers (IDE: Promise...) on Asus's website wich i didn't install since i won't be doing any RAID (a mistake ?). Should i uninstall Via's driver and use only Asus's. I'm also wondering if this could have something to do with Sp3 (compatibility ?) I find it strange that the 3 minidump list different driver errors, is this common ? i'm beginning to suspect failing mtb chipset...
    Nevertheless, i will start memtest at once, and let it run all nite as suggested...
    ll keep you posted with the results tomorrow evening...
    Thanks again !
  4. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Big Dan, talk about deja'vu, there was someone else here just a few days ago that had almost the very same issues you have and they were with the VIA Hyperion drivers. I'll see if I can find the links.

    By the way, I rechecked the minidumps to make sure I didn't mispell the driver but I did write it correctly as the minidump had it.


    Check out this link; I thought I messed him up but I hadn't:

    Also this one:
  5. Big Dan

    Big Dan TS Rookie Topic Starter


    Strange... i can assure you (after trying to install WinXp 4-5 times) that the "missing" driver was "viasraid.sys", althou it was present on the floppy...
    After completion of memtest, i will try to uninstall Via's drivers (if its possible) and i will install the ones from Asus (including IDE Promise) even if they are a bit antiquated...

    And thank-you very much for your insight, its greatly helpful...
    I feel confident you will help me resolve this.

    I've just read your edit, thanks... I will also check Via Arena's forum

    Been there... Seems there are issues with driver versions 5.18a and up + Via's VT8237 chipset. It is suggested to install no newer than version 5.17a. I'll try the most recent between the ones from Asus and Via's 5.17a, if it's possible without formatting and re-installing again.
    I will keep you posted...
  6. Big Dan

    Big Dan TS Rookie Topic Starter

    Hi again,

    Finished memtest... depending on wich slot the ram was installed, i had
    failing or good ram !? Now i dont know what to think, (bad mtb or bad ram)
    And worse, I wanted to install Hyperion v5.17a so i had the good idea to uninstall the via v5.22 drivers (by control panel)
    now system wont boot anymore (not even safe mode)... bsod 0x0000007b...
    Is it possible to patch the hard disc (connected as sec. on another machine)
    with the missing driver, i figure it should be viasraid.sys ? And where ?
    I'm on the verge of trying to sell a new machine to my client, this is getting on me bad...
    Any ideas ?
  7. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Go back to those links I gave you and read them through. If I am not mistaking he had the same issues, i.e., not even being able to reboot as you do, and I believe he had a work around.

    Here is another idea that I think is proactive. Go to the VIA forums because I think there is quite a bit over there concerning these drivers and the many people who have had issues. Perhaps they have some answers.

    And Big Dan, please keep us up-to-date on your progress. We'll try to help anyway we can.
  8. Big Dan

    Big Dan TS Rookie Topic Starter

    Route44, memtest finally found one bad ram stick (1 of 2 x 512mo). Took 26
    passes !
    Next : I've finally managed to repair the damaged WinXp Pro installation, without having to resort to formatting... For this you need the WinXp Pro Sp1 CD, i have tried most WinXp version but as far as i know this feature is not available on Sp1
    version. Boot on the CD as usual...
    There will be detection of the existing Windows installation and you will be prompted to install or repair: CHOOSE INSTALL. (if you choose repair at this time, you will be warned of loosing your data from formatting of the drive) Accept the confitions (press F8...) etc... Then you will be prompted again to install or repair: now it's time to choose REPAIR.
    Installation will go on (like a fresh install) and after completion you
    will find your desktop as it was, files, programs, settings and all.
    However if you were Sp3, you will be reverted to Sp1, so you will have to move
    to Sp3 again, including IE7, WMP11 and some 23 updates.
    But i figure this is minor comparing to loosing everything and having to start all over again...
    Ok, so this worked, now i installed the Hyperion v5.17a drivers...
    So far so good, all is stable. The bad ram was surely causing problems but i'm sure the Hyperion drivers v5.22a were also causing trouble, as i found out from your links, Route 44.
    I will finish building this system tonite with my client's software Office, Photoshop, etc, etc...) and i'll keep you informed as how it went.
    Looks good... !
    Finally: WARNING everyone ! NEVER uninstall Via sata/raid chipset drivers by the control panel/uninstall. There must be a way to revert to older drivers but for now i don't now.
  9. Big Dan

    Big Dan TS Rookie Topic Starter

    Hi again,

    It's been 3 hours and no BSOD ! Machine is fast and stable...
    Look's like this nightmare is probably over !

    Route44 you been a great help, your advices and links were invaluable !

    Thank-you very much...
    Now i'll do my best to help this forum in any way i can.

    Very best regards,
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...