BSOD, random lock up, minidump attached, and error code

By hibijibis ยท 4 replies
Sep 11, 2009
  1. Hi there all,

    I have only just recently discovered this forum in search of the truth as to why my once reliable desktop seems to be heading towards a slow demise.

    My problem began about 1-2 weeks ago. The computer just started to randomly hang, then explorer would crash, and got not responding. Then the comp would just die, and restart itself, and when it would restart, the desktop was weird, shortcuts not working, corrupt data etc.

    I have reformatted and reinstalled vista now 6-7 times.

    I have run memtest with 1st pass no errors. I have attached my hijackthis log as well. Pretty sure this isnt the problem as the computer has been formatted.

    Today on my most recent reinstall, I thought everything was fine, then my comp bluescreened itself. I wasnt there to witness it, but when windows restarted there was this windows recovered from a serious error. Here is the message.

    Problem signature:
    Problem Event Name: BlueScreen
    OS Version: 6.0.6002.
    Locale ID: 3081

    Additional information about the problem:
    BCCode: 51
    BCP1: 00000001
    BCP2: 8B626008
    BCP3: 00D83000
    BCP4: 00000368
    OS Version: 6_0_6002
    Service Pack: 2_0
    Product: 768_1

    Files that help describe the problem:


    The computer tends to randomly hang as well. The sound of ? hard drive activity ceases for a time, then eventually comes back to life. I had a look at the event viewer, and there have been errors with timeouts with

    A timeout (30000 milliseconds) was reached while waiting for a transaction response from the SysMain service.

    A timeout (30000 milliseconds) was reached while waiting for a transaction response from the TrkWks service.

    Does anyone know what would be my next step from here?

    Thanks I hope that provides all the information required.

    Oh in addition, my computer is overclocked by the shop, who told me it should run stable. And it has been since I got it last year.
  2. B00kWyrm

    B00kWyrm TechSpot Paladin Posts: 1,436   +37

    If you want someone to look at and comment on your HJT log, you need to repost in Techspot's Malware forum (or other suitable venue). I am not qualified to comment.

    Your minidump specifically says...
    REGISTRY_ERROR (51) - Something has gone badly wrong with the registry.
    And cites the probably cause as Memory Corruption.

    I would strongly suggest that you start with Memtest.
    Please follow this guide...

    Please note that (unless you start getting errors reported) you will need to let this run a long time.
    A good way of doing this is to let it run over night. In each 'pass" there are a series of eight memory tests that are run, each more complicated than the previous. You need to let it run a minimum of 7 passes, unless you start getting errors. If you have errors reported, you may want to re-run the test with only one stick of ram installed, checked each stick until you isolate those that are faulty. That way you can limit your replacement to those that actually need it.

    Let us know the results. If your memory comes up without errors, then we can check other things.
  3. hibijibis

    hibijibis TS Rookie Topic Starter

    Hi Bookwyrm.

    Thanks for the reply and interpretation of the minidump. Since I had posted, the restarts and BSODs had increased to pretty much straight after I booted into windows. I ran the western digital data lifeguard diagnostic program and the quick test was normal. I then ran the extended test and left it for a few hrs and it came back with unable to complete due to too many errors!

    So it seems that the hard disk is the culprit. Strange cause I havent had it for that long. Ah well. Hopefully will be able to make a warranty claim on it.

    Last time I ran memtest I did it to 3 passes no errors. I will try to run it at 7 as well just to exclude memory problem.
  4. B00kWyrm

    B00kWyrm TechSpot Paladin Posts: 1,436   +37

    "Memory Corruption" does not necessarily mean that RAM is bad, but it often does.
    In older NT versions, 0x51 was more commonly RAM than now, it seems.

    More information on your error:;en-us;307545

    This error may indicate that the registry encountered an I/O error while trying to read one of its files.
    This can be caused by hardware problems or file system corruption.

    It may also occur due to a failure in a refresh operation,
    which is used only in by the security system, and then only when resource limits are encountered.

    Suggested Resolution: Run disk cleanup then this command: sfc /scannow

    Disk Cleanup:
    Start -> All Programs -> Accessories -> System Tools -> Disk Cleanup

    sfc /scannow:
    Start -> Run -> "sfc /scannow" (only without the quotes)
  5. hibijibis

    hibijibis TS Rookie Topic Starter

    Ok. It has now been three weeks down the track, of what has been computing bliss. Not a cloud in the sky. I thought my hard disk had been the cause of the problems, but now the problem has come back on another hard disk.

    I have now checked both hard disks with the WD data lifeguard diagnostics, and both have passed the extended test. I ran memtest overnight with 12 passes now errors. The only other thing with the hardware I can consider, is maybe undoing the overclock, and putting the bios back on default settings.

    Although the computers has not blue screened as yet, it certainly hangs on startup. I am able to use safe mode with networking with no troubles. I looked in the even viewer, and there appears to be some DCOM errors. I will paste them now.

    A timeout (30000 milliseconds) was reached while waiting for a transaction response from the TrkWks service.

    A timeout (30000 milliseconds) was reached while waiting for a transaction response from the SysMain service.

    DCOM got error "1084" attempting to start the service BlueSoleilCS with arguments "-Service" in order to run the server:

    The following boot-start or system-start driver(s) failed to load:

    Since it doesnt seem to be the RAM, doesnt seem to be the hard disks, i'm not entirely sure what to do next. Since things seem to be running fine in safemode, seems to suggest that maybe it is a software issue? But if someone could advise if that thinking is faulty, that would be good. Otherwise I may have to try disabling services until I can work out which one is causing a problem? If it is a software issue.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...