1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

BSOD suspect ati3duag.dll according to minidump

By jkim · 19 replies
Aug 20, 2008
  1. Hi guys,

    I get a BSOD with a 0x0000007E or 0x1000007E randomly, but it has no other information except the error code. It does not specify the file in error nor the problem. However, I suspect that my problem was since XP SP3. Please let me know what patches you were referring to.

    My computer specs are as follows:
    AMD Athlon 2.8+ (Barton core).
    Gigabyte GA-7N400 Pro 2 Rev 2.x. Firmware FK?
    2 x 512MB Kingston DDR2 400 (slots 1 + 3).
    ATI Radeon X800 Pro. Catalyst 8.7
    WD 120g SATA 5400.
    PS: unknown.

    I am running:
    Windows XP Home SP3. "no new patches as per microsoft site".

    I have performed the following:
    Upgraded MB firmware.
    Updated MB drivers.
    Updated Catalyst driver.
    Performed memory stress test (5 hours and 100% clean).
    Performed graphics card stress test (3 hours and 100% clean).
    Looked through minidump (this is where I identified ati3duag.dll)

    I know for sure that it's not a VIA + ATI compatibility issue, as my MB is an nForce2 chipset.

    The only thing I didn't try is uninstalling Windows XP SP3, because I am not sure whether the problem started with SP3 or before. Another point is that XP SP3 is supposed to contain the 2 SP2 fixes mentioned in the various other threads relating to problems with ati3duag and bsod. Please refer to microsoft KB 946480

    I have checked all of my hardware components using various tests and have come to the following suspects:
    1. Bug in Windows XP SP3?
    2. Some kind of configuration/driver compatibility problem?
    3. Insufficient PSU. (I have tried unplugging all external peripherals).

    I want to rule out 1 and 2 before trying 3.
    My system config (at peak power usage, with all components connected) is as follows:
    AMD Athlon 2.8+ (Barton core).
    Gigabyte GA-7N400 Pro 2 Rev 2.x. Firmware FK?
    2 x 512MB Kingston DDR2 400 (slots 1 + 3).
    ATI Radeon X800 Pro.
    WD 120g SATA 5400.

    *optional/unplugged while testing/prefer to use*
    Seagate 40g IDE 7200.
    Internal 48x CD RW drive.
    External 8x DVD RW drive.
    2.5" 160g Maxtor External HDD
    USB Mouse battery charger.
    USB Wireless mouse dongle.
    USB Bluetooth dongle.

    In the case of 3, which power supply would you recommend out of the ones available at MSY (Australian shop).

    Brand Model {/ additional model}* price {/ add model price}*

    SHAW 550W / 600W Max.22 / 22
    SHAW 720W (Dual Fan) Max.25
    SHAW 860W (Tri Fan) Max.27
    A-Power Black Label 650 Watt Single-Fan 39
    A-Power Gold Label 860 Watt Dual-Fan 59
    A-Power Platinum Label 1200 Watt Tri-Fan 149
    ASUS Z45FP 450W /P-55GA 550W 79 / 115
    ASUS U-65GA 650W 165
    Thermaltake 430W / TR2 470W / TR2 550W 39 /69 /97
    Thermaltake ToughPower 600W / 750W 147 / 184
    Thermaltake ToughPower 850W /1200W /1500W 238/374/459
    Thermaltake 450W / 650W PE for Nvidia & SLI VGA 86 / 123
    GIGABYTE 460W / 800W 49 / 211
    Coolermaster Extreme 390W /460W /500W 44/54/61
    Coolermaster Extreme 550W /600W /650W 71 /85 /95
    Coolermaster RealPower Pro 550w /650w 119 / 155
    Coolermaster RealPower Pro 750w / 850w 192 / 238
    Coolermaster RealPower Pro 1000W 299
    Coolermaster RealPower Modular 520W/620W 129/149
    Super Flower 500W / 550W 65 / 77
    Super Flower 600W / 750W / 800W 104 / 159 / 189
    Topower 420W / 520W “Fan-less” Real 138/165
    Topower 500W / 600W / 750W 69 / 113 / 170
    Topower 900W / 1000W / 1200W 203 /280 /329
    Huntkey V-Power 550W / Titan 650W 61 / 96

    I want one that doesn't cost too much but provides reliable power at a fairly efficient rate. I guess this rules out SHAW (reliability) for one. From what I've read Huntkey Titan ($96) and Coolermaster RPP ($119) are at the reliability and efficiency I'm after. Are there any cheaper on the list that would be recommended?

    Of course I would prefer to resolve this problem without having to purchase new hardware, especially since if it is not a hardware problem, then new hardware isn't going to magically fix the problem anyway.
  2. woody1191

    woody1191 TS Rookie Posts: 551

    G'Day :)

    Could you upload the MiniDumps you have please (No more than 5 at a time).

    I couldn't recommend a PSU for you to be honest I'm not very good with that sort of thing, but I can point you in the Right Direction in terms of Manufacturer, you are Correct about Coolermaster being Good but also the Thermaltake ones you listed are Good as well but I'm not sure about the Huntkey one. Obviously you don't want to buy a PSU yet, we will rule out all other options First which are Free to do :).

    I saw your posts on the other Thread unluckily the OP on there didn't post back.
  3. jkim

    jkim TS Rookie Topic Starter Posts: 16

    Thanks for the reply woody.
    I have attached the minidump parses (using Microsoft Debugging Toolkit) for your perusal.
    Thanks for your time.
  4. woody1191

    woody1191 TS Rookie Posts: 551

    Ok all your MiniDumps are as you said and all Mention Windows Kernel Drivers as Symbols they can't load, but significantly the last 1 you uploaded Mentioned a Network Driver "Rtnicxp.sys" a Realtek Network Driver to be exact, please try using Driver Cleaner Pro to clear your Realtek Drivers and then reinstall the latest versions and see if your Computer runs ok again.

    Oh also I believe it is your Network Drivers because it showed this in your DxDiag File.

    I don't think it should show a cancel message like that, so it might show something wrong with the Network Drivers.
  5. jkim

    jkim TS Rookie Topic Starter Posts: 16

    Hi Woody,

    Thanks for your time.
    I will try cleaning the drivers using your suggestion.

    With the DXDiag report, the cancelled message was expected. The test itself involved another dxdiag client connecting to the specific port to start a talk/chat session. As my wife was using my other PC I cancelled that test.

    I will post back after I try the driver cleaner solution you've posted.
  6. jkim

    jkim TS Rookie Topic Starter Posts: 16

    Well, that didn't work...
    Driver Cleaner doesn't have my motherboard components, including the onboard lan that you mentioned.

    I reinstalled my mb driver, network driver and sound drivers.

    Still no luck.
  7. Acclamator

    Acclamator TS Rookie Posts: 257

    For PSUs go with Antec or a reputable brand.
  8. jkim

    jkim TS Rookie Topic Starter Posts: 16

    I'm limited to what they sell.
    I've listed all of the ones they sell at the local store.
    As you can see they don't sell ECZ or Antec, so they're not an option.
  9. woody1191

    woody1191 TS Rookie Posts: 551

    I don't know if you have tested your CPU or not, if you haven't then please run this Prime95 and run all 3 tests for about 20mins each and report any errors if any and what test it failed on. Sometimes it can find errors in minutes so you need to watch it closely, it also sometimes shuts the program down if it finds a error.

    About PSU's if you do go for 1 go for 1 of the 2 I mentioned in my First Post they are the Best Quality ones you listed.
  10. jkim

    jkim TS Rookie Topic Starter Posts: 16

    I've been running Prime95 for 10 hours now, and no errors to date.
    I have 2 interesting bits of information though.
    I got a proper !analyze -v trace last night when it reoccurred.
    As you can see, it says to go into debug mode.
    So I edited my boot.ini file to read as follows:

    [boot loader]
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /noexecute=optin /fastdetect
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="XP Home Debug" /debug /sos
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="XP Home Fast Detect" /fastdetect
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="XP Home Noexecute" /noexecute=optin

    All 3 non-debug modes log in fine. However, when I start my computer in debug mode, after logging in, but before doing anything else, the system freezes. Only a hard reset will make it move again. Makes it difficult for me to debug the problem since debug mode won't work!
  11. jkim

    jkim TS Rookie Topic Starter Posts: 16

    Also I tried a new PSU but it was a dud. The PSU is dead so I have to go back to the shop and get it replaced.
  12. woody1191

    woody1191 TS Rookie Posts: 551

    What the PSU in the Computer is dead?
    Or you tried another and you found that was dead.
  13. jkim

    jkim TS Rookie Topic Starter Posts: 16

    I got a new PSU but it was dead. My old one still works, which is what I'm using now to access these forums.
  14. woody1191

    woody1191 TS Rookie Posts: 551

    This is a odd error, The Hardware sounds to be Ok. It looks to be pointing to software or the OS, I will suggest you back up your Important Data and do a Clean Install to rule out Software problems also make sure you have the Drivers for your Devices.

    Try not to install all your Software back at once, try installing a program or 2 at a time and run it normally for a day or 2 then install more Programs you use back on. Also when installing Windows Updates install a few at a time then restart and install others a few hours later, this should rule out the Software and OS as a problem.

    Also have you had anymore Bluescreens?
  15. jkim

    jkim TS Rookie Topic Starter Posts: 16

    No. I have only been running movies and internet explorer, email, word etc on this PC since I identified the error. I can reproduce the blue screens at will by playing 3d games. 5 - 10 mins into a game and bam! blue screen.
  16. woody1191

    woody1191 TS Rookie Posts: 551

    Actually the only piece of Hardware that hasn't been tested is the Motherboard maybe it is being caused by that, but as you can see the problem is pretty isolated and getting harder for me to suggest things.

    If you have done the reformat option then Ok, but also try using your current Hardware like your RAM and Graphics Card in another Computer if possible and see if you can try running a Game on that.
  17. jkim

    jkim TS Rookie Topic Starter Posts: 16

    I am suspecting it may be the same... but I have no way to prove it.

    I can't put my current hardware in other computers because they are too outdated and don't fit in recent hardware. The only hardware I can really replace was Power supply and graphics card, which are both fine according to various testing.

    Thanks for all your comments though.
  18. jkim

    jkim TS Rookie Topic Starter Posts: 16

    Still not resolved. Anyone tried debugging vid drivers? I think that's my next step in trying to find this problem.
  19. woody1191

    woody1191 TS Rookie Posts: 551

    Hi jkim sorry to hear your Problem is still not resolved, if you want to try removing your Graphics Card Drivers with Driver Cleaner Pro, And then reinstall the Latest Version of Drivers.
  20. jkim

    jkim TS Rookie Topic Starter Posts: 16

    Thanks for the comment but already tried that long time ago. That was one of the first things I tried.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...