BSOD Vista Ult. x64, netio.sys, can only boot Safe Mode (no network)

By montejw360 · 12 replies
Oct 22, 2009
  1. Hi, first post, woot woot!

    I'm getting the BSOD Vista Ult. x64, related to netio.sys, and I can only boot Safe Mode (no network). Not sure how to even debug this stuff. I'm on my WHS, so I've got some internet access obviously. I'm doing a System Restore, going back 2 days, won't have time to see if it works this morning, have to leave.

    How can I debug this? Just post my mini dump? How can I read my mini dump myself, I don't know what program to use to read the .dmp file. I would attach it, but the System Restore is running on the bsod computer right now.

    Thanks for any help,
  2. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    NETIO.sys is a Windows OS driver and it has to do with networking/internet.

    My suspicion is your NIC card either with its drivers or the card itself. But this is only a guess at this time. When you are able attach your minidumps at your next post.

    How to find your Minidump Files:

    My Computer > C Drive > Windows Folder > Minidump Folder > Minidump Files.

    It is these files that we need (not the folder). Attach to your next post the five most recent dumps. Notice the Manage Attachments button at the bottom when you go to post the next time. You can Zip up to five files per Zip. Please do us a favor and don’t Zip each one individually
  3. montejw360

    montejw360 TS Rookie Topic Starter

    Thanks Route44.

    Not sure the last five minidumps would be any different than the first one as nothing changed, the computer was in an endless boot, crash, boot, crash, boot cycle till my wife turned it off after an hour of it. When I left it, the computer was in a System Restore, I couldn't wait any longer, had to go to work.

    So, here's the last five, they're probably all the same.

    One thing that has changed is I can boot into Safe Mode with networking. I think that's changed since the last System Restore I did.

  4. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    You are correct. All errors are the same 0x0000007F: UNEXPECTED_KERNEL_MODE_TRAP
    One of three types of problems occurred in kernel-mode: (1) Hardware failures. (2) Software problems. (3) A bound trap (i.e., a condition that the kernel is not allowed to have or intercept). Hardware failures are the most common cause and, of these, memory hardware failures are the most common.

    All five cite NETIO.sys as the issue.

    Since you can now boot into safe mode that is a strong indicator the issue is drivers. Try updating your NIC/Wireless drivers.
  5. montejw360

    montejw360 TS Rookie Topic Starter

    I'm going to call this fixed, but not solved....

    I found a note on that said something about a bsod error and I think it had the same STOP error number as I was getting. The message pointed to an MS update that had gone wrong and that there was an updated update. Anyways, I've updated again and it's working. For now. I also updated my NIC driver. The driver I had was a 2007 version, now I've got a 2009 version.

    Anyway, I'm up and running. I can't say what fixed it, that's why I'm calling it fixed, but not solved.

  6. montejw360

    montejw360 TS Rookie Topic Starter

    Bluescreens started again....

    netio.sys is mentioned on the bluescreen again. I don't know what happed/changed to make this come up again. The only thing I can say is I've been doing a lot of work with my Windows Home Server, messing with Hamachi a bit, Remote Desktop.

    Anyway, if you can help, here are the last 5 minidumps. I think the 1 or 2 are good boots, then 2 crashes, then a good boot into Safe Mode.

    I just did a System Restore going back one day, still crashing. (I'm on another computer next to the one crashing)

    Thanks for the help,
  7. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    All errors are the same 0x7F and all point to NETIO.sys as the cause. It could be your NIC card itself is faulty.

    Have you ever run Memtest on your memory?
  8. montejw360

    montejw360 TS Rookie Topic Starter

    Thanks for the quick look. I'll yank the nic out and figure out how to run Memtest. A hardware issue makes some sense to me being so intermittent and out of the blue.


    edit: I guess I won't be yanking the nic, it's onboard.
  9. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    See the link below and follow the instructions. There is a newer version than is listed but either one should work. If you need to see what the Memtest screen looks like go to reply #21. The third screen is the Memtest screen.

    Let it run for a LONG time. The rule is a minimum of 7 Passes; the more Passes after 7 so much the better. There are 8 individual tests per Pass. Many people will start this test before going to bed and check it the next day.

    If you have errors you have corrupted memory and it needs to be replaced.

    Also, with errors you need to run this test per stick of RAM. Take out one and run the test. Then take that one out and put the other in and run the test. If you start getting errors before 7 Passes you know that stick is corrupted and you don’t need to run the test any further on that stick.

    Link: (This is an ISO file and not a Data file)

    * Get back to us with the results.
  10. montejw360

    montejw360 TS Rookie Topic Starter

    Thanks again. I just finished a chat session with a Dell tech, I think we narrowed it down to something related to my VPN software, Hamachi. I've done a quick search and there's been problems with it AND some AV software, seems they might not play well together. The reason I say AND is it seems to be the combination, not just Hamachi itself.

    Edit: I'm running Avast AV. I might uninstall it and try something else to see if it makes a difference.

    Anyway, I'll run the memtest anyway, it gives the computer something to do. I thought I was paying attention to the changes I made to the computer before the issue came up, but I may have installed Hamachi a couple days ago and had not tried it, so the bsod came up later.

    For everyone's edification, we found the problem by uninstalling all of my Network Adapters in the Device Manager while in Safe Mode. Rebooted to Normal Mode, the NIC driver was automatically reinstalled, no problems. I reinstalled Hamachi (VPN), used Hamachi, no problems. Rebooted, bsod. Went back into Safe Mode and uninstalled only the Hamachi (VPN) Network Adapter in the Device Manager, rebooted Normal and everything is good again.

    Edit: At least I don't have to keep doing System Restore's anymore, and that's a good thing.

    Thanks again,
  11. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Makes sense in light of the constant referral as NETIO.sys being the probable cause. Avast is very good. Thanks for the update and information along with explanation.
  12. montejw360

    montejw360 TS Rookie Topic Starter

    I've posted on the Avast forum. Someone is looking at my minidumps. I'll post back any real solutions if they find any.

  13. montejw360

    montejw360 TS Rookie Topic Starter

    Here's what the Avast tech came up with. He asked for the big memory.dmp file, the minidump didn't show him anything. After looking at it he stated:

    Thanks for your kernel dump. The system double faulted, because lot of kernel stack space was consumed. Windows network drivers are used in conjunction with multiple third party network drivers and some of them loop packets back into tcpip.sys (windows application) in a sending/receiving calling context and this is quite unexpectedly expensive operation on Vista.

    So, currently you use VBoxNetFlt.sys, hamachi.sys and nm3.sys drivers.
    I'd suggest you to turn nm3.sys (Windows Network Monitor) off from all network adapters and see if it helps. If not, then it's either VBoxNetFlt.sys or hamachi.sys fault.

    I turned Windows Network Monitor off, turned Avast back on and it's running fine. So, it's fixed again. If the Windows Network Monitor has some sort of bug or is just not playing well, I'm not sure what to do about that.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...