BSODs when booting Win XP Professional

By cookiesandjuice · 14 replies
Jun 4, 2011
Post New Reply
  1. Windows XP Professional SP3
    Dell Latitude C640 laptop

    I, just two hours ago, installed DivX HiQ Beta. It switches other websites' default players with the DivX Web Player. After I decided to let it automatically switch YouTube videos from Flash to DivX; two videos later a video was in Flash and had the default YouTube player interface. Seconds later I got a BSOD.

    I was really stupid and didn't copy down the stop error code. It did tell me to uninstall any new software though.

    I rebooted the computer, while the "beginning dump of physical memory" message was still there. That's when I started getting this message before the BSOD:

    Memory write/read failure at 5FFF0000, read FF10FF00 expecting FF10FF10
    Memory address line failure at 5FFF0000, read FF10FF10 expecting 00000000
    The BSOD then said something about a crucial process/thread unexpectedly exiting or being terminated. (*smacks face*)

    • Next reboot BSOD: Video card adapter?
    • Next two reboots: uninstall AV, disk defragmenter, backup utility tool; use CHKDSK /f
      (I finally got to my senses and copied down this stop code: )
       STOP: 0x00000024 (0x001902FE, 0xBA678B94, 0xBA678890, 0x8054C007)
    • Next two reboots: adequate disk space?
      (Another stop error code: )
      STOP: 0x0000008E (0xC0000005, 0x8054C139, 0xB38F27FC, 0x00000000)
    • Next reboot: process/thread crucial to system operation unexpectedly exited/been terminated
      STOP: 0x000000F4 (0x000000F3, 0x89EEBDA0, 0x89EEBF14, 0x805FB1D6)
    • Next reboot:
      STOP: c0000139 {Entry Point Not Found}
      The procedure entry point eateDIBitmap could not be located in dynamic link library GDI32.dll.

    I have tried:
    • Going to Safe Mode (as well as with Networking/Command Prompt <- last one was Command Prompt)
    • Going to Last Known Good Configuration
    • Booting normally (while pressing F8.. which doesn't work on the Windows start-up screen. Can see cursor too on black screen after Windows start-up screen)

    Note: This laptop has NO floppy disk drive, nor a CD drive.
    When it says it's beginning to dump the physical memory, either it hangs or it is completed instantly.

    I'd appreciate any feedback, suggestions, and advice. Thanks.
    To be honest I can never see myself testing out Beta products ever again!
  2. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    You have said what you have tried but not said what happened when you tried it.

    Can you get to the command prompt?

    Not sure what you are saying here, you need to start tapping the F8 key during POST immediately after hitting the power button. Please slow down a bit and explain yourself a little better.

    Beta versions are always a risk but your sytem is behaving like it may have Malware or coincidentally you have a hardware fault. Please provide a link to the site you downloaded this software from.

    Have you another PC to use and a USB adapter to hook up the hard drive for diagnosis.
  3. cookiesandjuice

    cookiesandjuice TS Rookie Topic Starter Posts: 25

    Sorry about not being clear. I've been busy for the last few days, and haven't really had the time to work on my laptop.

    The methods that I had tried using to boot-up Windows without a BSOD ended up with me having a BSOD.

    Anyway, I have tried pressing F8 immediately after POST. But when it reaches the Windows logo screen, F8 can't get into Safe Mode anymore. Which I think is normal. However, if there is a message saying there is a memory error, after the Windows logo screen when a cursor is at the centre of a black screen, there can be a BSOD. It's all very random.

    To update, the laptop, after using only the batteries in it and not the plug-in power adapter, it said that the amount of memory had decreased. Then there was a memory test the laptop conducted on its own, and the only thing that didn't pass was the video card.

    Now, I can log-in occasionally into the laptop without a BSOD happening for a while, and usually there is a pop-up saying the system has recovered from a serious error when it clearly has not. If, before Windows loads up, there is a message saying that there was a memory error or the amount of memory has decreased, there is a BSOD before I reach the log-in screen with user accounts.

    I haven't turned on my laptop for a while, and just today there was an error saying along the lines of, "The system memory amount has changed." After logging in, a few minutes later there was a BSOD. This is different from what I experienced a couple days ago.

    If you mean going to the Command Prompt through tapping F8, then I've tried it before. Now that I can log-in sporadically, I might have to try it again.

    I also think that this could a malware/hardware issue, except that DivX is a trusted company. I doubt there could be malware from it, unless it wanted to ruin its reputation. I could have gotten the malware from somewhere else though, or if the download was hijacked. I am almost sure there is a hardware fault, though.

    I have two desktops that the laptop could be connected to. I'm not sure what you mean by a USB adapter.

    Later today, I will try to obtain and post the minidumps.
  4. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    All these errors relating to memory would suggest your RAM has developed a fault. It needs to be tested with a boot disc to do the job properly, is there any chance you can get a CD drive for the laptop? Or a USB memory stick?

    Do you know how many memory sticks this laptop has and how to remove them. If so (you will probably only have two) remove one of them and then try to start it up, if there is no improvement swap the sticks and try again.
  5. cookiesandjuice

    cookiesandjuice TS Rookie Topic Starter Posts: 25

    I'll have a USB adapter to connect to the laptop on Friday.

    A CD drive..? I'm not sure which ports an external CD drive would plug into. I know CD drives can plug into a USB drive, but would I have to install it? I do have a USB memory stick though.

    I'm fairly certain that there are two memory sticks. I'm not sure how to remove them.. my friend does, but he doesn't have the screwdriver to open the computer, and neither do I.

    NOTE: Recently, I've been getting only the BSOD error IRQL_NOT_LESS_OR_EQUAL. Stop code 0x0000000A. Does this mean anything?

    I can't obtain the minidumps at the moment because the computer continuously crashes after I log-in to my account now.
  6. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    I am fairly sure that you have faulty memory. You can download the diagnostics from here, scroll down the page and just below the pictures of the blue screens is a list of downloads, you need the one for a USB key with NEW next to it.

    Unfortunately Memtest can miss some errors so getting access to your memory modules will be needed in order to do a more thorough test on them.

    To use the F8 key it needs to be pressed during post not after it. This will allow you to try and run in safe mode, if running in safe mode works without errors this will then indicate that the problem is a driver.

    Most DIY stores will have the correct screwdriver to open the case to get access to the memory. It will probably be a Torx or Allen key that you will need.

    A USB adaptor can be used to connect your hard drive to another PC, at present this will serve little purpose apart from being able to save any of your important documents.

    An external CD drive can be connected to any USB port. To boot from an external drive you have to get into the Bios and set the USB device to 1st in the boot order.
  7. cookiesandjuice

    cookiesandjuice TS Rookie Topic Starter Posts: 25


    There is one problem though, Mark. I cannot boot the laptop from the USB drive. I'm not sure if this is an issue, but I think it is ... there is no .exe file on my USB key after installation.

    In the BIOS, there are only options to boot from this stuff. I'm not sure if I have any of these, except the Internal HDD. I know I don't have a CD drive.

    • Diskette Drive
    • Internal HDD
    • CD/DVD/CD-RW Drive
    • Modular Bay HDD
    • Cardbus NIC
    • C/Port II or C/Dock II NIC
    • C/Dock or C/Dock II top PCI slot NIC
    • C/Dock II bottom PCI slot NIC
    • Onboard NIC

    Oh, and a few other stuff I discovered:
    1. In the Pre-boot Self Assessment Test Build 3009 (gotten through POST > Boot Options), it said the Memory Test failed. Error code 1000-0123 Msg: Memory integrity test failed.
    2. I went into Safe Mode, and I was able to extract minidumps and shut down before/without the computer crashing.

    Later on, can I use MemTest without booting from a USB drive/external source?

    Attached Files:

  8. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    OK, this is a bit of a mixed bag of minidumps, that usually means faulty memory and two of them state a hardware fault.

    And the built in Memory test has failed which gives further evidence to this problem being down to a faulty memory module.

    Not sure what the problem is with the USB stick but I would now recommend you get the correct screwdriver to gain access to your memory modules and do the test I suggested earlier.

    Make sure you remove the poswer supply and the battery before removing or replacing the memory modules.

    Have you actually tried to uninstall the Beta software you downloaded just before the problem started. This would also seem a likely cause for the problems considering you were able to run in safe mode without a crash.
  9. cookiesandjuice

    cookiesandjuice TS Rookie Topic Starter Posts: 25

    My problem with my USB key is that my laptop cannot boot from it. Could I do the memory test on the hard drive?

    I will do my best to look for a screwdriver to open the bottom of the laptop.

    Yes. I have uninstalled the beta product already. As well, I have successfully booted up Windows regularly for 15 minutes without crashing. Right now, I'm running CHKDSK after a reboot, and it seems to be going okay. More updates later.
  10. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    That's sounding good. It could well be that all the problems related to that beta software.
  11. cookiesandjuice

    cookiesandjuice TS Rookie Topic Starter Posts: 25

    I'm not so sure. Six days ago, after I uninstalled the beta product by using System Restore, the computer was still crashing...

    Note: Thanks for continuously posting and helping out, by the way. You're a lifesaver.
  12. cookiesandjuice

    cookiesandjuice TS Rookie Topic Starter Posts: 25

    I'm very confused.

    I was at the normal 1.5 GB of RAM. After a few hours of being able to log-in normally, and defragging the computer with IOBit Smart Defrag, running Flash videos, and the like, I rebooted the computer and performed the self-assessment test again. The computer PASSED the memory test.

    Then, when I logged in again, I closed the lid of my laptop to take out the two batteries. (One hangs at 98% charged), with the AC still plugged in. When I opened my laptop again, after hearing no noise - a sign of standing-by - the screen stayed blank. The fan rapidly started heating up. I had to shut down the laptop by holding down the power button.

    After POST there is a message saying there are memory read/write and address line failures, and the amount of memory is decreasing and the amount of system memory has changed. I checked the BIOS—System memory = 704 MB.

    After one blue screen (0x00000024) I restarted the computer. The computer has FAILED the memory test now, with the same error code and message as before. I'm back at my desktop now. Under My Computer > Properties, RAM = 512 MB.

    Attached Files:

  13. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    This crash has a code of 24. The usual cause is a fault on the disk drive or memory.

    I would advise you now get the screwdriver so you can gain access to the memory modules in order to start a proper diagnosis.

    Running the PC on just one memory module at a time will quickly prove if this is a memory fault. Only after doing that can you move on to test for other causes.
  14. cookiesandjuice

    cookiesandjuice TS Rookie Topic Starter Posts: 25

    Thanks Mark, for all your help. However, I've decided to just leave the laptop be. It was given to me for free from my cousin, who works at a computer programming company. It was a corporate laptop about to be thrown out.

    The screws on the bottom - one is stuck, and will only unscrew halfway, and the other has a rounded slit and so a screwdriver that would fit into the other doesn't fit into it. It doesn't look any different.. perhaps it's simply bored in too much.

    Again, thank you. If I ever have any computer issue I will come back to TechSpot.
  15. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    Your welcome.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...