Built-in CD/DVD-RW drive stopped functioning

By Relativism ยท 4 replies
Dec 29, 2011
Post New Reply
  1. Hi there,

    A couple of months ago my CD/DVD-RW drive stopped working (it works physically, but when I enter a CD, the software will not read it, and the corresponding drive in the My Computer screen disappeared). However, since I found out it stopped working I've been too lazy to try and fix the problem. Today, however, I made some attempts to retrieve it. First off, I opened my case [I handpicked the hardware ingredients some years ago and had it assembled for me] and tried to figure out if any cables were disconnected from the device. I'm by no means an expert on the subject, but I think the drive was still connected properly.

    Next up, I checked out my BIOS. It said something about a ROM station being disabled, but enabling that did not help. At the booting options, however, I found the option "IDE:TSSTcorp CDDVDW SH-202J", which (I'm guessing) must be the drive, so my software recognizes the device [right?]. Not finding anything else, I just checked off "Return all values to default", but that did not retrieve the device either.

    Finally, I tried switching some devices of/on and using the "Search for changed apparatus" function in the screen (I don't know what it's called in English) included in the attachment. In this application, I tried using the CD/DVD-stations as well as the IDE section, since in the BIOS the device was identified with the IDE tag.

    Long story short, I still have no idea how to retrieve the device. Any ideas?

    Thanks in advance,

    Attached Files:

  2. mike1959

    mike1959 TS Evangelist Posts: 1,034   +55

    In 'Device manager' (the screen in your image), right-click on the DVD/CD and choose "uninstall this device".
    Re-start the PC and you should find, Windows finds the DVD/CD and installs the drivers for it. It should then work.
  3. Relativism

    Relativism TS Rookie Topic Starter

    Hi there,

    First off, thanks for taking the time and effort to look into my post. I have done as you said (Deleted both DTSoftBus stations (which are virtual drives associated with my DaemonTools), upon which the entire CD/DVD section disappeared in the Device Manager), and upon restarting my PC showed the notification found in the attachment to this post.

    Apparently, my PC just restored the virtual DaemonTools drives (so it basically undid what I removed in the Device Manager), but did not recognize or find my physical CD/DVD drive. Any ideas on how to resolve my drive from here on?

    Thanks in advance again,

    PS: Some additional info might help:
    - my operating system is Windows Vista Ultimate
    - I already tried the standard methods suggested on TechSpot (the posting system will not have me post the link in my post however), which led me to a standard Microsoft solving application, however this did not resolve the issue.

    PPS: If there are any further "standard solving procedures" I could try but somehow missed, or if there is any information you would consider useful to solving the problem that I have not provided, please tell me so.

    Attached Files:

  4. mike1959

    mike1959 TS Evangelist Posts: 1,034   +55

    There are several things you can try.
    One is to try this program;
    or same thing from CNET;

    This can get the correct information about your DVD drives, and has the option to find the driver for them.

    Or I have used this program, which works very well, but the free version can be very slow;

    If you have other software which is preventing you from installing or modifying your system, then you may have to remove it, while you do the driver updates. It may be your Daemon tools virtual drive software is the problem....... I've never used it, so can't comment.

    If you are able to remove the cables (power & data) from the DVD drive, boot the PC, shut down, connect cables again, boot again, then Windows will detect DVD drive as if was a new one.
  5. Relativism

    Relativism TS Rookie Topic Starter

    Hi again,

    No luck again so far. Here are my results on your suggestions:

    1. Unknown Device Identifier 7.00
    > Finds "CD-Rom station", but asking for drivers just creates a Google search of standard generic terms ("Cd-rom-station Driver Download (.exe OR .zip)") that I've searched for already. See first attachment. No more information than the name "Cd-rom station" was provided, and I did not find any other relevant drives that could correspond to my missing drive.
    2. DriverEasy
    > Does detect a number of CD-Rom drives, some of which are just USB-stick software packs. The TSSTcorp is in there again (see attachment 2), and I think this represents the actual drive as stated earlier, but its drivers are indicated as correctly installed. This did not resolve the issue either.
    3. Intermezzo - downloaded any windows update that seemed at least a little relevant (including Service Pack 3) - no changes.
    4. Doing the physical removal thing resulted in two boots that did not yield any new messages, nor recognition of the device. It is still missing.

    When opening my (physical) case, I noticed that there were free slots in the device. There were two connected wires (a power wire and an HDD wire connected to the motherboard), and two (much smaller slots) were not occupied. Perhaps this might have to do with some required cable that's missing?
    However, I already think I pretty much ruled out hardware error as a cause for the problem, since (in post 1) I found out that the device showed up in my BIOS under booting priority options.

    So, any further suggestions? Thank you for your continued effort!

    Attached Files:

    • UDI7.jpg
      File size:
      14.3 KB
    • DE.jpg
      File size:
      28.4 KB

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...