Cannot access my backup drive

By bj00uk · 12 replies
Oct 12, 2009
  1. Hi everyone

    Basically while I was using my PC I tried to access my Seagate 320gb HDD Backup drive this this basically pretty much full with information from the last couple of years, I was planning on backing it up this coming weekend.

    Basically I get the following error code

    H:/ is not accessible
    The Wrong Diskette is in the drive.
    Insert (Volume Serial Number; ) into drive H


    Can anyone help? Please I have lost some vital bits of information
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Can you access the backup drive using another computer?
  3. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    From what i see, i'm guessing this is a second internal HD? As the error message implies Windows thinks it's removable media.

    1) I agree good to try it on another computer to get to your data first and copy it
    2) Then i'm thinking you put back in your computer and go in Device Manager and uninstall the Drive. Let windows reinstall the disk driver (and the disk attributes)
  4. bj00uk

    bj00uk TS Enthusiast Topic Starter Posts: 79

    I tried it in another desktop and still I get the same error,
    Yes it is a secondary internal HDD one which was taken out of a Maxtor external enclosure because the enclosure failed.

    Now I remember why I always used to recommend people to buy a few of smaller HDD instead of one huge HDD, and keep work and entertainment separate.
  5. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Sounds like the problem is with the HDD itself :(

    Maybe best to try:
    1) Data recovery tools. Try using TestDisk (it's a tool on a G-parted Live CD). See [post=720766]How to boot from a G-Parted-Live-CD[/post]
    2) Try booting into Knoppix and see if Knoppix (vs. Windows) can read the drive or any useful info. See [post=766270]How to recover your folders/files when Windows won’t boot[/post]
  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    When googling your "Wrong disk. Insert correct volume" problem, i saw its been encountered and posted by many over the last several years but nothing i found seemed to show why or how to fix. So I did some digging into Windows and here’s what I’ve learned. (May or may not help lead to help find/fix your case but thought I’d share what I’ve learned)
    1. The issue has nothing to do with “removable media” (my earlier guess).
    2. It appears to have everything to do with a Volume serial number Windows creates for every disk volume (i.e. partition) – whether on removable media or HDD
    3. Each serial number is created based on time of day so it’s unique. Windows uses the serial number to uniquely identify the partition, know when it’s present and when the partition has been changed/removed/replaced.
    4. The serial number is displayed as a hexadecimal number. (A hex digit can have one of 16 values: number 0-9 or letter A-F, i.e. “hexadecimal”).
    5. You can easily see the serial number on each of your current partitions using the dir command in a command prompt window. To open the comand window, click Start->Run, enter cmd. Here’s the result for my G: drive (which happens to be a USB flash drive). Note the serial number F043-1833
    6. Note: Volume serial numbers shouldn’t’ be confused with the hardware serial number. A h/w serial number is assigned by the disk drive's hardware vendor when the drive is built and does not change.
    So now it starts to get interesting….
    • When Windows mounts the partition, it saves “mount point” info in the registry. Info includes both the name of the mount point as well as volume serial number
    • From what I understand, some apps will also save the serial number so they also know when the partition has been changed
    • When Windows (or an app) detects the serial number change you get those Insert Correct Volume Serial number message pop-ups.
    • The DiskView tool will display the mountpoints and serial numbers stored in your registry. Run it, click View->All Mountpoints, select Mountpoints. Note the display on my computer below and note:
      > There are two different entries / names per mount point.
      > But note the Volume Label and serial number are the same for each
      > If you look at the data for my flash drive, you’ll see label USB Flash and serial number f0431833 which you’ll notice is the SAME serial number shown by the dir command
    So I think questions
    • Download DiskView here. Run it. Do you see mountpoints for the H drive? What serial number is in the registry? What type of filesystem is on your HD? (FAT32? NTFS?)
    • Tho regardless of question above, is curious you get the same “Insert Volume” message even on other computers when you first connect the drive? This also makes me question if the drive is bad and/or just the sector with the serial number is bad. I'm curious/willing to look further (e.g. maybe a raw disk editor) if you want to do above and look further.
    /* EDIT */ I fixed the DiskView download link!
  7. bj00uk

    bj00uk TS Enthusiast Topic Starter Posts: 79

    Hi, I will try that out.
    It is NTFS, and yes when I connected to my other PC it still had this error. Now I do not receive the
    "H:/ is not accessible
    The Wrong Diskette is in the drive.
    Insert (Volume Serial Number; ) into drive H"

    error but "H:\ is not accessible. The parameter is incorrect." This time I tried CHKDSK again but it still never worked

    Would it be recommended to use the drive again once it has been backed up (if I can) and formatted.
  8. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    How did chkdsk fail? Do you have your install disks? As i'd suggest booting into the recovery console and try running chkdsk from there. If you don't have your install disks you can download the recovery console from online. See [post=766270]How to recover your folders/files when Windows won’t boot[/post]. The first step describes how to run chkdsk from recovery console.

    As to the HD... it seems that it's somehow got corrupted or failed. You can run diagnostics and stuff on it but IMHO if you need a drive you're going to rely on for important backups and critical stuff, i'd probably invest in a new HD. Use this one as temp storage/non-critical stuff
  9. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Hmmmm... the more i read the more it sounds as tho your problem is related to boot record problems. The possibly good news if it's only boot records that are corrupted attempts to use disk data recovery tools may help get to your data (as they ignore the boot record stuff)

    When you're in recovery console, in addition to chkdsk try validating drive letters C through H
    enter dir <driveletter> example dir c:
    Try this for each drive letter from C to H
    > We can validate each drive letter C to H this way
    > Because when you try this in recovery console your old "H drive" might be reassigned a new drive letter! So let's not assume it must still be H.

    Just do above steps (dir command and DiskView) and then we'll try the rest...
    I'm thinking once we first assess each drive letter (i.e. what devices are detected on what drive letter) then we can next look at attempting to use both the fixmbr and fixboot commands for the device. This might fix possible partition boot record corruption.

    Here's a a link describing recovery console and all its commands
  10. bj00uk

    bj00uk TS Enthusiast Topic Starter Posts: 79

    When I say CHKDSK failed I mean It does not work on that particular drive it just says
    "The type of file system is NTFS.
    Unable to determine volume version and state. CHKDSK aborted.

    I will try out recovery console and diskview when I get bk home from Uni later tonight.
  11. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    OK. I'm thinking we might initially use Partition Table Doctor 3.5 (PTD) to see things with a nice Window interface (it'll give you an easier interface then having to use the Recovery console). In any case, is worth running the free version to see what it reports.

    1) Run DiskView and please provide a screen capture
    2) Run PTD and provide a screen capture as well

    We can defer needing the Recovery Console till we see what PTD reports

    /* EDIT */
    btw.. this is a guess, so of course i might be wrong, but all your error messages sound consistent with having a bad boot sector on the HD
    => Volume serial number is in boot sector (reason for the Insert correct volume message)
    => The BIOS Parameter block is in the boot sector (Windows uses the Parameter Block to understand partition layout) so problems here sound consistent with "invalid parameter" message
  12. bj00uk

    bj00uk TS Enthusiast Topic Starter Posts: 79

    I cant send anything from DiskView I get no archives found when I try to extract it ??
  13. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    You mean that you can download it but you can't unzip/open the zip file? That's odd...

    I use a tool called ALZip which, in turn, uses (i believe) standard zip format.

    I just tried downloading/unzipping myself and seemed to work... You might try downloading and using ALZip also for this (click here). See if that works for you then.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...