Cannot boot xp. ntfs.sys blue screen 0x00000024

Not open for further replies.
I'm not surprised to see Compaq being mentioned in two previous posts.
Myself I've got this "friendly"(?????) blue screen on a Compaq Evo 800c, using XP only (so no multi boot).

[a] Booting results in immediate Blue Screen and immediate Reboot. Blue Screen is visible for less than a second..
When Boot Bios options is set to check memory first you do not even see the blue screen.

Using XP recovery option results in (lasting) Blues Screen that can be read

[c] I wasn't able to use Bart-PE: Got the same error.

[d] I wasn't (like Hed wrote) able to use W2000 boot flops. Got the same error.

[e] I cannot acces it as drive E: from another system. Sugested by both coolbarguy and MrKobie. That will require an additional bay to "read" the drive from either another laptop or a desktop.

[f] I haven't been able to use the Knopix reffered to by coolbarguy. It keeps telling me a ntfs fs is read only :(
I did find the tools "not referred to in his posting" as in his posting after the semicolon it stops.

Als my idea about how I think "asjeep" may have encountered it more than once:
[a] Introduce a Bios Boot-PW
Shutdown XP. But instead of real shutdown (by mistake or by error) the option restart is chosen.
[c] PC will now restart and pop up with the Boot-PW
[d] All that time the Fan isn't working (So the PC is getting just a little 'hottie' I think) and appearantly the File System is being "read"already??
[e] If no-one is paying attention to the PC this willl last to long and will result in the stopcode 24 at reboot/startup.

Are the knoppix tools referred to found in /usr/share/doc/ntfstools?? And if so how to use them??

Knopix has no proble m reading any file on the NTFS drive so as mentioned in this thread before: it is NOT likely to be a hardware error!!
I've seen something similar in the past with the need to replace nt.dll on a NT4 system. (But that was running on FAT which made life a bit easier)

Any comments suggestions appreciated....
I'm happy again

ntfsfix utility from Knoppix did the trick for me.

I wish I hadn't wasted my time with the other utilities....


Posts: 4,190   +11
Thx for letting us know. Hopefully that can keep people from waisting their time with other utilities too.:)
This thread saved my life....I was so worried of loosing all the photos and videos I took since my last backup (2 months ago)

I used the procedure described in the KB Article 228888

In particular this part:

Using Recovery Console on a Single Drive Computer
If your computer contains only a single NTFS volume and no additional Windows 2000-based computers or hard disks are available to use for the previously described methods, you can boot from the four Setup disks to run the Chkdsk tool with the Ntfs.sys driver disabled. To repair a NTFS volume by using Recovery Console, use the following steps:
Start the computer by using a Microsoft Windows 95/98 startup disk with CD-ROM support (or from another computer with a CD-ROM drive, insert the Windows 2000 installation CD-ROM).
Change to the CD_ROM:\Support\Bootdisk folder, and then run Makeboot.exe or Makebt32.exe to create the four Windows 2000 Setup disks.
Using Notepad, modify the Txtsetup.sif file on the first Setup disk you created in step 2:
In the [FileSystems.Load] section, locate the line that begins with "ntfs."
Insert a semicolon (;) at the beginning of the line, as shown in the following example:[FileSystems.Load]
fat = fastfat.sys
;ntfs = ntfs.sys
Save your changes.
Start the computer that is experiencing the "stop 0x24" error message by using the four Setup disks. When the Welcome to Setup dialog box is displayed, press F10 to start Recovery Console.
Run the following command to repair the corrupted NTFS partition:
chkdsk driveletter: /p

Type exit to quit Recovery Console, and then restart the computer.

Since my hard drive was in IDE-RAID (HPT370) I was not able to use the knoppix option.

As a tip for others with the problem:

Make sure you run the chkdsk driveletter: /p command in the procedure for ALL the ntfs drives in your computer

I assumed it was my boot disk the one with the problems but fixing it didn't solve the problem so I did the same for the other disks and YES! the problem was solved.

Thanks to everybody in here...Is a great forum.

A similar problem resolved.. well ... kinda similar.

I searched the web for a fix for a problem I was having and this was the only place that was remotely close.

I was trying to access the repair console in Win 2k pro and when trying to load the floppies, I'd get a message "the file fastfat.sys is corrupted" on disk 4 and this would halt my access.

Long story short, found a work around and it goes like this.;en-us;228888

Do the fix at the bottom and then find someone with win2k of the same version. Grab a copy of thier fastfat.sys from \WINNT\system32\dllcache .

Swap that out for the one on your disk #4 and you are all set to go.

Hope this might help someone.



Posts: 4,190   +11
Thx for the tip, surely you're not the only one who will come across such a problem.

PS. Welcome to TechSpot. Hope you enjoy your stay.:wave:
I just recently got exactly the same problem running on win xp pro and have no idea what to do. Exact same symptoms as hed reported but what I would like to know is if there's another way to fix it (besides Knoppix or whatever it is, I'd prefer to avoid large downloads like that if at all possible). I already know it's definately not bad memory or anything like that either because I stuck another HDD in there and it works perfectly fine and without any troubles.

I've tried making a boot disk for xp (from the link given earlier on in this thread) and following the instructions in the link given in the 2nd post in this thread but it didn't work because the file Txtsetup.sif on the Win XP bootdisk is obviously different to the one on the win 95/98 bootdisk, maybe even the win2k one as well judging from hed reporting his problem fixed, since when I opened it up it was all gibberish and I didn't find any trace of a [FileSystems.Load] section.
Thanks so much.. I had this same problem with my 120gig HD full of information i just didn't want to lose.

I followed Mrkobie's directions for me and it fixed the problem perfectly. Thanks!!

A couple notes however: the ntfs.sys file is actually located under c:/windows/system32/drivers/ not in system/drivers

also... when renaming the file to ntfs.old, you must be in safe mode for the change to take affect. if you boot in regular mode and try to make the change, windows automatically reinstalls the ntfs.sys file.

Thanks again!
thanks to the information on this thread i passed the ntsf problem. I got the floppy installation set as mentioned in this thread. Found the file txt..but it was compressed as mentioned above.

Looked and found the file, uncompressed, in the i386 folder on the win xp installation cd.

Opened it in notepad and changed the file, commented out the ntfs.sys section under the [load]. saved it onto the installation floppy.

Set my bad hard drive as primary and inserted the installation disks. it mounted the drive. from there i was able to run chkdsk from the installation floppy repair mode.

disk was straightend out and i am using it right now. All my data was just where i had left it. saved hours of rebuilding.

Thanks for presenting the info that led me to a solution.

I think a bad cmos battery was the cause of my erratic hard drive behavior that resulted in the file corruption. Got a new battery.

Thanks again, and good luck on your repair. It can be done.
havent been any posts in the thread for a while, but it helped me greatly, and i thought id share my discoveries.

i had the same problem as most people here. an sata drive with bad sectors causing my pc to blue screen when ntfs.sys was loaded. the drive is my only sata drive, but not my only drive and it does not have my os installed on it. it has data on it that i absolutely cannot lose.

the data was bad to the extent that knoppix would not recognize the drive. i tried booting off xp floppies, but after installing the drives drivers on floppy #4, the setup would blue screen. i didnt have access to a pc with 2k/xp installed on a fat32 drive, so i was pretty much out of options. then i decided to try booting of a windows 2003 server cd. i was able to install the drive and chkdsk /r it and repaired the sectors.

i guess microsoft did something about the sensitivity of ntfs with 2003 seeing all the problems in 2k/xp
one ntfs solution

I had the exact problem described by many on a client's Dell desktop. I couldn't get beyond the blue screen even in Safe Mode. The following worked for me. I realise there are degrees of problems and this may not work for everyone.
I tested the maxtor hard drive with Maxtor diagnostics - came through perfect.
I removed all but video card, just in case
I entered Recovery Console with the XP CD (Home) and renamed ntfs.sys tp ntfs.old (in system32\drivers folder)and then copied WINDOWS\ServicePackFiles\i386\ntfs.sys to the system32\drivers folder. Rebooted and was able to enter in Safe mode - just barely, with explorer constantly crashing on me. They offered System Restore - did nothing (though I tried it)Most options ( even My computer| properties) were inaccessible, BUT I could enter Task manager (with Ctrl-Alt-Del) and enter File|New Task(run). I set up a checkdisk as recommended by MS (chkdsk /f) which came up after the next reboot.
I then ran: sfc /scannow (see;en-us;318378). A restart and I was very happy to see everything back to normal. This may not be the easiest solution, but heh, it worked!
Yed's stuff works

I thought I'd try Yed's instructions from Microsoft while I was waiting those few seconds it takes Knoppix to download(!), and it fixed it. Marvellous.

The only point I'd make is that if you have to copy and edit TXTSETUP.SIF from your XP startup disk, make sure that you delete (or rename) TXTSETUP.SI_ or the installer just uses that one anyway and you still get a BSOD for all you trouble.

Rename it and the recovery console loads OK, allowing you to CHKDSK etc.

Thanks to everyone who has put so much effort into this thread. If only I'd seen it two weeks ago - when I rebuilt the PC from scratch to fix this :blush:
[CENTER]Found a fix for my XP pro machine, hopefully someone else can bennifit.

I had the same problems as above.
Could not boot to XP ntfs.sys error
Every time I tried to re-install or access command console it blue screened.

From reading above I created 4 boot disks from a Windows 2000 Cd. Why I didn't use the CD alone ( I have no idea) :knock:

I ran the install from the floppies and instead of installing I did a repair via the command console and was allowed to access the drive. (did not ask me for a password) I attempted to run Chkdsk but it couldn't find the autocheck file to run. I mapped to file which I knew was on my Hard drive. It look like chkdsk attemtped to run but errored out with some type of dll error. ( I am guesing 2k and XP uses a different file to run chkdsk) .

I then rebooted the machine and went into safe mood. This time the machine let me logon. I then did a restart and used my XP cd to repair and run chkdsk.
After that I did a restart and the machine was fine. I know this will happen again so I spent yesterday backing everything up and will rebuild machine this week. [/CENTER]
Found a fix for my XP pro machine, hopefully someone else can bennifit.

I had the same problems as above.
Could not boot to XP ntfs.sys error
Every time I tried to re-install or access command console it blue screened.

1. Building new system: AMD 2600, Shuttle MN31L, KByte 2700 512M, WD120M, MSI 52X CDRW.

While install WinXP PRO the system BSOD throughout installation.
Once, I able to complete Windows installation and was installing the MB cd drivers and BSOD. After rebooting got error message 'C:\windows\system32\config\software'. I fdisked the drive and started over. And now have tried 5 times to get an error free installation.

I have changed memory,cpu, cdrom and will change hd next.
I modified cmos several times. But have not updated the bios yet.

This is brand new equipment, all have been retested in another system on different MB.

If anyone is familiar with known issues with this configuration or similiar configuration, please help.

Thanks in advance
I have the same problem all you guys have, with the exception that I have it repeated 3 times. All three machines are Compaq NX9010 laptops. I can get into the recovery console using the Win Xp boot CD. if I type DIR all I see is one file. Can any one please help me! and if possible give me step by step instruction.
Same problem with NTFS.sys error

What causes this error? Hardware? If so, what hardware! I have the same error. I am replacing my motherboard since it is under warranty and replacing my XP Pro disk as well.
I have had to replace 3 laptop hard drives in less than 3 weeks. Thank God for extended warranty! All these HD drives die exactly at their one-year mark. I am sure this is not a coincidence THANKS MICROSOFT! :hotbounce
After the HD is replaced and OS reinstalled everything works well!
The only solution I know of

I feel that the solution I am about to provide is probably the best one there is.. so here goes:

Before I start, let me tell you what I DID try first... I tried to use recovery console for Win XP as well as Win 2000... it didn't go anywhere.. same blue screen. Then I tried to re-install both XP and 2k.. again... same thing... Finally I tried to put my harddrive into another PC as slave...hoping I will be able to just access my drive under that computer... NOPE! It didn't even matter that the operating system and boot-up was being done on the other drive.. the mere existence of my drive on that system also gave it the same blue stop screen.. I even tried some boot-up software called PE... and same thing.. finally... this was the solution... (if you WANT to save your DATA - if you don't care about the data.. just format... but if you want your data.. this is what you MUST far as I know)

I used Active Uneraser 3.0 and it has an option where it will make a bootable cd image of the software.. which takes a minute to burn... You boot-up using that cd.. and it will let you either make an image of the entire harddrive..(that option for my 60 gig would've taken 33 hours...sending to an external HD) OR you can pick individual folders and copy them over to whatever drive you want.. I used a USB one in my case... and I was surprized the software supports USB drives... in DOS... so yeah.. I'm copying right now... folder by folder... its tedious.. but if you want your data.. thats what you have to do.. after that I plan to format the old HD and always keep backups and emergency bootup discs available...
the problem... but I'm happy with my solution..
I think Norton Disk Doctor and all that crap was the problem. Removed it and this PC is much faster now :haha:

btw tnx for the solution to the prob :)
I've had the same problem, but in XP home. The problem has happend twice in one week. The first time it happend the system partion was Fat32, so I formated, after running chdsk in recoverory console, to NTFS(Not a quick format)

Well, it was running fine, since I partitioned the hardrive, most of my stuff was still there. I just had to reinstal drivers and programs that need regestry values.

A few days later, there were a few power falures, I figured that might have been the problem, but it was the same blue screen, woulden't load in safe mode. However, the one thing that was diffrent was that CHKDSK actualy showed a percent and took time to look at the partion, got to 50% and poduced unrecoverable erors (Before it just instantly said that the partion was bad).

I formated, reinstalled, and now it is running just fine. But I wonder if it was just a fluke that it happed twice, or is there a bad sector on my hardrive? If it is this ntfs.sys that is the problem, I'll try that replacement if it dies again. But please give me some answers to weather this is a hardrive problem or not.

I'm realy going to scream if it dies again, some of my stuff takes a long time to install.

A friend of mine found this, I'm going to try it if it happens again, but use at your own risk:

The Problem:
Recently, a friend of mine had a problem with Windows XP.
The computer would not start and presented a blue screen with an error 0x024 in ntfs.sys.
You could not even start in safe mode, a new installation using WinXP or Win2k-CD stopped with an NTFS-error as well.
I did some research and found some people who had the same problem, but no real solution. Microsoft has some Troubleshooting information but this looked like a lot of work and probable data-loss (check references). I did not have that much time since I wanted to start off into holidays the day after.
Detailed problem information:
What I found out:
If your hard disk is okay (no hardware failure), it is most likely that the error occurs due to a corrupt NTFS-filesystem. This could occur because of a dirty shutdown, a hang-up or something similar.
Current Journaling file-systems should prevent such errors but they can happen nonetheless.
So, there is an error in the filesystem that Windows is not aware of. When it starts to mount the partition with the corrupt filesystem, the computer hangs (bluescreen).
The solution: my suggestion:
(Please be aware that you try this on your own risk. I will NOT take ANY GUARANTEE that this will work or that your data will not take any harm. It worked for me, but that does not guarantee anything!)

Get a Knoppix image and burn it to a CD. You might know someone who already has one.
Knoppix is a Live-Linux, means a Linux that starts directly from CD without writing ANYTHING to your hard disk.
Just insert the CD and restart your computer. If Windows still boots up, you have to enter your bios and change the boot sequence. CDROM boot must be BEFORE hard disk (e.g. IDE-0).
Knoppix will boot up and will most likely find your hard disk (I could even mount and read it). Currently, Linux does only offer NTFS read support. With Knoppix you can easily save your data over a network to another computer. You should in EVERY case do this to prevent data-loss!
Anyway, the NTFS write support is currently in development. On the Knoppix-CD also is the package ntfs-tools, which contains ntfsfix.
Due to the development status of the NTFS-Linux Project, write support of NTFS could corrupt the NTFS-filesystem which is written.
ntfsfix marks the partition and when Windows boots again, it will check the disk (chkdsk) automatically, which is exactly what we could not do before because Windows hung just before.
1. Boot Knoppix
2. Open Shell
3. Type "su" and press enter. (this makes you root)
4. Type "cfdisk" and press enter.
5. You will see all your partitions on your hard disk. They are e.g. hda1 (probably your C:), hda5 (D:) ... Check those where filesystem is NTFS.
6. Write these down! You should then have a list like: hda1, hda5, hda6
7. Exit cfdisk.
8. Now type: "ntfsfix /dev/hda1" and press enter.
9. Do this and replace hda1 with all occurences on your list.
10. Close Knoppix and reboot.
Windows will boot up and it might take quite a long time while the screen is black. As long as the bluescreen does not come up, everything is okay.
If Windows finally starts okay, you should be done.

Now if only I could find my knoppix CD....
Dyamalos- I hate to break it to you, But the only fix I have found to this problem is to replace the HD. I tried formating the drive (not a quick format) and reinsatlling the OS. As you said it will work for no more then two days and crash again. So far I have had to replace 6 HD in less then 2 months on 6 laptops. After the new HD and OS is installed all is well.
I'm sorry I do't have any quick fixes!
As stated, both of the times windows died was due to an improppor shutdown. The seccond time the power did go off. It has ran a week fine. I have restarted for some of the programs I had to install. But if it does happen again, I think that I will try that meathod I posted. (Would post the link but alas, can't)

Also, laptop hardrives can breack for a number of reason, this is a full PC, not alaptop. (I've had my share with laptops...and a bad one at that)
I'm having the same problem but none of the solutions i've found online seem to be working.

1) Booting up from windows XP cd wont work because the recovery console isn't there.

2) I booted up with Linux (knoppix) and ntfs isn't working at all.

"Processing of $MFT and $MFTMirr completed successfully.

NTFS volume version is 3.1.

Setting required flags on partition... OK

3) I tried to use captive-ntfs but it isn't working either. It's quite a friggin pain in the ***. I've tried downloading the files via captive drivers acquire thing, i tried using the drivers from my windows xp cd (in the i386 folder) but captive-ntfs isn't working!

4) ....i don't know what other solutions there are.

Please help me out...i don't belieieve just trying to delete/rename/replace ONE file on an ntfs system is such a PAIN in the ***.
If there's a writable-dos-ntfs-boot thing, that would help plenty.

My HDD is working fine as i can access it via knoppix.

Thank you
Not open for further replies.