Spread the love! TechSpot Tech Gift Shortlist 2017

Cannot boot xp. ntfs.sys blue screen 0x00000024

By hed ยท 134 replies
May 7, 2003
  1. tacoman359

    tacoman359 TS Rookie

    Alright, Knoppix finished downloading. I tried to follow the instructions on http://www.retosphere.de/tipsandtricks/ntfserror.php?menu_id=24& but I didn't see any shell, so instead I went to K Menu, System, Shells, then clicked on Bash and typed in su in the thing that popped up. It showed me my partitions, one was a Dell Utility, one was NTFS, and one was Free Space. I wrote down sda2, because that was the NTFS one, and continued along with the steps. Now, I exited the shell and opened up K Menu and so on again and clicked on Bash, typed su, then typed ntfsfix /dev/hda2, but then got very confused. A few errors came up:
    Failed to determine whether /dev/hda2 is mounted: No such file or directory
    Mounting volume... Error opening partition device: No such file or directory
    Failed to startup volume: No such file or directory
    Attempting to correct errors... Error opening partition device: No such file or directory
    Failed to startup volume: No such file or directory
    Volume is corrupt. You should run chkdsk.

    But I was just confused on why he was telling me to type /dev/hda2 when I thought it was /media/sda2, it must be different on different people's computers. So I tried ntfsfix /media/sda2 and just got a bunch of errors again, but this time a little different:
    Mounting volume... Error opening partition device: Is a directory
    Failed to startup volume: Is a directory
    Volume is corrupt. You should run chkdsk.

    Can someone please explain to me what I should do next?

    Edit: Okay, I just tried it with ntfsfix /dev/sda2, and a different error came up, but I think I'm on the right track:
    Mounting volume... Error opening partition device: Device or resource busy
    Failed to startup volume: Device or resource busy
    Attempting to correct errors... Error opening partition device: Device or resource busy
    Failed to startup volume: Device or resource busy
    Volume is corrupt. You should run chkdsk.
  2. tacoman359

    tacoman359 TS Rookie

    Alright I ran NTFS4DOS again and this time it didn't freeze with chkdsk. Then, I deleted ntfs.sys and copied ntfs.sys from my other XP Pro computer, but it didn't work. I got an error saying that the file was corrupt or missing the next time that I started Windows. Dell didn't send me a Windows XP Pro installation CD, so I need to buy one to repair that file. I'm not sure why deleting and copying the file from one computer to the other didn't work, it must change the file or something with certain preferences. I'm going to try ntfsfix in Knoppix again while I wait for my installation CD.

    Edit: Ntfsfix worked, it said that it failed to mount the partition or something like that, but it fixed it. Now I just have to wait for my installation CD to replace that file.
  3. tacoman359

    tacoman359 TS Rookie

    I got my installation CD, but I didn't have the drivers for RAID and didn't know which version I had so I couldn't download them. I'm not even sure why I have RAID, I only have one hard drive. I went into Knoppix and enabled read/write on my hard drive then copied ntfs.sys from the CD onto it. The reason that it wasn't working when I was copying it with NTFS4DOS was because for some reason it was making it into a text file or something like that when I copied it from the floppy onto the hard drive. I noticed this because in Knoppix the icon appeared differently than all of the other SYS files. So in the end, I didn't really need an XP Pro installation CD, all I had to do was use Knoppix and copy the file to a floppy or CD from my other XP Pro computer. Just in case anybody is wondering, XP Home and XP Pro have two different ntfs.sys files, they are different sizes.
  4. ciplionej

    ciplionej TS Rookie

    Eppur si muove

    Had no Knoppix at hand but luckily a PCLinux from a CAELinux distribution CD saved my day.

    I could only get read-only acces to the HD so I backed the lot up. Then formatted the HD by using the installation application from this distro and once it was all nice and clean I could install from an XP CD whilst this was not possible before.

    Thanks for the tips!!!

  5. Withinside

    Withinside TS Rookie

    Great thread

    I've been running my ASUS A8N-Sli machine for about 6mths now, random problems here an there, no biggies. Recently I installed a brand firing new seagate 320G sata2 drive, with that installed a brand new fresh copy of win xp pro sp2 w/ key. Fully installed all updates, all updated drivers. Then did files and settings transfer wizard (OMG CANT BELIEVE IT WORKT). Then during all this, I noticed that the rear fan in my power supply didnt spin up, so I poked it, it started to spin, ok for a few days. So I got a new rocketfish 700W PSU, far exceeds capacity and capabilites of the old (safe power 600w?) junk. First boot with the new PSU gives me this same blue screen.

    A8N-Sli Premium w/ 1303 BIOS
    A64 X2 4800+ OC 2.6GHz 217x12
    Mushkin 2x2GB HP3200 DDR400 CR1-CL2-3-2-6-11-22 OC DDR433
    BFG GF8600 256MB x1
    nVidia nForce SATA2 controller:
    sata1 - Seagate 320GB SATA2 w/ new OS
    sata2 - Samsung 160GB SATA2 w/ old OS

    Anyone who's read about this MB knows what kinda headaches I probably have went threw already with it up until this point. I managed to get the machine fully working (w/out any of the bundled software!) perfectly, super fast, incredible machine. Now I think I have an idea on what my problem now is thanks in large part to this thread (Cheers guys :) but I still havent the slightest clue why swapping out the PSU would cause this, and it still happens with the old one. If anyone has any ideas, or has one of these MB's and needs some help of thier own getting it to run like it was meant to feel free to find me threw my regular channels, or here an stir up some convo.

    I'll lets you guys know how I fair out, thanks muchly again!
  6. rxmed

    rxmed TS Rookie

    having the same problem with 0000024 and ntfs.sys, can anyone tell exactly what they did to solve this problem
  7. Withinside

    Withinside TS Rookie

    Easy fix

    As it turns out, the file ntfs.sys was corrupted. I booted from the winxp cd, inserting my sata drivers when prompted. Then booted to recovery console. Ran chkdsk /r then after that was done I typed exit, I hit enter and it rebooted, then proceded to load up winodws normally (it asked due to previous load attepmt). As far as I can tell, I was gonna get this BSOD when I booted up the next time after shutting down to change the PSU anyway. My machine works great, and now with a new PSU (with all fans spinning). Thanks for the great thread folks, I don't think I would have faired out as good had I not found it.
  8. rajendrankadu

    rajendrankadu TS Rookie

    cannot boot xp. ntfs.sys blue screen 0x00000024
  9. rajendrankadu

    rajendrankadu TS Rookie

    cannot boot xp. ntfs.sys blue screen 0x00000024
  10. rajendrankadu

    rajendrankadu TS Rookie

    Stop 0000024 and ntfs.sys, can anyone tell exactly what they did to solve this problem. Help me to solve
  11. Darkwing

    Darkwing TS Rookie


    I am with 'livecurrent' on this one. I tried all of the suggested solutions from this site after my usual checks didnt work. Im not sure why i didnt think of the ram in the first place, but... well.... ah bugger it! lol
  12. williaml337

    williaml337 TS Rookie Posts: 24

    Fixes the master boot record of a disc.
  13. Darkwing

    Darkwing TS Rookie

    That's the one! :)
  14. Rio

    Rio TS Rookie Posts: 26

    Ok, i haven't read through 3 pages of replies due to the fact that I don't have that much free time on my hands.
    But, has anybody even checked Microsoft?
    This should solve everyones issues. If problems persist please feel free to reply to this thread, but i don't think they will (unless people don't read this)

    Quote from Microsoft:
    This is the solution for a similar issue, but involves changing the file system.

    Please let me know if this works for you. :)
  15. joker2120

    joker2120 TS Rookie


    My friends computer did this and now I am trying to help him figure out how to fix it....but he has a road block.....he can't find his disks.....now what should we do?
  16. Rio

    Rio TS Rookie Posts: 26

    Looks like you may have to buy a new copy...
    There is another option but I do not reccomend it.

    Or, there may be somewhere on the internet that has ntfs.sys on it..
    You just need to overwrite the old file with a new fresh one...

    Am at school at the moment so cant really help much, will check it out when i get home,
  17. Grundle

    Grundle TS Rookie

    I do this for a living and when I get a PC with a blue screen on "NTFS.SYS" I use Knoppix Live CD.

    First you have to get the Knoppix ISO file and burn it to a CD.

    Once you do, pop the CD in and boot up the computer.

    When Knoppix loads, click the Terminal Shell icon along the bottom.

    In the terminal window, type 'su' for super user, then 'cfdisk' to identify the NTFS partition(s), and then type 'ntfsfix /dev/hda[n]' where [n] is the disk/partition number, example hda1.

    If you get messages about failure to mount then you need to unmount the disk. Simply right-click the disk icon (eg, hda1) and choose Unmount from the menu. Then go back to the shell and try the 'ntfsfix' command again.

    Then boot to a Windows CD and run chkdsk /r on the drive.

    Works like magic!
  18. davros72

    davros72 TS Rookie

    Hello another person with the BSOD/ntfs.sys error!

    I've read all the previous notes and decided to go down the knoppix route mentioned in a few other posts. Like some other people I'm having read only problems. I've done 'su' and am root when typing 'ntfsfix /dev/hda' but it makes no difference.

    Could anyone help with the following please:-

    1) Where do I find my hard disk within Knoppix?
    2) How do I change my hard drive so it is not read only?
    3) Should I change my hard drive so it is not read only?

    Any help to resolve this frustrating problem would be greatly appreciated.

  19. Rio

    Rio TS Rookie Posts: 26

    This may sound stupid, but have you just tried putting in your Windows CD (computer already running) and copied the original ntfs.sys onto your HDD overwriting the old one?
    That worked for me once.
    It all depends on what is causing the error within ntfs.sys on which i am no expert in reading the logs.
    Thats all i can help you with, sorry.

  20. davros72

    davros72 TS Rookie

    Thanks Rio but regrettably using my windows cd only takes me back to the BSOD. I can't access safe mode or the recovery console, so the Knoppix solution seemed like a good one.

    Have remembered some of my Linux training and have found the /dev/hda folder now, used chmod to change the permissions of these files so that they are 'rwx' but it still says the disk is read-only. Aaaaggghh!!

    In one of the previous posts it mentions right clicking the disk icon? I can't see that on screen - does anyone know where it is? Having said that the main problem seems to be this read-only one which if I can get around may lead to a solution!?

    Is there anybody who had this problem and got around it or anyone knows how to get around it. I don't want to be defeated and have to surrender it to a repair shop but if that's the only route....!
  21. davros72

    davros72 TS Rookie


    Is there anyone reading this thread that can help with the read only problem when using Knoppix? All help gratefully received!
  22. davros72

    davros72 TS Rookie

    Ignore Me!

    Ignore my previous posts please!

    I plugged an external hard drive in last night and Knoppix found it straight away so it would appear my problem is now to do with my hard drive. As Knoppix doesn't find it I'm fearing the worst.
  23. davros72

    davros72 TS Rookie

    The end

    So just to let anyone reading know the outcome of my tales!

    I took my pc to a local repair shop and just told them about windows being stuck in a loop, within 10 seconds they had mentioned it may be the hard drive. After running some tests it was confirmed that the hard drive had indeed died. At least I had the satisfaction of knowing that my guesses were right!

    I would recommend anyone reading this to follow the Knoppix route. You will at least be able to ascertain whether it is your hard drive or not. If it isn't you can retrieve your data and then hopefully sort the problem out yourself. If it is at least you know what you need to do.

    Thanks for reading.
  24. DrMcNugget

    DrMcNugget TS Rookie

    I have posted this in another forum, but as this was the thread in which I got the idea to try Knoppix, I am reposting my question here:

    I am trying to use a Knoppix CD to access my files locked on my computer during a NTFS-related error. I have downloaded an ISO and I have burned the CD successfully and Knoppix loads like a dream.

    However, Knoppix's default font is so huge that I can't navigate the system. I'm a moderate computer nerd; though I am brand-new to Knoppix, I could easily and confidently follow the instructions I have if only I could read the words on the Knoppix screen!

    Can anyone offer any easily-understood, step-by-step directions for how to shrink the text size? I have been Googling forever, but I haven't come up with anything I can understand.
  25. Dodgey

    Dodgey TS Rookie

    Hed... looks like I have the same problem, are you saying that you can use the win 2x boot discs to boot xp? if so, where can I d/l one from for cd or dvd?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...