1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Cannot boot xp. ntfs.sys blue screen 0x00000024

By hed · 134 replies
May 7, 2003
  1. mboruza

    mboruza TS Rookie

    so far, I think easiest solution to this is NTFS4DOS (http://www.datapol.de/dpe/freeware/). It took me less than a minute to download it and use it to create a bootable floppy, plus a few more minutes to reboot the PC with it and on command prompt use the command "chkdsk c: /f" and "chkdsk d: /f", then reboot and .. done! all and all around 10 minutes (more or less)... :cool:
  2. jreedar

    jreedar TS Rookie Posts: 17

    ntfs.sys bsod error

    I installed ZoneAlarm firewall and during the install it said that one part coudn't be installed completely because I wasn't administrator (however I was) and it continued installing and finished. Later that night I started to get the BSOD for ntfs.sys. I was able to boot to safe mode with no problem, after finding this forum I've booted with my original W2K installl disk and went to "Repair a Windows 2000 installation Using Recovery Console" I'm currnently running chkdsk /R on all my partitions, I've done 4 of the partitions and have 2 left but had to leave for work this morning. My question is what should I do next?

    Should I do the suggestion of the first post of this thread: How to: Repair Windows XP/2000 if you are unable to boot into Windows. ???

    Also at work I'm also running W2K pro and I could copy my "C:\WINNT\system32\drivers\ntfs.sys" file and try to replace the one on my home computer if that will help?

    I also read in this post about doing a 'fixboot' from the Recovery Console, is that an option I need to try?

    I just want to get back to normal without having to reformat or loose any data. While in Saftemode I did follow all the manual removal steps of uninstalling ZoneAlarm from my system and registry. I think my hard drive is not damaged since I can boot into SafeMode with no problems and I've successfully run chkdsk /R on my partion I have windows installed on and a few other partions and they don't get any errors.

    Any advice on how to proceeed would be greatly appreciated!
  3. ASMx4

    ASMx4 TS Rookie

    2 cents

    I'm sure this thread will continue on as long as XP does so here's my solution;

    I was able to get back into xp and set the page file to "No Page File"

    Right click My Computer and select Properties
    Advanced Tab
    Settings Button
    Advanced Tab (again)
    Change Button (Under Vitual Memory)
    Highlight your C drive
    select No Paging File
    click Set
    OK OK OK reboot.

    Well, it's been working MUCH better since doing this an hour ago. Played Call of Duty2, Ran SFC, Ran chkdsk; solid as a rock. (I couldn't do crap without it BSOD'ing before.)

    Bookmark this, though... http://www.retosphere.de/tipsandtricks/ntfserror.php?menu_id=24&
    It's gonna save yer booty someday. :grinthumb
  4. AlanSE

    AlanSE TS Rookie

    Easy Fix

    I struggled with a number of Windows options to fix this problem. I had read a post by evil_penguin on PCStats, but wasn't sure about downloading and running Linux. But it was well worth it, and pretty easy, especially since I have a laptop and putting the drive into another system wasn't a great option.

    1. Download Knoppix from Knoppix.org (this is a bootable CD image).
    2. Burn the CD.
    3. Boot your down computer from the Knoppix CD (if you have a problem with this see some earlier posts for updating your BIOS options).
    4. From a command prompt run 'ntfsfix /dev/hda1'.
    5. Shutdown Knoppix and remove the CD from your computer when complete.
    6. Reboot your computer from the harddrive. My experience was that I had the option of booting normally or in Safe Mode. Booting normally asked me to run chkdsk which I did. System seems fine now.

    Downloading 600+ MB takes some time . . . but this was really pretty painless. I too wish I had done it first.
  5. geminihc

    geminihc TS Rookie

    thnx for everyones advice! veyr helpful, i had the same prob

    HOWEVER, i still have a problem

    I used knoppix to fix my ntfs. So, I restart, go into chkdsk screen. But its stuck at this step saying:

    CHKDSK is verifying indexes (stage 2 or 3)...
    Correcting error in index $I30 for file 2179.

    its like it cannot fix it or something, but it doesnt say anything nor continue and is just stuck there. how long should a chkdsk take after doing the knoppix thing?
  6. DimebagUK

    DimebagUK TS Rookie

    Nearly fixed

    It's currently 4:30am and I've been battling with this since about 10pm...

    I am though nearly there, and this thread has helped a great deal. Knoppix has allowed be to force view my files on the usually disallowed partition even though it says it is "dirty". However, even after using the step by step tutorial and having used ntfsfix when I attempt to boot Windows XP afterwards I still get a nice little BSOD 0x00000024 error.

    Could anyone figure out why this might be? When I try and rename ntfs.sys in Knoppix it says it cannot be deleted... Therefore I cannot replace it.

  7. Honour

    Honour TS Rookie

    Same prob....

    Hey peeps I'm (obviously new here) I have the same stop error problem 0X24. I've bee scouring this and other posts but am having trouble getting any of these solutions to works for me.
    Dell 8400, XP, will not start at all safe mode or nothing.
    I DO NOT have my XP disk, apparently Dell doesn't send them anymore.
    I can get to DOS prompt using my old ME install CD.
    I do not have a floppy drive.

    I tried this solution....
    I get Knoppix up and going but when I try to do a cfdisk, It says I opened this disk read only and do not have permission to write.

    Am I doing something wrong? Anyone got any other suggestions. Your help would be greatly appreciated.
  8. Trueblood

    Trueblood TS Rookie

    Anyone found the solution?
    I might be doing something wrong, or just completely missing something, but here's what I've tried. (I've tried everything in Knoppix 4.0 and 5.0)

    I open the terminal and go to superuser, then cfdisk, and right off that bat i get an "Opened disk read-only - you have no permission to write" error.

    I have tried using the Termial Program, su, then ntfsfix /dev/sda2
    (sda2 is just a guess, all of my personal files are on this drive accesed from the knoppix desktop. sda1, and sda3 do nothing.)

    When I do this I get the following:

    Mounting Volume... Failed
    Attempting to correct errors...
    Processing $MFT and $MFTMirr....
    Reading $MFT.... OK
    Reading $MFTMirr .... OK
    Comparing $MFTMirr to $MFT ... OK
    Processing of $MFT and $MFTMirr completed successfully.
    Setting required flags on partition ... OK
    Going to empty the journal ($LogFile) ... OK
    NTFS colume version 3.1
    NTFS partition /dev/sda2 was processed successfully.

    then I reboot, and get the x24 error every time.

    Now if I go to my sda2 drive from the knoppix desktop, mount it, I get a warning that says "Volume is dirty. Forced to continue"
    I then right click and hit Change read/write mode and I get an error
    that says "The remount command failed/ Maybe there is another process
    accessing the filesystem currently"

    My understanding of all of this is limited, but is there anything that i am doing
    wrong? or anthing else I can try?

    Thanks for your time!
    Logan Trueblood
  9. GazzaH

    GazzaH TS Rookie

    Hi All,
    This site was a good help, so I'd like to briefly outline what worked for me after many a wasted hour on this crappy problem.
    There are similar posts here but the more solutions the better I spose:
    - I had the bsod: ntfs.sys stop error
    - I have a single NTFS SATA (maxtor200g) hardrive (Sil3112 chip, GA-8KNXP Mobo)
    - WinXP Pro SP2

    I tried the knoppix solution to no avail, although it could read by ntfs disk. See the link earlier in this thread - and make sure to 'su' for those before getting the read-only error when using ntfsfix /dev/whatever.

    So, I dutifully downloaded the XPsp2 pro 6 disk floppy creator from MS -

    Then, time to edit the txtsetup.si_ (not .sif) on the boot disk #1. Yes, it's compressed so won't be editable in notepad right away. I just extracted using winrar (trial version - free), but others say you can use dos expand. Either way you are left with a plain-text file. Open that with notepad, delete any empty lines from the top which the uncompress may have left. Then search for the part:

    fat = fastfat.sys
    ;ntfs = ntfs.sys

    and add the semi-colon as shown above.

    Now, save this edited file as txtsetup.sif on the floppy where the original file was, and delete the original.


    If you have a sata disk, you'll need SATA drivers. I used the non-RAID one from here - for my gigabyte mobo:
    Put all of this on a (7th!) floppy.


    autochk.exe is a routine needed by chkdsk, but it's not on the xp boot floppies, or at least mine wasn't found, so I copied it from /windows/system32/ onto another (8th) floppy from my friend's computer - xp pro.
    You can probably find it somwhere on the internet if you don't have another windows machine handy. Or get someone to email it to you..etc.

    So, now you should have either 7, or 8 disks ready to go, (8 if you have sata drivers on one.)

    OK, go into bios, and set the first boot device to floppy.

    Start loading setup from the floppies.
    Hit F6 if you have SATA when it mentions SCSI/RAID stuff. Nothing will happen, yet, but after disk 5 or 6 you will be asked about the SCSI/DiskController. Press S, then insert you SATA driver disk. Press Enter. Now back to the loading...snore...

    Eventually it will say 'welcome to setup blah blah'. DON'T HIT F10. That would start an install. Press 'R' and cross your fingers.
    Hopefully you will get a prompt. If you don't, then your SATA disk may not have been found - your drivers may be wrong.

    Assuming you have a prompt - well done!

    Type 'dir'
    Mine said 'An error occurred during directory enumeration..'
    but that's OK! Cos we already knew the disk was shagged.

    The thing we've all been waiting for:
    chkdsk c: /p

    It will say, (for me, after a couple of mins):
    "AUTOCHK.EXE could not be located..."
    "Type the full path..."

    So put in your autochk.exe floppy, and type in:

    and away we go...

    Now I'm no expert on chkdsk, and I'm not even sure if the /p option does fixes - some posts say it does, some say it doesn't. But, the /r option certainly does, but it takes a VERY long time. I ran chkdsk c: /r and went to bed. Next morning it had finished.

    I ran chkdsk /p in the morning and it said there were still errors, but when I pulled out the floppy, and restarted windows, it loaded.

    I'm going to make myslef defrag, and run chkdsk about every month as a result.
    I shall never buy a Maxtor HD again (I believe it is doing bad writes occasionally, corrupting the ntfs.sys), although I hear seagate are buying them or already have (?) so maybe quality will go up.

    Hope this helps someone.
  10. Trapper Dave

    Trapper Dave TS Rookie

    Exactly the same as me; did you fix it in the end?

  11. Trueblood

    Trueblood TS Rookie

    I finally got home and got my xp disks. Then used them to run chkdsk, everything works ok now.
  12. Trapper Dave

    Trapper Dave TS Rookie

    See, I've got the problem that the Windows XP CD application freezes. I'm getting some spare disks sent out, but I can't see that fixing the problem, as I've already tried another disk and that does the same.
  13. snoopsmsc

    snoopsmsc TS Rookie

    Just a small addition to GazzaH's post. I had the same error (though not with a SATA drive).

    However, when I tried to use the XP boot disk set, I kept getting all sorts of errors (could not load this file or that file, The error code is 7. After I resolved that one, The error code is 1024), so I decided to bag using the XP boot disks and try making a full installation cd with a modified txtsetup.sif.

    I copied all files to a hard disk folder, then use IsoBuster to get the boot image off the disk, edited txtsetup.sif, and put it all back together with Nero.

    I followed the general idea of creating a slipstream XP SP2 installation, but instead of making the slipstream, I edited txtsetup.sif. I used the instructions found here:


    Then, I booted up to this CD, and followed the instructions from GazzaH's post, and I was able to check the volume using chkdsk /r.

    Kudos to GazzaH!
  14. kitkat92627

    kitkat92627 TS Rookie

    I need help booting up. I have a resource CD Microsoft Windows XP Home Edition Service Pack 2, and Dell Deminsion and XPS Resourse CD. Can I use one of these CD's to boot up, and if so, will all my information be saved that is stored on my computer. Any help would be appreciated.

    Thanks, K
  15. yourefree

    yourefree TS Rookie

    knoppix additional info

    In order to run ntfsfix you need to unmount the hard drive (right click and click unmount). I couldnt get it to work - received the common error from other posters about not being able to connect. It took me a while to figure out that this was because knoppix had the drive mounted and therefore it was in use. unchecking mount and then running ntfsfix worked. Knoppix seems to be a nice OS and especially for fixing windows issues. For those people reading this for the first time try knoppix and unmount the drive (it is easy) and run ntfsfix. Good luck.
  16. RussE

    RussE TS Rookie

    Hey anyone, I've got the same problem with a friends PC. He has taken the HD out and I've got it in a USB I/O Magic. When I plug it into mine I get the Beautiful Blue Screen. Figure there has got to be a way to disable the "auto-boot" for this external so I can get in and do a chdsk. Any Ideas would be greatly appreciated.

  17. doulos

    doulos TS Rookie

    My Solution

    Just thought I would add my solution since this forum topic helped me out so much. The ntfs.sys BSOD appeared during boot up at random times. BART PE ran fine except when it accessed the HD. Since the problem was random, I was able to keep rebooting BART until I had backed up all essential files. Reinstalling/repairing XP always blue screened.

    Reformatting the drive didn't help. Swapping it out for a known good one didn't either. Re-seating cables and memory cards failed as well. I finally got things working when I swapped out the memory. Never have seen memory go bad before.

    Dell Dimension 5100, 2.8GHz Pentium 4, 2 x 256MB Infineon DDR2 SDRAM 400MHz (PC3200)

    This shows that multiple causes can produce this symptom.

  18. ufact

    ufact TS Rookie

    Similar problem with Blue screen 0x00000024

    My PC runs on XP Professional SP2. I just replaced the 2 hard disks about 6 months ago.
    I upgraded ZoneAlarm Security Suite from V6.5 to V7.0. Somehow, through reasons still unknown, ZA pro was installed instead. Once I find out the mistake, I reinstall ZA Security Suite after my son installed a software called "Matlink". First, I found I cannot log into other user account. The next thing is the PC stalled for more than 10 minutes before I decided to restart.
    The blue screen with the technical information "***stop 0x00000024 (0x00190203, 0x876f48B0, 0x0000102, 0x00000000)
    A search on Microsoft knowledge base suggests it is a corrupt nfts.sys file.
    I followed the recommendations on one site:
    1. Set up BIOS to boot from CD-ROM.
    2. Boot from XP Professional setup CD.
    3. Press R for recovery console.
    4. Type the following command line: copy X:\Windows\i386\nfts.sys C:\windows\system32\drivers where X is the CD drive
    5. No luck as this line keep coming up "System cannot find the file specified"

    I believe I may be on the right track but I must have missed something. I followed strictly all the space when I typed the command line.
    I have been working on this topic for the past 5 years as I am desparate to get the PC working for my son.
    Once I can boot into the system, then I can uninstall ZA Security Suite V.7.0 and reinstall V6.5.
    Hopefully, someone can show me how to boot into the PC without reinstalling Windows!

    Many Thanks!
  19. GomerAssassin

    GomerAssassin TS Rookie

    I'm new and I need big help.
    ntfs.sys and i can't get into the RC. BSOD shows when I press R at the cd boot. What can I do? I tried booting from floppies too and same thing. How else can i get into the RC? If I try to re-install xp. Same BSOD.
  20. frizank

    frizank TS Rookie

    ntfs.sys nightmare is OVER

    Hey everyone, brand new to the forum. I've been reading this thread for a while trying to get past the ntfs.sys BSOD 0x00000024 stop error - after trying some of the proposed solutions (with no success) I did something else that was far less complex that did the trick for me. I run XP Pro SP2 (NTFS) and my situation was this:

    I COULD NOT boot normally without going to the BSOD
    I COULD NOT boot to safe mode without going to BSOD
    I COULD NOT boot to recovery console via XP CD without going to BSOD
    No matter what, it was BSOD over and over....I COULDN'T DO ANYTHING!!!

    I got myself an external enclosure, installed my SATA in it, then plugged it into my laptop running XP Pro (NTFS) via USB. Make sure you are all booted up, etc before plugging in the drive - don't chance booting off the crapped drive! Once recognized, etc I pulled up my command prompt and ran chkdsk on the bad drive with the /R switch which locates bad sectors and recovers readable info (type chkdsk /? if you want to see what all your options are and what they do). After it finished I installed the drive back into my computer and POW - normal boot up. Chkdsk had repaired my corrupted ntfs.sys associated file structure.

    I would like all to know, though, that I tried the Knoppix solution first (also posted somewhere in this thread) and managed to dismount my drive in the process. I later discovered that doing this renders all the open handles as invalid on a drive. So when I slapped the drive into the external enclosure and tried to read it from my laptop, it showed 0 bytes used. Basically that made it appeared as though there was no data on the drive (scary but I knew because I hadn't done anything like format the drive). The only reason I mention this is because I am unsure blowing away the open handles previously in Knoppix actually helped the situation. SO, if you follow the steps outlined above and still can't boot off your drive, Check disk in Windows does have a /X switch (forces a dismount first if necessary) that accomplishes the same exact thing withouth having to jack with Knoppix. So basically, run chkdsk <drive volume> /r. If that doesn't work for you, run chkdsk <drive volume> /r /x and see if that does it.

    I hope this helps someone who was as desperate as I was to save their data. Starting over would have meant performing a level format then reinstalling the OS (in that order).
  21. spikey

    spikey TS Rookie

    Test Your RAM?

    I’ve had the same problem with my girlfriends PC that I was building her. Drove me nuts! I’m no expert, after looking round the net several treads suggested it might be the memory? I down loaded MemTest 86 (www.memtest.org/) and low and behold the memory stick that I thought was good had 13713 errors on it! New stick of ram and I’ve have had no problems with it blue screening or the NTFS error.
    I’d eventually swapped everything in the PC even the case out of desperation! I’d bought two sticks of ram, when I first fired up the PC I got a bleep telling me that the ram was dead. Tried the two sticks independently one of them worked and it fired up. Put loads of stuff on it, all going well rebooted quite a few times then the NTFS error!!
    I’ve learnt the very long, very hard and very expensive way (knacked a motherboard trying to flash the bios) test your ram!

    Hope this helps someone (It would have helped me)
  22. Trancidonia

    Trancidonia TS Rookie Posts: 31

    lol same here, having this thing since last thursday...

    being researching truout this thread and in the internet, but it's not really being helpful as i don't know which and what should i download from knoppix and had it burned it to my CD, i tried one of those 5.1 which is like 650++ and above and of coz i tried to set the boot sequence(CD-ROM in before HD boot), but somehow it just doesn't work.

    my cousin plug off one of either harddrive 40g 80g but it doesn't seems to work either, which means i'm missing something, or i download and burned the wrong thing into my CD which doesn't work either, anyway, means more researching and testing for me.

    If you guys able to found how and how and stuff, please do post em here, i'm gonna be around for a while before i decide to kill the pc or something which i don't really want to lol.
  23. AndrewGS

    AndrewGS TS Rookie

    I'm having the same issue but I can't get my other machines to stay running when I hook up my affected hard drive via USB, therefore I can't run chkdsk or remove my files. I've run diagnostics on the hard drive and it checks out.

    Any ideas anyone?
  24. laxman

    laxman TS Rookie

    Same problem but different

    I'm getting the same stop code thing I guess as every one else the 0x024, but instead of it having the ntfs.sys it says the error is in the atapi.sys. This is my strictly gaming pc so I didn't have anything too important on it so I actually wiped the whole thing clean and I still get the same error. Most of the time though I can't even get the bsod to even appear. When I try to install windows it will just reset itself. I have a hard drive with slackware linux on it and everything works fine with it. Except I'm not too familiar with how linux works and since a lot of the games tend not to work I'd like to get windows back up and running.
  25. tacoman359

    tacoman359 TS Rookie

    I am also getting the same error. I am running Windows XP Pro SP2. I'm pretty sure it's the hard drive because right before it started happening, a bubble popped up in the tray saying that a file was corrupted and to run chkdsk. I ran chkdsk, but my computer froze in the process and I had to hold the power button in to shut it off. Next, I tried booting into safe mode but i still got BSOD. Next, I tried running the Windows XP Home SP2 CD because that's all I have, but it froze after it finished loading all of the files. After that, I created Windows XP install/startup disks or whatever they are, but I couldn't figure out how to edit the TXTSETUP.SI_ file so I just put the disks in and after it finished loading, I could access all of the menus and everything without it freezing, but it said it could not find a Windows installation. Next, I tried the same procedure but with Windows 2000 install/startup disks, and this time I could edit the Txtsetup.sif file. After it finished loading the files, I still got the same error: it couldn't find a Windows installation. Next, I tried running Damn Small Linux because I figured it would be the same as Knoppix, but it froze. Next, I tried running NTFS4DOS. It was working great... It was about 50% done with chkdsk but then it froze. I tried getting to the command line to copy the ntfs.sys file over, but when I clicked on it, it came up with an error and brought me to chkdsk, which I didn't allow to run again because I didn't want to waste another two hours just to see it freeze. I might try running it again tomorrow. Right now, I am downloading Knoppix.
Topic Status:
Not open for further replies.

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...