Cannot load driver for digital camera... "error code 10"

By Jball ยท 15 replies
Jan 2, 2010
  1. Hello folks

    I have a Dell Inspiron 531 running Vista. _ (I have installed all updates)

    My Canon SX20is Camera cannot be seen by Vista. It is supposed to be compatible with vista.

    It says the drivers are loading, but then I get an error message saying they were not successfully loaded. and the "error code 10". I tried uninstalling and reinstalling

    Canon advised that vista provides the driver. I searched microsoft forums to no avail.
    It sounds like I have the correct drivers, but for some reason they are not running properly.

    Thru my research I think I may have a corrupt driver somewhere.
    I talked to someone in tech support and they said it is a dell issue.
    I searched their site and there are no drivers or anything too helpful.
    Can anybody help on this one ? Any help would be greatly appreciated.
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    i looked at the different drivers available for the Inspiron 531. Which links are you using/do you believe support that camera you want to use?
  3. Jball

    Jball TS Rookie Topic Starter

    I checked on the dell website (link below) There were no driver updates for cameras that I could see. I have the drivers that came with the computer, that I bought just over a year ago. When I go to the device manager these are the drivers that are present: Windows says these are correct : )


    (the libusb0.sys is not digitally signed)

    the forum wouldn't let me post a link....
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    This is a tough one. Not sure if i will be able to help find a solution but will at least try to take a look around at things....

    First off, i think you made an excellent observation. As there's a good bit of issue and confusion published on the web regarding Windows\system32\drivers\libusb0.sys

    So the first question is where is it coming from? My guess: It came when you installed the ZoomBrowserEx application

    Could you
    > Locate the file Windows\system32\drivers\libusb0.sys
    > Rt click it and see if you can see any version number or other identifying info about it
    > Now uninstall ZoomBrowserEx. Does the libusb0.sys file still exist? or is it now gone?

    > What happens if you connect the camera to the computer when ZoomBrowserEx is uninstalled. Same thing?
    > Look in Device Manager for the camera (it's probably under USB devices or Still Image Device). Does it appear? Does it have a yellow icon or not (the yellow icons mean a device error)

    /* EDIT */
    btw.. no drivers on the Cannon website, but i assume you downloaded and ran the ZoomBrowser EX 6.4.1 Updater?
  5. Jball

    Jball TS Rookie Topic Starter

    Hi thanks again for you assistance..

    The libusb0. sys was created in April of 2009 and modified in March 2007 ?

    I couldn't see a version though. I actually deleted the libusb0 file the other day, but it made my keyboard and mouse inoperable. So I did a system restore to get it back.

    The camera appears under portable devices as "digital still camera"
    the funny thing is once it appeared as "canon digital camera"....then canon disappeared, and it reverted back to digital still camera.

    I did download the zoombrowser updater, but zoombrowser didn't see the camera either.

    I actually removed all the cannon software and the libusb0 file is still there.
  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Hmm.. a closer look at the hits when Googling for libusb0.sys makes me think maybe it's not part of Cannon stuff but seems to be often downloaded for game controls (like for Sony Playstation) as well as for iPods.

    The library also seems to problematic for many people.

    > Click for how to determine whether you are running 32 or 64 bit windows. Tell me if you have 32 or 64 bit Vista

    > Do you have anything installed for game controllers or iPods? (don't try uninstalling if you do. just let me know)

    > Look in Vista's equivalent to Control Panel->Add/Remove Programs (i forget what it's called in Vista). But look through all the uninstaller listings. Do you see an uninstall entry for libusb.sys? (Do not try uninstalling it yet if you do)

    /* edit */
    btw.. before any attempt to repair this libusb problem, i would strongly recommend you create a disk image backup of your hard drive. In case of the worst, you can simply recover the hard drive image from backup and be back to where you are now. Note that System Restores can help but they are not backups. System Restores can sometime can get you back to a usable system. But often they can't as they aren't backups of everything.
    > EASUS disk copy is a good freeware disk image backup
    > Acronis True Image is an excellent commercial version (it can do more then EASUS tho EASUS is good enough for current basic needs)
  7. Jball

    Jball TS Rookie Topic Starter

    Hi , yeah the libusb0 file is probably from an ipod, which I do have.

    My Vista is a 32 bit system.
    and libusb0.sys does have an uninstall entry on my computer.
    I just created disk image back up of my hard drive.

    Thanks -Jay
  8. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    So we'll first uninstall libusb0. Once its no longer mucking with your USB devices we'll see if the Cannon works correctly. The libusb uninstall will (hopefully) be simple but you have the drive backup, just in case.
    > Shutdown computer
    > Unplug all USB devices other then USB mouse/keyboards
    > Restart in Safe Mode
    > Run the libusb uninstaller
    > Reboot

    Now try connecting your Cannon again.
  9. Jball

    Jball TS Rookie Topic Starter

    I did what you advised, but unfortunately it wouldn't uninstall libusb. It said that it is in a format unrecognized by this version of uninstaller. Wha do you think ?
  10. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Hmmm.. if the uninstaller can't remove this pesky problem, your best (and safest) choice may be to reinstall Vista (hope you have the restore / installation disks)

    Otherwise, a couple things to try (tho i can't reliably predict their results)

    Disable the driver
    This will prevent it from being loaded on reboot. (Unknown if there are dependencies requiring it when you run. Note "disabling" it is not equivalent to when you just tried deleting the file)
    > Download and install Serviwin
    > It must be run with admin privileges. rt click serviwin.exe, select Run as Administrator
    > Click View->Drivers
    > Find libusb in the list, rt click Change Startup Type. Set to Disabled
    > Exit and reboot

    Unattach libusb?
    Not certain if this applies to your case but found what appears to be attach/unattach commands for the driver/filter. You might try unattaching it and see if it helps. See this post

    The Vista reinstall may be the safest bet at this point...
  11. Jball

    Jball TS Rookie Topic Starter

    Hey thanks again for all of your help.

    I think I may go the reinstall route when I have some time. I do have the original discs that dell provided.

    any hints on what to look out for when I do the reinstall ?
  12. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    I think simply reinstalling Vista and then applying Windows Updates should get you back to a fully functional system (and one that should support the Cannon camera). I'm pretty sure it was libusb that was causing USB devices to fail

    As far as things for the future, i'm a big time proponent of investing in a backup product that can clone a hard drive image in addition to simply backing up files/folders. (e.g. i use Acronis True Image).

    Use Acronis to create a disk image backups (as well as providing you file/folder backup functionality as well)
    > Then you can fall back to disk image backup in the future rather than starting with a reinstall
    > You can also create a disk image whenver installing home-brewed, non-vendor installs (such as the one that included libusb - where libusb is rather flaky and problematic on Vista) so you have a fresh image backup for just this kind of emergency

    For more differences/advantage of clone backups vs. basic file backups also [post=791112]see this post[/post]
  13. gphantom

    gphantom TS Rookie Posts: 23

    Acronis the BEST.

    Using for 3 years now. Loving it

  14. gregory104

    gregory104 TS Rookie


    Having the same problem and didn't found a solution yet.
  15. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Problem might sound the same but you need to create your own thread along with your own specifics (about computer make/model, camera make/model, Windows version, etc) for any attempt for help
  16. choppy

    choppy TS Rookie

    I just resolved a similar issue with a Canon DSLR and Vista. It turned out to be Ipod/Iphone jailbreak software that installed libusb0.sys. Removing the jailbreak software allowed the libusb0.sys to be uninstalled and restored function of the Canon camera.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...