1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Can't Upload to Many Sites Anymore

By 'Ric ยท 29 replies
Mar 30, 2008
  1. For some reason, I can't upload pics or files to a number of websites (e.g. PhotoBucket, Yahoo Groups, Google, Blogspot, etc.) from my PC. My wife is having a similar problem on her Laptop. We upgraded our machines, so both of us are running Vista and fairly new to it. Both our accounts have Admin rights.

    McAfee Security Suite logs show no entries indicating anything has been blocked by it. Adding websites to trusted lists in McAfee, IE, and Firefox doesn't help.

    Typically, when we try to upload, we just get a blank screen with "Done" in the Status Bar in FireFox. IE just gives us an error page. An exeption is PhotoBucket, which acts like it uploads fast, jumping to 100%, but then saying there is no image. Viewing the error window sometimes shows an Access Denied to some function call and lots of warnings about undefined parameters. Searching on the error messages I get just takes me to pages that suggest the website content has errors. Since our problem is across many sites, I don't believe that they all are written badly, especially when no one else on them has these problems.

    My router/access point has a some filtering and fire wall capabilities, but nothing looks suspect.

    I have googled all over the internet and found no help. At this point I even suspect my Verizon DSL service might be pulling some upload-blocking stunt(?)

    Can someone look at my HJT log and tell me if anything is in it that might be suspect of blocking my uploads?


    Attached Files:

  2. 'Ric

    'Ric TS Rookie Topic Starter

    Anyone? ...Hello?
  3. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183


    I'll take a look at your log and tell you if i see anything. If there;s evidence of infection might leave it to the removal experts but want to get back to you with some feedback as i see your post seems to have been overlooked thus far.
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    Nothing jumps out at me as infection/malware although i do notice:
    Multiple Media Centers?
    References to what i think are different Media Center products? Question is do you really want multiple Media Centers (each which adds to/slows down your system startup). Suggest you look in Add/Remove Programs and remove media center installs you don't want

    McAfee Application Cleanup Service
    O23 - Service: McAfee Application Installer Cleanup (0206321206889046) (0206321206889046mcinstcleanup. See if this entry remains after reboot. Shouldn't stay there.

    Also advise you cleanup your browser and application cache/temp/junk files
    • Download CCleaner and install/run it
    • Look at the check list of things it will remove under the its Windows tab and Appications tab. You might not want it to delete all your cookies and history. It's up to you. Uncheck an item if you don't want to have it deleted.
    • Click Run Cleaner

    Flush your DNS cache
    - Click Start -> Run. Enter cmd. Hit return
    - Enter ipconfig /flushdns. Hit Return

    Reboot and see if any different.
  5. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    these need attention

    O4 - HKUS\S-1-5-19\..\Run: [Sidebar] %ProgramFiles%\Windows Sidebar\Sidebar.exe /detectMem (User 'LOCAL SERVICE')

    O4 - HKUS\S-1-5-20\..\Run: [Sidebar] %ProgramFiles%\Windows Sidebar\Sidebar.exe /detectMem (User 'NETWORK SERVICE')

    O4 - HKCU\..\Run: [Sidebar] C:\Program Files\Windows Sidebar\sidebar.exe /autoRun
  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    jobeard: just curious as to what looks wrong with Windows Sidebar

    ric: any change in the problem? I'm going to guess you have Windows Update running automatically? Do you know if Windows Update has been working correctly or is also having problems? If you're not sure, run it manually and see if it reports any errors.
  7. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    see this

    This is an undesirable program.

    This file has been identified as a program that is undesirable to have running on your computer. This consists of programs that are misleading, harmful, or undesirable.​

    and this
  8. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    now that's interesting.

    bleepingcomputer (a site i often use myself) is reporting based soley on filename. If we go to another site near and dear to our hearts look here it describes sidebar.exe as "Having this program run at startup is up to your discretion. If you find the program useful, you may want to leave it running at startup". (<=== Which is correct for the real sidebar.exe)

    The important distinction (which i'm surprised not found in bleeping or our own web site) is the directory sidebar.exe resides in.

    Desktop Sidebar\sidebar.exe is bad!

    Windows Sidebar\sidebar.exe is good!
  9. 'Ric

    'Ric TS Rookie Topic Starter

    I am running Vista. When I tried the ipconfig /flushdns it just comes back with "The requested operation requires elevation"

    Elevation of what? My User ID is already an Admin. However, I've noticed that with Vista the Admin rights are all powerful as they were and should be again.
  10. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    oh yea.. you have vista.. the joys of admin privileges

    here's a few ways to do it look here
  11. kritius

    kritius TS Guru Posts: 2,084

    just right click on cmd and select "run as administrator".
  12. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    i'm off to dinner

    will leave you w/kritius <== one of the malware experts should your problem actually be malware
  13. kritius

    kritius TS Guru Posts: 2,084

    And im off to bed, its 12.36 here and I have to be up in 5 hours or so.

    Will look at logs tomorrow if I get a chance. HJT was clean though last time.
  14. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    done with dinner and here's a few things
    1. Does Verizon DSL connect into your router/access point as well or does it have its own modem which then connects to your router? If the latter, case.. remove the router and connect directly to the modem and try
    2. Can you run Microsoft Update AND Windows Update successfully? (Try them both). If no, I think we should try seeing why that, in particular, isn't working
    3. Not certain just what error you're seeing in IE but here's a link to a good checklist of general things to try/see if they work/troubleshoot (especially trying your problem when in safe mode to see if it occurs)

    /*** Edit ***/
    By the way, when you said you can't upload "pics or files" could you be more specific? Is the problem only found with media files (pictures, movies, audio tracks / CDs), limited to just particular types (extensions?) media files? problem affects more then just media files?
  15. 'Ric

    'Ric TS Rookie Topic Starter

    I can't upload any pics to Photobucket.com or .pdfs to Yahoo Groups. In the error console, I get an "Error: uncaught exception: Permission denied to call method Location.toString" error and then a bunch of Warnings that things are not defined. I think this has something to do with it. I am wondering if some security patch or upgrade raised the permission level for whatever it is that permission is being denied to.

    So, after I did the "Run as Administer" with the cmd prompt and flushed the dns cache finally I tried also running FireFox as an Administrator also.

    I just tried a test pic upload to photobucket and it still won't work.
  16. 'Ric

    'Ric TS Rookie Topic Starter

    UPDATE: I was trying different file types and found ONE file that I can upload. It's a .gif file, but other .gif files still don't work. For some reason, both FireFox and IE can upload this one .gif but none others that I have found so far.
  17. 'Ric

    'Ric TS Rookie Topic Starter

    ... I tested this uploading to Yahoo Groups. The same pic can upload there, while others still just produce a blank screen. I found a couple others, too, but most won't go. The error console still says the same things.

    The permissions on the files that upload are the same as those that do not.
  18. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    [QUOTE='Ric] can't upload any pics to Photobucket.com or .pdfs to Yahoo Groups. In the error console,
    I get an "Error: uncaught exception: Permission denied to call method Location.toString"
    error and then a bunch of Warnings that things are not defined. I think this has something to do with it. I am wondering if some security patch or upgrade raised the permission level for whatever it is that permission is being denied to.[/QUOTE]
    this is a Java issue, not a Browser or TCP issue.

    1- update your version of Java RTE here

    you will need to Reboot to get the browser to access the new version.

    2- retry your test
    if it fails, then the site you are uploading to has a script or applet error -- report it
    via Contact Us.
  19. 'Ric

    'Ric TS Rookie Topic Starter

    I don't think that's it either.

    Reinstalled Java twice. This last time I ran CCleaner to clear out any left overs from the old installation before installing the new one.

    It still doesn't work on either Yahoo Groups or Photobucket.

    Oddities to the problem:

    1. I do have some files that work, while most don't.

    2. Same problem on at least two different websites.

    3. The error window shows the errors and warnings, but the Java window doesn't show any problems.

    Could something be interfering with Java? I was thinking it might be an access rights thing blocking something it was trying to load, but I can't find any such thing. I tried setting both FireFox and all the .exe's in the Java bin to "Run as Administrator" to know avail. Also, the two different files have the same rights and are in the same directory. One works, the other doesn't. IE also has errors with the same file, so I don't think its a FireFox bug either.
  20. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    look in the system tray where the firewall/AV products have their icons.

    you said " in the error console" ... when the error shows up and if it is Java,
    then there will be a small coffee cup in the system tray.

    mouse over: Java(TM) Platform

    right-click->Open Control Panel will show:
    Java Plug-in 1.6.0_03
    Using JRE version 1.6.0_03 Java HotSpot(TM) Client VM
    User home directory = C:\Documents and Settings\Jeff

    c: clear console window
    f: finalize objects on finalization queue
    g: garbage collect
    h: display this help message
    l: dump classloader list
    m: print memory usage

    TestVM 3.3 sc
    Copyright (c) 2007 Sun Microsystems, Inc.
    All Rights Reserved.
    TestVM 3.3 sc
    Copyright (c) 2007 Sun Microsystems, Inc.
    All Rights Reserved.
    this is a Java Applet URL which will start the Java Plugin
  21. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    agree those error messages imply you need to double check / rebuild your Java install. Minor point, the latest version of java should show v1.6.0_05

    Note when a new version of Java is installed it does not replace the current or any older versions on your computer. Rather, Java is designed such that you can have multiple versions installed at the same time. But that "feature" can cause problems as well.

    1. Open Control Panel -> Programs and Features
    2. Scroll down to Java. Do you have more than one Java version installed? e.g. it might say Java (TM) 6 Update 3 as well as Java (TM) 6 Update 5. Uninstall all Java versions.
    3. Now run CCleaner to do cleanup. And reboot if only for "good housekeeping"
    4. Install the latest Java JRE using the link jobeard supplied earlier in this thread (post #18). It should install Java (TM) 6 Update 5.
    5. Verify your Java installation but first you must close all browser windows!. Then open the browser and go here. Then test your Java Virtual Machine (VM) go here. The VM test should show all the installed release versions along with a small animated/dancing character. If this test fails it can also be a firewall issue!
    6. Open Java Control Panel by clicking Control Panel -> Java then click on Advanced tab.
    7. Under Settings / Debugging check each box for:
    - Enable tracing
    - Enable logging
    - Show applet life cycle exceptions
    8. Under Default Java for browsers verify both Microsoft IE and Mozilla are checked off. Are they both checked? If not, do so.

    Try again from both browsers.
  22. 'Ric

    'Ric TS Rookie Topic Starter

    All done -

    I have nothing but Java v1.6.0_05 installed, and both tests pass. I checked all those boxes and tried uploading again to both sites with both browsers. Still fails.

    Where does it hide the logs/traces? Do you want me to post them?



    The error console is not the same as the Java console, it's the FireFox under tools right after the Java console. It recently hasn't shown any errors, but continually scrolls warnings. The Java console shows no activity after it starts up with that initial menu. Maybe this is normal?
    Warning: reference to undefined property x[i + 9]
    Source File: https://www.techspot.com/vb/clientscript/vbulletin_md5.js
    Line: 100
    Warning: reference to undefined property o.parentNode.ndPar[geNIx(o)]
    Source File: http://images.intellitxt.com/ast/js/vm/func_200803201111.js
    Line: 2
    Warning: variable editorid hides argument
    Source File: https://www.techspot.com/vb/clientscript/vbulletin_attachment.js
    Line: 33, Column: 11
    Source Code:
    for (var editorid in vB_Editor)

  23. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    these are Javascript errors; ....clientscript/vbulletin_attachment.js

    empty your FF and IE cache
  24. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    I still like to quote someone who posted in a different thread
    "Who needs a hobby when you have a PC"​

    That said, since both those Java tests worked i'd check further for settings and something interfering. Please tell me the following:
    1. Check how large are some of the files you can't upload? Just to make sure it's not a file size issue.
    2. Who's firewall software are you running on your PC? Some firewalls can be set to block some scripting - tho you said one file type worked? or was that one file? and did it work on different sites? (Don't retest, but whatever you recall)
    3. I think you mentioned Verizon DSL. Do you have a DSL modem plus your own router connected? Or do you have a combination DSL modem and router?
    4. I'm assuming you're setup doing this testing with PC on a wired connection to your router? (don't know that it should make a difference but just asking)
    5. What version Firefox? (Click Help -> About Mozilla Firefox) and check Java Script settings. (If you make any changes, first close all FF windows and restart FF to test)
      • Tools -> Options
      • Click Content.
      • Enable JavaScript AND Enable Java should both have check marks.
      • For JavaScript check the Advanced button. Will have you set options the way mine is set. Checked: Move or Resize Windows and Disable or replace context menus
    6. Check your IE Settings. What does it say for version number? (you're vista, so be some version of IE 7 and here's IE7 settings). Close and restart IE before testing any changes.
      • Click on 'Tools' (You may only see a round looking gear in upper right of screen is the icon)
      • Select Internet Options and click Security tab
      • Click Custom Level button
      • scroll towards the last several items in checklist to find script options. Verify Active scripting and Script Java Applets are enabled

    I'll check if your firewall has a method to block java scripts (could be the problem) but if above tests don't help and if not clear if firewall or not, next step would be to make sure nothing else could be interfering with the upload/script so the idea would be
    • if router is separate device, remove it. plug PC directly to modem
    • Boot your computer into Safe Mode with Networking. How that;s done can very between computer mfr. But you restart computer and as soon as it starts the power up cycle start tapping a key (F8 if a Dell computer. Search your Help or look online for your PC support to find out about yours if not Dell). After initial splash screen but before the usual Windows starup screen, you should now get a menu of startup options where you can up/down arrow to select what you want. If you see Windows starting, you did it wrong. Try again.
    • If this test still fails try again but after you've turned off the firewall. (i'd avoid the test w/firewall off till last)
  25. 'Ric

    'Ric TS Rookie Topic Starter

    jobeard: done that - no change

    1 Size doesn't seem to make a difference, nor file type.

    2 McAfee Security Center (Anti Virus, Spam, Spyware, and Firewall package)
    Two different files of the same type - one works, one doesn't?

    3. Pc is connected hardwired to a Linksys 80211AG Wireless Router. The router is then connected to a Westall DSL modem. A laptop that uses the wireless also has some problems. There may be something to this? The router & modem are older, pre-Vista.

    4. Ethernet wire to Linksys Router above.

    5. FireFox
    Both Javascript and Java were already enabled, but nothing was checked under the advanced "Allow scripts to:" - I checked the same two that you have checked.

    6. IE is version 7.0.6000.16609 - Active scripting and Script Java Applets were both already enabled

    I'll try the router bypass and net safe mode in a bit... (my wife is watching her flute choir on YouTube on the laptop right now.)
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...