Hardware CPU Fan error

Hesham3del

TS Rookie
Hey all,

So, everything was just fine with my prebuilt PC until I got that CPU Fan error thing.

At first, I used to bypass it by restarting the PC several times until this screen goes away and login normally.

I made a complete hardware cleaning to remove dust and such as this maybe the reason behind this error, but still the problem is there.

My BIOS is updated and I did a "clear CMOS" by removing the battery for 5 mins. and putting it again but nothing happened, problem is still there.

Using AIDA64 I looked into the V12 of my PSU, it's good, 11.9xx.

Also, two times since yesterday, the PC was shutting down immediately after powering up.

My PC specs is as follows,

CPU : AMD FX-9590
Motherboard : Asus Crosshair V Formula-Z
Cooling Unit : Cooler Master Hyper 212X
GPU : AMD Radeon RX 560 4GB
Memory : 32GB, 4x Kingston HyperX 8GB

Thanks in advance.
 

Hesham3del

TS Rookie
Thanks for your reply.

Here are some updates which may help in my case

- The PC barely started working today, always shutdown before that error appears or while booting up/entering the BIOS.

- When the PC booted into Windows once today, the fans were super quiet although they were adjusted to "Standard" and not "Silent", the silence was up-normal and here are some reading from the BIOS,

https://ibb.co/PcSZ9GS

- I've noticed that when I adjust the CPU and Chassis fans to "Turbo" the temperature increases till the PC freezes.

- Was converting some videos for the family, the PC freezes when it reach 65C - 70C although it's set in the BIOS to protect from overheat at 90C- 100C.

- The PC is running smoothly now by putting a large fan in front of the open chassis and setting the fans speed to "Silent".
 

Cycloid Torus

Stone age computing - click on the rock below..
CPU Fan is "N/A"? Most motherboards will not function properly if the CPU fan is "N/A" (not there, not recognized, not turning - wonder which).

Can you observe the actual performance of fans? All spinning? Same with Turbo? Turbo should give faster spinning fans.

This is an older motherboard, so I have to ask when you last cleaned out the dust, replaced the Thermal Paste and reconnected your connections - a loose connector on a fan could be the issue. AMD specs on this CPU says "Max Temps 57°C" https://www.amd.com/en/products/cpu/fx-9590 It looks like the setting in BIOS may not be protecting your components.

See YouTube for cleaning and thermal paste replacement videos.

Lastly, you did not list your PSU. It has to be a good one as just CPU and GPU could use up to about 500w.
 

Hesham3del

TS Rookie
Thanks for your reply Cycloid Torus,

My PSU is Bitfinex Whisper 750W

Here is a small update but I think it will put the last nail in my issue's coffin,

I've stopped using the desk table fan and set the fan speed/mode into "Silent", the PC restarted and on the 2nd windows login, I've got an warning that the CPU temp. is 65C so I raised the fan speed to "Standard"

No load were done during that temperature rise, just web-browsing.

Also, mainly on the restarts, I don't see that CPU Fan error and sometimes also on the first boot-up.
 

Cycloid Torus

Stone age computing - click on the rock below..
PSU should be 'OK' as long as it isn't loaded with dust.

"Can you observe the actual performance of fans? All spinning? Same with Turbo? "

"AMD specs on this CPU says "Max Temps 57°C" " - 65C is way too high for this CPU - just browsing it should be 40C and playing games at 50C - something about your cooling solution is WONKY.
 

Hesham3del

TS Rookie
Finally, problem solved.



The problem was the cooler's fan, it was not rotating freely when I spin it compared to the fans of the case for example.



So I've replaced that failed fan with one of the two case fan's and it works well.



I faced an small issue with it today as it was rotating at nearly 5xx rpm while on "Silent" mode and got the same error, so I simply lowered the minimum speed limit to 500.



Also, my back panel fan was having that CPU Fan error, this was due to putting that fan on control a.k.a. user control, so I disabled the control and made it automatic up to the system from the BIOS.



Thanks all of you for helping me out, it's greatly appreciated.



Have a nice day :)
 
  • Like
Reactions: Cycloid Torus