CPU or VRM makes high pitched noise

Hello everyone, I'm using AMD FX-8120 (125W) with Gigabyte GA-970A-DS3. I've been using this CPU on the MB even on the F3 bios version, even though the CPU is not officially supported (only the 95W version, and only from F7a bios). So here is the problem, I ran OCCT test and after about 10 minutes or so, there is a constant high pitched noise coming from somewhere around CPU area, which lasts for around 30 seconds then stops. When that happens, I can hear the CPU fan slowing down, and temperatures decreasing which would normally point to throttling (the temps are very low, so it's not that). After 30 seconds it just comes back to normal, the test is still running and after a few minutes it happens again etc. However, the CPU usage, frequency, and voltage all stay unchanged (I've checked in OCCT, CPU-Z, and AIDA64 at the same time), and that is a bit confusing since I don't even know what's happening. Could be some safety instructions from the mobo because of the high TDP processor? At some point I tried overclocking, and I got to 3,9GHz with the stock voltage, but I can't go any further, even with the voltage bumped to 1.43V, but that's not my primary concern (even though it could be that I got a bad cpu example). I just mentioned this because the problem could be related, as there could be compatibility issues, but the CPU is working fine, while it shouldn't work at all, considering the mobo manufacturers compatibility list!? I searched all over the internet, and I haven't found anyone with the same problem as I'm having. I found that some people are complaining about coil whine, and after searching more on that, I can tell that this is not coil whine, but more of a high pitched "beep" noise (not that loud at all) that is constantly heard for about 30 seconds. So, if anyone has an idea what's going on, I would be very thankful for any help.

Latest posts