CRC Failed / Executables Corrupt, Memtest86+ Reports No RAM Errors

By eladnava · 12 replies
Sep 23, 2009
  1. Hi folks,
    My problem is strange. I have read other CRC Failed topics here but all seem to have been solved some way that mine cannot be. Every decent file I download (I tested with a 100MB file from Nvidia download page) gets to my computer corrupt when I try to launch it. Oh and I downloaded the same file from a different computer in the house on the same network, put it on a USB thumb drive and loaded it onto problematic computer, voila no corruption, so it can't be something to do with ISP) And when I download RARs or other archives it says CRC failed. I tried downloading the same file about 6 tries, none of them the file got there uncorrupt, this was with an .exe installer for Nvidia drivers and it also happens with archives.

    Executables that are installers tell me "The package is corrupt, please obtain another copy and verify its integrity." and Winrar/Stuffit/UnRarX on Mac tell me CRC failed. (Yes same problem on both Windows Vista and Mac OS X Leopard on the same machine)

    I burned and ran Memtest86+ waited until it says ### Pass complete, no errors, press esc to restart ### did that about twice still no errors found.

    What could be the issue? I ran a checkdisk /f on the Vista HD nothing seems to have changed.

    Any ideas possible, willing to try anything at this point. Even went and reseated the RAM and even tried moving it to the other 2 slots available, nothing changed. I don't have any other RAM to experiment with to see if it really is that RAM but I'll consider trying 1 by 1 to see if only 1 is corrupt.

    By the way, running no Anti-Virus of any kind.

  2. eladnava

    eladnava TS Rookie Topic Starter

    Bump, can anybody please help?
  3. pjamme

    pjamme TS Enthusiast Posts: 208

    The strangest thing is that your computer is stillrunning if you truly don'thave any running Anti-virus. Or did you mean while downloading?

    Viruses and all their ilk can cause numerous problems and I would think file corruption would be easy for them.

    Another thought, have you run SFC /Scannow to make sure all you windows files are in tact?
  4. raybay

    raybay TS Evangelist Posts: 7,241   +10

    You need to run MemTest86, the new version just out, for four hours or seven passes, which ever is longer.
    A Cyclic Redundancy Check is usually a hardware error, but it could be anywhere, including a failing CMOS battery or a cpu fan or other intermittent failure... including a failing power supply or hard drive.
    Please tell us more about your machine brand, model, age, and configuration.
  5. eladnava

    eladnava TS Rookie Topic Starter

    The thing is, I don't need an Anti-virus, since all I do on the computer is visit a few trusted sites and play World of Warcraft, and sometimes download movies from trusted people.

    If it were a virus-related issue then it shouldn't be happening on my Mac as well, since Mac's don't really have viruses.

    I will run SFC /Scannow, thanks for the tip.

    So wait I shouldn't have burned MemTest86+ and I shouldve burned MemTest86 instead? Also MemTest86+ didn't let me wait for all of those passes, it ran all of the tests and I think it did about 2 passes and decided on its own it's done and said to restart computer.

    These are the specs of my machine:
    HP Pavilion a6120n Desktop PC

    I changed it a bit, though, adding an Nvidia GeForce 8400 GT video card, 1 more HardDrive (70gigs), and 1 more CD/DVD burner. Also I added a Edimax USB dongle and also a Wireless PCI Adaptor (1 works with Vista and doesn't work with Leopard, the other works with both)

    I own this machine for around 3 years and have kept it in excellent condition, almost like new. Since the problem with downloaded files being corrupt not only with archives but also with executables I am thinking it could be 2 things: My Wireless PCI Adaptor (although unlikely, but I tested with 2 different adaptors and no change) or somehow my RAM. It also happens on both of my harddrives, the Vista one and the Mac one, so not sure if harddrives could be at fault.

    I really appreciate the time you guys take to answer my thread, thanks a lot so far! :)
  6. eladnava

    eladnava TS Rookie Topic Starter

    Bump, I have tested with Memtest again and still no RAM errors, but I'm still getting corrupt executables and CRC Failed, could it be my Wireless Adaptor or my ISP? I live in Israel.
  7. raybay

    raybay TS Evangelist Posts: 7,241   +10

    My best guest is that your hard drive is defective. A Cyclic Redundance Check (CRC) is designed to detect accidental changes to raw computer data, and is commonly used in digital networks and storage devices such as hard disk drives. When the test reads a block or the hard drive repeats the calculation; if the new CRC does not match, then the block contains a data error.

    CRCs are so called because the check (data verification) code is a redundancy (it adds zero information) and the algorithm is based on cyclic codes. The term CRC may refer to the check code or to the function that calculates it, which accepts data streams of any length as input but always outputs a fixed-length code. CRCs are popular because they are simple to implement in binary hardware, are easy to analyse mathematically, and are particularly good at detecting common errors.

    So I suggest you go to the manufacturer's website of the company who built your hard drive. Every manufacturer except Toshiba and Tri-Gem have one.
    They will have their own hard drive tests... usually they last less than five minutes.
    So in a short time you will know whether your hard drive is bad, or part of the problem.
  8. eladnava

    eladnava TS Rookie Topic Starter

    Ok, I'll try that now and report back, although I get this problem on 2 seperate hard drives.
  9. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Having a CRC error on two separate drives would be extremely rare... check all your cables and connectors. It has been two years since we have seen any CRC errors.
    It is possible that the CPU fan, power supply, and other issues to do with cooling and memory had something to do with this.
  10. eladnava

    eladnava TS Rookie Topic Starter

    I think the problem is gone, I tested by downloading a 20 gig set of RAR archives and decompressing them. I did not have to replace any of my RAM, but I think the problem was with my Edimax ew-7318ug USB wireless adaptor, because as soon as I disabled it and enabled my PCI wireless adaptor I think the problem went away.
  11. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    I'm curious to see if your network adapter replacement fixes the issue or not.

    As stated above, CRC errors are the result of file/memory corruption. The question then, is why. Memory and hard drive problems are common reasons, but memtest passes and it is affecting files on two hard drives - It pretty much can't be either of those now.

    Your wireless adapter is an interesting guess (if the source for all of these corrupted files was the Internet), but it would be the first network adapter I've seen to do that. The protocol in which your data travels from/to the internet (TCP/IP) itself contains some rudimentary, checksum-based error checking that for the most part, works pretty well. It would seem unlikely that your NIC is to blame, as I would assume your network connectivity simply wouldn't work (or at the very least, work very well).

    While I hope the NIC change fixed your issue, I'd like to suggest that you may also have a virus. One of the reasons I say that is that viruses do exist that cause CRC errors. The reason these CRC errors occur is rooted in the way certain viruses try to conceal themselves by subverting file system APIs in Windows so programs can't detect them (typical behavior with rootkits). Some take it a step further though and use system calls that offer direct access to your disk. AVs use these methods too in your defense, but this where the CRC errors can be generated. To Windows or other software, the data looks 'corrupted', but the files are actually fine.

    If the problems occur again, it would definitely be worth running a virus scan and if you don't want to install a virus scanner, try using to do an analysis. And when it comes to removing it, you'll probably want to use combofix and Microsoft Security Essentials (I can't recommend it enough) to do the cleanup..
  12. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    Keep in mind that RAR files can have pretty good error correction. I'm unsure if your RAR program will prompt you if an error is detected, but it is possible that the recovery records were able to correct any issues on the fly.
  13. eladnava

    eladnava TS Rookie Topic Starter

    Yeah, it has to be this silly USB wireless dongle. Ever since disabling it all the corruption went away. Before also executables were corrupt, I would download the Nvidia graphics drivers and they would prompt that they were corrupt. Now I can download them over and over with no problem.

    You are right, I probably should install Nod32 by now. :p

    I should go to the store and return this piece of crap, before the warranty voids.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...