DirectX problem please help

By kin3tic ยท 31 replies
Nov 8, 2008
  1. I'm having some trouble relating to directx not being able to create devices for games that take up fullscreen. But for any games I've setup that play in a windowed screen they work without fail even when other games that do require directdraw fail. I honestly have no idea what's wrong. A simple restart fixes it but this problem just keeps occurring over and over. I've tried reinstalling directx and video card drivers already. I'm currently using catalyst 8.10 right now for my stuff. It sometimes occurs after I finish watching some shows on media player classic. It happens for games that do not need heavy processing power to play. I tried going into dxdiag to disable/enable directdraw and it only worked once. It's not working anymore.

    I've asked at a few forums, one said to update directx to the very latest one (just released two days ago). But no go; the problem continues.

    DirectDraw test results: Failure at step 17 (SetDisplayMode to 640x480x16): HRESULT = 0x80004001 (Not implemented)
    Direct3D 7 test results: Failure at step 39 (SetDisplayMode to 640x480x16): HRESULT = 0x80004001 (Not implemented)
    Direct3D 8 test results: Failure at step 8 (Creating 3D Device): HRESULT = 0x88760827 (error code)
    Direct3D 9 test results: Failure at step 8 (Creating 3D Device): HRESULT = 0x8876086c (error code)

    I'd really appreciate some help.

    Attached Files:

  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Update XP to SP3 and see if things improve
  3. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    I'd start by look at ALL your drivers (including mobo chipset)

    For starters, i believe (assuming i got the info correct)
    - You're a couple versions behind on sound driver
    - 8.1 Catalyst is the latest driver BUT they released hotfix 10/15/08 for performance/game problems (gotta love they still call it their 8.1 driver as that's gonna create lots of confusion when driver number doesn't indicate whether hotfix installed or not!)

    But recommend you check on ALL drivers
  4. kin3tic

    kin3tic TS Rookie Topic Starter Posts: 22

    I grabbed the very latest (8.11) no dice. And even if I did get the hotfix for 8.10, the problem happens when even when I'm not playing any games. A game I play that requires very little computer power still fails since directdraw won't work.

    My sound driver IS up to date. Auzentech hasn't released anything new yet. Are you talking about my mobo sound? I disabled that so yeah.

    My drivers are all up to date. Unless they release something at the time of this post.

    I'm trying catalyst 8.9 to see if there's any difference.
  5. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Have you updated XP to SP3?
  6. kin3tic

    kin3tic TS Rookie Topic Starter Posts: 22

    Sorry, not yet.

    I did have SP3 before, but it was giving me problems so I went back to SP2. That will be one of the later things I will try.
  7. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    What kind of problems did you have with XP SP3? Install problems or running problems? Your having problems now. These current problems, might affect the installation of XP SP3...
  8. kin3tic

    kin3tic TS Rookie Topic Starter Posts: 22

    Honestly? I don't recall anymore. Since I went back to SP2 I didn't have any problems for awhile. But if these older catalyst drivers fail I'll probably end up trying SP3 again and see if I still have problems anyways.
  9. kin3tic

    kin3tic TS Rookie Topic Starter Posts: 22

    Still having problems after I went to SP3. Any other ideas? Need me to dump some info or something?

    I'm going to run some stress tests one more time to see if there's no hardware problems with prime95 and memtest again. I did this awhile back and didn't have any problems but I should check again.

    Could it be my mobo at fault? Should I reflash the mobo and vid card? RMA my vid card?

    This problem is absolutely irritating. ANY ideas please.
  10. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Can you provide more detail on "still having problems"?... Blue screens? Direct draw problems are side effects of other hardware issues
  11. kin3tic

    kin3tic TS Rookie Topic Starter Posts: 22

    There's no BSOD. Recently I was playing a game in fullscreen and it froze up on me. Had to hard restart.

    But there was no minidump or bsod warning. Nothing in event viewer that I think would be relevant.

    There is this:

    The Eset Nod32 Boot service failed to start due to the following error: 
    The service did not respond to the start or control request in a timely fashion. 
    For more information, see Help and Support Center at
    The thing is I don't HAVE nod32 anymore.
  12. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    If you think you don't have NOD32, think again... Can you see NOD32 anything in the add/remove programs list?
  13. kin3tic

    kin3tic TS Rookie Topic Starter Posts: 22

    I don't see anything.

    There's still entries in my registry though.

    I should probably delete them, right?
  14. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    If you are familiar with working with the Registry go ahead and edit it. If you haven't done this before, try a registry cleaner first. What antivirus program do you have installed now?
  15. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Just a thought....

    Snipped from dxdiag output:
            Card name: ATI Radeon HD 4800 Series
         Manufacturer: ATI Technologies Inc.
            Chip type: ATI Radeon Graphics Processor (0x9440)
             DAC type: Internal DAC(400MHz)
           Device Key: Enum\PCI\VEN_1002&DEV_9440&SUBSYS_00000000&REV_00
       Display Memory: 1024.0 MB
         Current Mode: 1280 x 1024 (32 bit) (60Hz)
    DirectDraw test results: Failure at step 17 (SetDisplayMode to 640x480x16): HRESULT = 0x80004001 (Not implemented)
    Direct3D 7 test results: Failure at step 39 (SetDisplayMode to 640x480x16): HRESULT = 0x80004001 (Not implemented)
    Can you manually set your monitor to 640x480x16?
    Try running with that as default? See what happens... As well as run another dxdiag

    /*********** EDIT ***************/
    If you want to try a Registry Cleaner suggest you first try the one in CCleaner. Registry cleaners vary in how aggressive they are in removing/trying to change things. The more aggressive the higher probability of a cleaner caused problem. I've never had any problem using the registry cleaner in CCleaner on any system yet.. just my 2cents worth (and it's worthwhile to be careful to run ghost image backups before any registry cleaner tho admittedly i haven't always done so myself based on my track record when using CCleaner's registry cleaner.)
  16. kin3tic

    kin3tic TS Rookie Topic Starter Posts: 22

    When I get the DX error or like right now?

    I'm using AVG free atm for my anti virus.

    I liked using CCleaner for my old computer so I already have it, but I didn't run any registry cleaner for my new setup just yet. I'll do it now.
  17. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    You should continue to re-run CCleaner's registry cleaner until no problems found. (It cleans progressively. It may sometimes fix one set of issues which may cause/uncover a smaller set of issues that still should be fixed by a running/finding them in a subsequent registery cleaner pass.

    The dxdiag output indicated display was running 1280 x 1024 (32 bit) (60Hz) at the time you ran dxdiag. As i read its output, problem occurred when it tried changing to (or after changing to) SetDisplayMode to 640x480x16

    So i;d try manually setting that resolution and try running that resolution awhile. Also re-run dxdiag when that's already the display resolution just to see what happens (i'm just making guesses here at things to try)

    /************ EDIT 1 ****************/
    So then i'm confused... Your dxdiag output indicates you're using Auzentech driver v6.00.0001.1281 released 8/22/2008. Yet their website lists your sound driver as RC6 followed by RC7 9/03/2008, and finally RC8 as the newest driver released 9/24/2008 (and with a track record of 3 driver releases within 30 days i'd keep an eye out for updates over next coupla months)
    Sound Devices
                Description: Auzen X-Fi Audio [EC00]
     Default Sound Playback: Yes
     Default Voice Playback: Yes
                Hardware ID: PCI\VEN_1102&DEV_0005&SUBSYS_0034415A&REV_00
            Manufacturer ID: 1
                 Product ID: 100
                       Type: WDM
                Driver Name: ctaud2k.sys
             Driver Version: 6.00.0001.1281 (English)
          Driver Attributes: Final Retail
                WHQL Logo'd: No
              Date and Size: 8/22/2008 00:46:50, 518400 bytes
                Other Files: 
            Driver Provider: Auzentech
    /************** EDIT 2 ****************/
    I just re-read your post about Nod32 service failed to start. Go ahead and use the registry cleaner first. If this error message persists is just a matter of deleting the service control entry from the registry which still exists altho the file it refers to has been removed. You can easily/safely remove the entry from the registry using the sc command at a command prompt. Will explain further if you need use it.
  18. kin3tic

    kin3tic TS Rookie Topic Starter Posts: 22

    Yeah, I'm confused too.

    I've downloaded this and installed it again and again and it's still the same. Uninstall/reinstall and it's still the same, which is weird as according to the site the driver was updated. I guess I'll try doing it again.

    I also know I have to re-run CCleaner several times. Already on top of that.

    As for setting my display mode to 640x480 16bit, it won't let me. The lowest it's going is 800x600x* where * is 16/32.

    I'm not too familiar with this, care to walk me through it? Just for future reference if it does show up again in my event viewer.
  19. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    1) Needn't try re-install again. I think i have all the info i need to download the driver install package from their site and look at its install files to figure out what it's up to for your specific sound device. Tho not likely till tomorrow (i.e. another 12 hours)

    2. Just to sure to be clear, you should be starting CCleaner, hit the update link to make sure you have the latest version, THEN click the Registry icon in left of CCleaner window and click Scan for Issues followed by Fix selected issues. (running normal CCleaner doesn't clean registry)

    3. Will have to look at your display mode info. Wonder if your monitor can't be set to that resolution by hand no surprise if can't be set that way by directx.. not sure the implication. would need look into it
  20. kin3tic

    kin3tic TS Rookie Topic Starter Posts: 22

    For 1.

    OK I'll just keep the file on my desktop anyways.

    For 2.

    Yeah I know that a regular clean won't do anything. Gotta click the registry, repeat several times etc etc.

    For 3.

    Uhh if it helps I've been using the same monitor from my old computer and it hasn't had any problems with my old computer at all. Runs 100 times better than my new computer. I think I mentioned a few times my old computer runs awesome. Too bad it's super old.

    I was following some suggestions here: because it has similar problems. Stress tests I did ended positively. I guess I could run 'em overnight. The other place kind of ended in RMAing the guys mobo/vid card. I did update my bios just now though.

    I'm only updated because just now it crashed during a game, fullscreen. No bsod though, just froze up. Hard restarted, but this time upon restarting something happened to my bios and it asked me to either load up the previous bios or revert to my old one. I chose the former but I updated to V.1501. Nothing in event viewer about my bios or anything.
  21. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Start->Run, then copy/paste the next line as is. Hit Enter
    [B]cmd /c sc query type= service > "%userprofile%\Desktop\sc.txt"[/B]
    Open file sc.txt on your Desktop and find the service entry and its service name
    Start->Run, use the following command but replace servicename with the one to delete
    [B]cmd /c sc delete[/B] [I]servicename[/I]
  22. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Info update about your Auzen sound card driver
    Boy, i really hate when companies do this.... But first, some info and terminology...

    Although it's common to talk about downloading "new drivers" the download file one typically gets is more often and appropriately called a "driver package" as a vendor can "package" many different things together into a single download file (i.e. not JUST drivers)

    Sound cards are a good example as their "package" often includes control panel applications (like sound mixers or control panel sound apps which allow you to configure your sound device). (As an aside, that's why is best to first check Add/Remove Programs when uninstalling drivers. If the "driver package" also installed applications you'll find an entry in Add/Remove Programs. Uninstalling via Add/Remove Programs should uninstall everything the package installed earlier - both apps AND drivers

    Point of all this being.... the download files ("packages") Azun put together as RC6, RC7 and then RC8 on their download site all install the same sound card driver v6.0.01.1281. It's the other stuff in the package that varies between the 3 releases. (It's nice when a company actually makes this clear by listing contents and versions contained within a release package)

    So if you've been installing RC8 you should be OK. Best method to install
    1. First look in Add/Remove Programs to uninstall any other package you installed previously
    2. Then do the new package install

    And now back to your video problem... Will see take a another look at it again.. tho probably not till later
  23. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    this was interesting....

    i was skimming through some threads related to directx/directdraw/direct3d issues

    someone had posted their problems cleared after having Windows check for bad disk data/sectors using chkdsk to do the repair.

    Is easy for you to at least try the same. So suggest is worth a shot. See this KB for chkdsk command usage. Run a /r (repair) operation on each of your hard drive disk volumes. Note the statistics provided when Windows is done with each volume (if only for curiosity later)
  24. kin3tic

    kin3tic TS Rookie Topic Starter Posts: 22

    Another place suggested:

    And it worked.

    But I ran chkdsk on my first main drive C: and it has an error. Oh joy. I'll run the repair on all my drives and tell you how everything works out (or doesn't).
  25. kin3tic

    kin3tic TS Rookie Topic Starter Posts: 22

    So the only drive I have a problem with is my main one C:

    After running a repair I ran chkdsk again on it and there's still errors.
    There's alot of "Missing object id index entry or duplicate object id detected for file record segment *" Where * is something starting from.. I think 3000 to the last one which is 155819.

    And a bunch of deleting index entries.

    Is there a log of my very first chkdsk repair anywhere? I wasn't watching when it first went through and it just restarted my computer without telling me anything when it finished.


    Nevermind, I reran another repair and watched the entire thing. It told me there was no errors, and the volume was clean.

    Funny, running another chkdsk right now with cmd.exe and it tells me I have errors.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...