Dragon Age Origins - Error Initializing PhysX

Status
Not open for further replies.

TorturedChaos

TechSpot Chancellor
So i got the game Dragon Age Origns, but when i try to load it it gives me the error Error Initializing PhysX, and tells me to go to nvidia.com/physx for updated drivers. I have the newest driver off their site (excluding beta drivers) and downloaded the newest update for the PhysX. I updated everything and restarted, and no go still.

my graphics card is a EVGA geforce 9800GT.

Any suggestions? Should i get the beta driver?

EDIT - removed the overclock from my graphics card, but still the same error

EDIT 2- tried the new beta driver. still no go. Anyone come across something similar to this in other games?
 

TorturedChaos

TechSpot Chancellor
so i just discoverd that the game makes a log file. here is what it has to say:

LEVEL MESSAGE
Platform Multi-core system detected. Using multi-threaded renderer.
Platform 2 core(s) detected, 1 worker thread(s) created.
General Initialize - Verify Platform capabilities
General Initialize - Resource Manager
General Initialize - World Database
General Initialize - Physics
Error Failed to initialize Physics
Error Failed to Initialize Eclipse

General Shutdown - Start
General Shutdown - Game
General Shutdown - World Database
General Shutdown - GUI
General Shutdown - Console
General Shutdown - Input
General Shutdown - Graphics
General Shutdown - Sound
General Shutdown - Physics
General Shutdown - Online Features
General Shutdown - Resource Manager
General Shutdown - Utilities


Personally it didn't give me any additional info.
 

Route44

TechSpot Ambassador
I suggest going to Nvidia's forums and do a search for your issue. I wouldn't be suprised in the least that others are having the same issue.

Also, when you upgraded your video card drivers did you use any utility to first make sure all the old drivers were cleaned out before installing the new?
 

fimbles

TS Evangelist
I have no such issues with dragon age. My driver version is 191.07, Physx vesion is 909.08.14.

Uninstall physx, Then Try exploring the dvd, go to software folder and there should be a physx exe in there. install that.

Hope this helps.

Ps. ( As route44 points out make sure to clean all traces of old drivers off of your pc before installing the new ones. driver sweeper is great for this.)
 

TorturedChaos

TechSpot Chancellor
I have no such issues with dragon age. My driver version is 191.07, Physx vesion is 909.08.14.

Uninstall physx, Then Try exploring the dvd, go to software folder and there should be a physx exe in there. install that.

Hope this helps.

Ps. ( As route44 points out make sure to clean all traces of old drivers off of your pc before installing the new ones. driver sweeper is great for this.)
I tried uninstalling Physx but no go. I spent several hours on google last night searching for a similar issue.

About 8pm last night a thought hit me tho, why not try it on Win7 (I have a dual xp pro - win7 boot setup). It worked right off the bad on Win7, so I can play just have to restart and log on to win7 to do it :p.

Still would like to make it run on win xp. Will try unistalling Physx again and maybe the game too, and reinstall everything. Will try insalling physx from the disk instead of from the nvidia download this time.
 

Xecutor

TS Enthusiast
The solution might be a lot simpler than we think here.

Have you tried going into Control Panel in Windows and enabling PhysX?

That might do the trick! ;)
 

alitadark

TS Rookie
Hi, I recently got this error myself.


I'm currently using a 4890, does that mean because i don't have a Nvidia card, i can't play dragon age origins o.O
 

Route44

TechSpot Ambassador
Hi, I recently got this error myself.


I'm currently using a 4890, does that mean because i don't have a Nvidia card, i can't play dragon age origins o.O
DA supports both ATI and Nvidia video cards. The recommended ATI card is a 3850 512megs or more. Your card will easily run the game.
 

Route44

TechSpot Ambassador
But that is not what you originally asked: I'm currently using a 4890, does that mean because i don't have a Nvidia card, i can't play dragon age origins o.O

Which I replied that you can play this game with an ATI card.
 

scott100

TS Rookie
How did you fix it alitadark? I also have an ATI 4870 and having the same problem. However, I do have this phys thing in my CP.
 

scott100

TS Rookie
Can someone pm alitadark please

I don't have enough posts to pm alitadark, can someone please pm him and ask him how he solved the problem? I'm stuck.
 

alitadark

TS Rookie
calm down :p, i only woke up now haha.



Basically, i uninstalled physx and downloaded a fresh copy from

w w w.nvidia.com/object/physx_9.09.0814.html

seemed to have fixed it since the physx install on the dvd didn't work.

The download will automatically uninstall physx (unless you have the latest version)


I hope this helps.
 

Zakyn

TS Rookie
So i got the game Dragon Age Origns, but when i try to load it it gives me the error Error Initializing PhysX, and tells me to go to nvidia.com/physx for updated drivers. I have the newest driver off their site (excluding beta drivers) and downloaded the newest update for the PhysX. I updated everything and restarted, and no go still.

my graphics card is a EVGA geforce 9800GT.

Any suggestions? Should i get the beta driver?

EDIT - removed the overclock from my graphics card, but still the same error

EDIT 2- tried the new beta driver. still no go. Anyone come across something similar to this in other games?
if you only copy this game from other pc or something like this, you must download the newest version of PhysX from original page, because is not configurated on your pc, this configuration is normally did in installation
 

Nebic

TS Rookie
I've found the way to get the Physx problem to go away. If any of you are having this problem, and are running it on Vista, try running it as Administer. The reason this didn't work for me the first Two times I installed the game, was because it never added it to the "All programs" Under the start button. So the desktop icon, when you right clicked it wouldn't have the option.

But running it as Admin fixed the problem right up for me. Again Vista fails, and I want a Mac.
 

IAvalonI

TS Rookie
I have the same problem!
I run a Nvidia GeForce 8600M GT.

I have tried everything I can imagine; I've updated my driver. Ran as Admin. Deleted Physx, installed it again from the DVD (software folder). Also tried it with the latest Physx from the website. I've deleted and re-installed my driver...

All without results! I have also called EA support hotline, but nothing...
Anyone got any ideas? I really can't wait to finally play this game :( !!!

Thanx, Avalon
 

Astray

TS Rookie
Failed to initialize physx

i have same problem with nvidia GeForce 9500m GS turbocache. every thing that i try and it doesnt still start the game. any ideas?
 

hawaitoast

TS Rookie
so ich hab mich hier nur angemeldet um altidark zu danken :)))) THX!!!!
er hat volkommen recht jeder mit einer 4800er Serie ob 4850/70/oder 90 wie ich kann das PhyX problem bei Dragon age beheben indem er einfach die Treiber von Nvidea runterlädt aus welchem grund auch immer man auf ner ATI grafickkarte Geforce/Nvidea treiber installen muss damit es funzt^^ :) :D also noma danke Altidark
der Link von Altidark funktioniert wenn dir die leerzeichen vom w w w wegmacht viel spaß beim zocken
 
Status
Not open for further replies.