E8400 clock stuck at 2GHz in CPU-Z

geno2k3

Posts: 46   +0
Hi i just recently installed a E8400 and i check on CPU-Z and the clock is stuck at 2ghz.

I look online and it tells me to turn off speed step but in my bios there is no option to do so.

My mobo is a 0RY007 from dell.
 

geno2k3

Posts: 46   +0
  • Thread Starter Thread Starter
  • #3
Is there any way to get it to clock 3ghz no matter what? Cause when i was playing one of my games it was still clocked at 2ghz.
 

geno2k3

Posts: 46   +0
  • Thread Starter Thread Starter
  • #4
Even under 40% load and 40 c it still does not shoot up to 9x multiplier. While playing Call of Duty 4
 

geno2k3

Posts: 46   +0
  • Thread Starter Thread Starter
  • #6


Even under 100% load the CPU does not go up to 3ghz.

Help me please.
 

Ritwik7

Posts: 1,657   +9
The only way I know is to disable the limiter from BIOS. Strange that the Dell BIOS ships without it.
 

geno2k3

Posts: 46   +0
  • Thread Starter Thread Starter
  • #9
Ok someone in another forum helped me. It now shoots up to 3ghz sometimes
 

geno2k3

Posts: 46   +0
  • Thread Starter Thread Starter
  • #11
Sometimes as in? How did you get the limiter off?
When it goes under load it goes up to 3ghz. Like when im playing games or doing anything that requires alot of the CPU.

I updated the BIOS now the multiplier is unlocked.

In call of duty 4 i now get 250 fps constant over 125. Amazing difference a bios update did.