Error 1935 when installing HP printer software

By ACE99 ยท 5 replies
Jan 31, 2011
Post New Reply
  1. I Have just bought a new computer and was in the process of installing my printer drivers/software etc when an error message popped up saying "Fatal Error During Instalation" (Print Screen of error is attached)
    I have tried all of the solutions noted on the HP website here with no success! (I have downloaded the correct/updated drivers from the HP website)
    My Printer is an "HP Photosmart C4380" and the operating system i am running is "Windows 7 Ultimate 64bit" My previous computer was running the "Windows 7 Professional 64bit" and worked perfectly.
    If i just plug in the printer the drivers are automatically installed by windows so i can use the printer except for things like scanning. I believe that the drivers installation is causing the problem so if anyone can find out how to only install the HP Printing Software and not the drivers i think this might work.
    Thanks for your help!

    Attached Files:

  2. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    When you tried all the solutions did that include the full guide to switch off services, firewall, etc, and then do an uninstall and reinstall?

    Are you quite certain that you have the software and drivers for 64bit operation.

    You will need to install all the drivers to allow full functionality, having software only will not work.

    Have you added any additional software since changing from Pro to Ultimate.
  3. ACE99

    ACE99 TS Rookie Topic Starter Posts: 59

    As far as i know i have done all of those things you listed i tried everything on the solutions page but i dont remember one that involved turning off my firewall unless that was included in the msconfig, startup and services section.

    I am also certain i have downloaded the correct drivers for my 64bit operating system i even downloaded them twice incase one file was corrupted!
    I understand that i need the drivers to allow full functionality but a fun new feature of Windows 7 is that it will automatically detect and install drivers for you which is why i can print to my printer normally but i need the HP software suite to allow for things like scanning and additional functionality. This is why i was wondering if there is a way to only install the software and not the drivers from HP.
    The only additional software i have added is "Kaspersky Internet Security" (my old virus software was "Avast" but got kaspersky liscense free with computer so decided to use that!) Kaspersky does not pop up with any problems during installation though. (I suppose i could try uninstalling it and then trying printer install and then reinstalling it) The only other new software is "Autodesk Revit Structure 2011 x64" which i don't think could cause the problem!
    Thanks for your help and i hope with it i can solve this problem!

    Just a quick extra note i just tried uninstalling Kaspersky and trying to install printer but the same error occured! (Back to the drawing board again!)
  4. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    It seems that you have done everything possible. Switching of the firewall would have happened when you stopped all start up software and services.

    There does not seem to be a way of having th HP software installed without the drivers, there is only the reverse available to get the basic driver without the software. I wonder if windows 7 would run the scanner without the HP software or maybe use third party scanner software, might be worth a try. An on line search might find something that will work.

    Having run the installation with all services and startup software turned off I can't imagine what could be causing this, it is maybe just something within windows that is causing a conflict.

    Clutching at straws here, but when you removed Avast did you use the removal tool from there official site, it might be worth a try as it can leave some registry entries behind.

    You could also run these clean up tools.

    Download and run ATF Cleaner follow the instructions on the page.

    Download and run Auslogics Disk Defrag from here, Auslogics Disk Defrag.

    Download and run Quicksys RegDefrag from here, QuickSys RegDefrag.
  5. ACE99

    ACE99 TS Rookie Topic Starter Posts: 59

    Unfortunately none of those worked either :( Any more ideas? If not i might try doing a complete computer wipe and reinstall everything and install the printer first but that will be a pain!!!
    Thankis for all your help!
  6. mike1959

    mike1959 TS Evangelist Posts: 1,034   +55

    At Christmas 2010, we saw a very similar error to yours, while trying to register and download the software for an 'itouch'. The problem was that the pc had a long-standing problem with downloading updates from MS, and had not got Vista Service pack 2 installed either. When connecting to an old spare PC running XP, it worked straight away, connected to Apple, all went well. So would suggest checking if you have all your OS system updates.
    * Also, I bought an HP Scanjet G2710, but the supplied cd had Vista drivers, none for my Win7 32bit. Had several hours trying to get it going, but by trial and error I did get it to work as follows,
    1) Copy HP CD to a new folder on C:
    2) Open folder, right-click on 'hpzsetup', then choose 'troubleshoot compatiblity'
    3) Choose 'Troubleshoot program'
    4) Choose 'Vista service pack 1' (but could try other options here)
    Of course you will have a different filename, but you could try the same idea.
    (Now I see the correct driver for Win7 32bit has been released from HP for my G2710). Hope this helps.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...