Ethernet Controller problem

Aug 6, 2009
  1. Hi, I've recently reinstalled my Xp OS due to virus ect. I manage to install the Audio and what not going to because that's where my computer is from. What I can't install is my Ethernet controller (LAN) has a ? next to it. I tried to Update driver, reinstall driver and nothing heres some information hopefully I'm not the only one with this problem!.

    My PC spec: HP Compaq d220 Microtower Desktop PC
    Inter(r) pentium(r) 4 cpu 2.8GH Z 280GHZ, 512 MB of RAM
    I don't know if this will help but Device ID is (PCI\VEN_14E&DEV_4401&SUBSYS_217914A4&REV_01\4&1A671D0C&0&50F0)

    if you need any more information please lemme know. thank you guys!
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    I suspect you're missing a digit from that Device ID? Im guessing it starts as PCI\VEN_14E4 which is a device from Broadcom.

    The HP download site for your computer lists two different Ethernet drivers: one for Intel controllers and the other for Broadcom. You need the Broadcom driver. Try this download
  3. P4PC

    P4PC TS Member Topic Starter Posts: 47

    Yes, sorry forgot one last digit, and it worked, thank you so much, I very much appreciate you just saved my life!. :)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...