1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Ethernet not working, 169.xx ip address

By steele002 · 5 replies
Jun 20, 2014
Post New Reply
  1. So this is my first time making a forum post, since I am not desperate because nothing I've tried has worked. So two weeks ago I had an electrical surge in my house, on my desktop the ethernet port on the motherboard died, so I sent back my motherboard to have that fixed. Now that I have it back I tried getting my ethernet to work, though now the connection properly works (as in the local area connection is now at least recognized) I still have no internet access. I just tried reinstalling Windows 7 64 bit, fresh install after I wiped everything. My ethernet adapter is called Realtek PCIe GBI Family controller. I have a E2500 Linksys router and a Comcast modem, I tried plugging the ethernet cable into each other but no luck. Currently I'm attempting to at least make the desktop use the modem internet directly. I seem to be sending packets but not receiving them when I looked in the Status of the Local Area Connection, in network connection details I have an autoconfiguration ipv4 of 196.254.xxx.xxx, ipv4 subnet mask,, and nothing in the ipv4 default gateway,dns server, or wins server, and no ipv6 default gateway.. I've tried many things, too many to name now, but I am willing to try anything you guys mention and post the appropriate data or logs, just tell me what it is you would like to see. Any help would be highly appreciated!
  2. jobeard

    jobeard TS Ambassador Posts: 12,493   +1,430

    Anytime you see 169.x.y.z, that's the clue that your DHCP request to the router did not get an answer.

    DHCP should return an IP address directly related to your router's address and two DNS addresses.

    search the form for DHCP - - I've posted a solution here on TS.
  3. steele002

    steele002 TS Rookie Topic Starter

  4. steele002

    steele002 TS Rookie Topic Starter

    Hmmm, well I tried your instructions from several of your posts but none of them have fixed my problem. My physical address still remains 00-00-00-00, and autoconfiguration is still 169.254.xxx.xxx <Preferred> and
    dns servers are fec0:0:0:ffff::1%1
    any other suggestions? I'm not sure if it could possibly be another motherboard problem, maybe with the NIC card, or maybe if I get a wireless device for my desktop, I could determine if it's that or not
  5. jobeard

    jobeard TS Ambassador Posts: 12,493   +1,430

    addresses like fec0:0:0:ffff::1%1 are IPv6 and Windows uses v6 for lan services, but not Internet access.

    If you still fail to get an IP, then likely your firewall is not allowing
    Allow UDP any source IP ports 67,68​
    so for a test, shutdown the firewall, disconnect the cable from the router, wait 30 sec and recable.
    That should cause the command ipconfig to produce something like
  6. Im an AT&T technical support agent. When you do a Ipconfig on the command prompt and the ipv4 is giving you a 169.***.*** it means that there is no communication between the pc and modem. In order to fix you will need to do the following disconnect the ethernet cable from both the computer and modem turn off computer and powercycle modem for 10 seconds once all lights on modem are solid green turn on youre computer once youre pc ison connect ethernet cable and youre issue should be resolved.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...