Explorer.exe Problem

By Freemont7 ยท 4 replies
Oct 8, 2009
  1. Here is the problem:

    My computer was functioning fine and had been on for several hours.I opened photoshop and started editing some photos, minimized photoshop briefly to access the desktop and explorer.exe crashed. I opened the task manager and checked the applications, explorer was not running. I attempted to "start new task -> explorer.exe" and it gave the "Windows cannot opened the specified path, device, or file" error. I tried restarting and explorer.exe never even attempted to start. I went into safe mode but explorer does not open there either. I tried finding the specific location of explorer.exe using task manager -> new task and found the explorer application but it just gives the "Windows cannot opened the specified path, device, or file" error.

    I browsed the internet looking for solutions and tried several things that did not work, most of the time the divergence comes from the fact that other people with this problem are able to get explorer.exe running in safe mode. I cannot access system restore (or do not know how to do it using only the task manager). I tried to find and delete "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\explorer.exe" as this had worked for many people but the file was not there. I ran several registry fixers and Memtest 86 with no results. Virus scanners found no viruses and I have not downloaded or installed anything in days if not weeks.

    What should I do next? Can I try using sfc /scannow from the task manager?
  2. Freemont7

    Freemont7 TS Rookie Topic Starter

    Update: System File Checker scan did not work; scan was performed but no problems found.
  3. Bobbye

    Bobbye Helper on the Fringe Posts: 16,334   +36

    If you can boot directly into Safe Mode, the restore can be done from there:
    Boot into Safe Mode
    • Restart your computer and start pressing the F8 key on your keyboard.
    • Select the Safe Mode option when the Windows Advanced Options menu appears, and then press ENTER.

    To do System Restore:
    • Go to Start > All Programs > Accessories > System Tools and click "System Restore".
    • Choose the radio button marked "Restore my computer to an earlier time" on the first screen then click "Next".
    • Chose a date in BOLD from the left screen- right before this problem began- Click Next.
    • Let the restore complete. System will reboot when through.
    You did not make it clear whether you tried this path also.

    One setting to check: Make sure the hidden files and folders are hidden. Having a check to shows these can sometimes cause unexplained Windows Explorer crashes:
    Control Panel> Folder Options> View tab> UNCHECK 'show hidden files and folders'> Apply> OK

    I am assuming that you have tried just plain rebooting?
  4. Freemont7

    Freemont7 TS Rookie Topic Starter

    Explorer.exe will not start in safe mode either (i just see my background image) so I cannot access system restore through the start menu in safe mode and i can't/don't know how to get to the control panel to see if hidden files are really hidden.

    I have rebooted half a dozen times with no changes, tried safe mode twice without success. Is there any way to do a system restore without using explorer.exe?
  5. Bobbye

    Bobbye Helper on the Fringe Posts: 16,334   +36

    Let's get some history going on this:

    On 5/21/09, you started a thread with subject Page fault in a non page area, need help
    . You didn't follow up on that problem.

    4 weeks ago (that would be about 9/11/09) you started another thread with subject BSOD page fault in a nonpaged area You mention the previous thread: "Several months ago I first received the BSOD error "page fault in a nonpage area" that instantly shut the computer down. You did not follow up on that thread either.

    Now another 'sudden I don't know where it came' from problem Explorer.exe Problem

    It appears that you did some searching trying to resolve the problems, but they didn't resolve. Having run memtest, registry cleaners, system file checker, malware scans and still no improvement.

    This doesn't make any sense at all:
    At this point, I don't know what the problem is. I suggest you reformat/reinstall and see if it will fix everything. Sorry we can't be more helpful.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...