1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

External HDD is recognized but there's no folder

By pammie ยท 7 replies
Feb 2, 2011
Post New Reply
  1. Hi to everyone........

    Big favor, I need help. My external HD is recognized, but no folder....need for school. Anyone, please help me out

  2. Mizzou

    Mizzou TS Enthusiast Posts: 783

    Hi Pam and welcome to TechSpot.

    What kind of external HD are we talking about? Brand and model would help along with the type of interface, assume it's probably Usb2 but still need to know for sure. When you say it is recognized does this mean you can see it in Windows Explorer and if so, does it have a drive letter assigned to it? That should be enough to get things started.
  3. pammie

    pammie TS Rookie Topic Starter

    Reply: External HD problems


    Thanks for responding to my post.

    I have an external Hitachi HD. There are 3 sets of numbers, of which none says model number. PN: H3640U FRU: 0F10120 SN: MG0LZV3A

    I believe it is USB-2 though not 100% My interface is Window XP

    The letter drive is "F" on My computer. Did not go on Explorer...need some help on how to do that.

    When I first got the drive, it worked just fine. The HD was partitioned and I was able to save docs to the F Drive. I went to check it out for school because I need to put on Adobe CS5, and I could not save a test doc. The message that came up was> Will not save> Folder is not accessible may be located in an unavailable location, protected with a password or the file name contains a / or \.

    I went to Disk Mgmt. No "F" partition. It was there, but now it is gone. I tried to format the drive, but I don't think it formated at all.

    I would appreciate any assistance you can give me.

  4. Mizzou

    Mizzou TS Enthusiast Posts: 783

    OK, it looks like you have the Hitachi 640GB USB 2.0 external drive. As an intial test let's try the following:

    Shut down your computer.
    Turn off or disconnect the external drive (while the system is shut down)
    Restart the computer.
    Once you have the desktop turn on or plug in the external drive.
    The default autoplay setting should give you a pop up windows with options that you can select. It should look similar to the attached snapshot.
    If you get this pop up select Open Folder to View Files, this will launch Windows Explorer (different than Internet Explorer) which will show the folders and files stored on your external drive.

    If you don't get the pop up double click on My Computer which also launches Windows Explorer. Then check to see if the Hitachi is displayed in the drive list, if so double click on the drive icon which should display the contents of the drive.

    If none of this works then we need to do a couple more tests. Let me know how this goes and then we'll proceed from there.

    Attached Files:

  5. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    In addition to advice above, i can suggest one more thing also worth trying.

    See if this might help [post=875300]How to Cleanup and Remove old USB Storage Drivers[/post]
  6. Mizzou

    Mizzou TS Enthusiast Posts: 783

    Good tip. If all the above fails thought we'd check disk manager to see if the drive is present and whether or not it's partitioned and formatted. If the drive is not visible then this would be a good next step, might also do a quick check with a flash drive to make sure the usb port is functional.
  7. pammie

    pammie TS Rookie Topic Starter

    Responding: Hitachi External HD


    Did what you suggested. When I go into My Computer, the F Drive is there. However, there are no folders in it. There is also a Q Drive. When I right click, it will not let me open it. I did not get the pop up window with the options.

    Checked to see if the USB is working....It is. Went to Disk Defrag....F drive does not come up. Went to Disk Management; Does not show the F Drive Partition. Where do we go from here?

  8. Mizzou

    Mizzou TS Enthusiast Posts: 783

    At this point I think it would a be idea to go ahead with the procedure that LookinAround recommended.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...