File Explorer trouble in Windows or security software?

By mom26gr8kids ยท 5 replies
Nov 27, 2014
Post New Reply
  1. I have a program I run on my computer that requires a .dat file. Sometimes when I open the program none of the data is there. In the past when this has happened it was because my file explorer was checked to run as administrator, so going in and restarting file explorer to start normally fixed the problem.

    A few weeks ago the laptop I had been running this program on died. The motherboard died, but the hard drive was okay. The problem is I have been having trouble accessing the data file because my new laptop is not sure where the pathway is. I finally had it working tonight so that I was able to see the data, so I exited the program and when I re-opened it 10 minutes later the data was gone again.

    I suspect the problem is what happened last year. Either my security software is blocking something (I am getting the runtime error 75 path/file access error) or file explorer is blocking something. But I cannot figure out on Windows 8.1 how to keep file explorer from Running as Administrator, or how to make it run normally. I did click on it in the task manager and restart it, but that did not help my problem. Does anyone else have any suggestions? Comodo tried to block the data file because it was trying to modify a registry key, but since it is coming from my hard drive from a computer that was virus free I told Comodo to allow the application. However, Comodo also has that program listed under "blocked intrusions" and I am not sure if that means it wanted to block the program (because I clicked on Allow) or if it really did block something and if that is keeping me from seeing the data file.

    If it seems like a security issue I will take it to a different forum. I just posted here first because when the data disappeared this summer it was the Windows system causing the trouble, which is what made me go there first. I only looked at Comodo after restarting file explorer and restarting my computer. Could it also be something in the User Account Control settings? I would appreciate suggestions to help make this work. These files are really important and I need to access them this coming week. I know none of the data is lost as I have it saved on the old hard drive as well as a flash drive, but neither of those are allowing the program to see the data. Thanks for your help.
  2. mom26gr8kids

    mom26gr8kids TS Guru Topic Starter Posts: 517

    By the way I should specify that I have gotten the runtime error several times during the process when trying to help my new laptop find the pathway and that went away once I finally accessed the data. I am only getting the error with the one program now that it can't find the files
  3. jobeard

    jobeard TS Ambassador Posts: 11,168   +986

    User Files like foo.dat are poorly named -- as your user profile has that kind of name in the root of your profile.
    1) change the name if you can

    Knowing the path to the file location will allow you to explore the NTFS perms.
    First, use the cmd prompt to CD to the folder and then use DIR file name to get some info. Next, try to show the content to prove it's accessible
    Last edited: Jan 14, 2015
  4. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    I hate to confuse you, but the problem may be resolved if you can 'take ownership' of the files whilst using your normal profile. Also possibly the containing folder(s). I cannot give you precise steps to do this, but you can certainly research that topic.
    Last edited: Jan 14, 2015
  5. jobeard

    jobeard TS Ambassador Posts: 11,168   +986

    Bump; correction "your user profile has that kind of name"
  6. mom26gr8kids

    mom26gr8kids TS Guru Topic Starter Posts: 517

    Thanks for the help. As it turns out some of the files were hidden. Since I haven't operated Windows 8.1 very much I did not realize this was the case. I got the problem fixed, but I appreciate the time you took to offer me some suggestions.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...