Firefox cannot open PDF files in URL

By Doug8765 ยท 4 replies
Nov 26, 2011
Post New Reply
  1. Hi -
    I don't know if this is the right place to ask this question, but one of your experts suggested (Broni, in the malware thread) to try this forum.
    • A couple years ago I decided to try out a different PDF reader, Foxit. Right away I did not like it and I uninstalled the thing.
    • Ever since, I cannot read any PDFs that are embedded in the URL, such as this one that I just tried after I recently reinstalled Firefox:
    • This problem does not exist for PDFs that are attached to files. For that the Adobe PDF reader successfully gets the job done.
    • I have tried repeatedly to go to the Firefox support and there are some entries there about people who have this problem also, but there's no help in getting rid of the problem.
    • Apparently, even if you delete/uninstall Foxit, somehow Firefox still wants to use Foxit to read the URL. In such a state, a non-existent app is given the task of reading the PDF.
    • In the past I brought this problem to Tech Spot and the proffered solution was to uninstall Firefox and reinstall. At the time I was unwilling to uninstall Firefox for fear of losing my bookmarks. However, now I have uninstalled Firefox and reinstalled Firefox (thank you Broni, for the authoritative uninstall/reinstall link from Mozilla) and the dang nonexistent Foxit reader still has the job of reading PDFs that are embedded in a URL.
    • My workaround has been always to edit|copy the URLs that have .PDF extensions and paste them into IE. That's irritating, but it does work.

    Any suggestions?

    If this is the wrong forum, please advise.

  2. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    Firefox has a menu entry Options under Tools

    That leads to a form with various top-line icons, the fourth of which is 'applications'

    Down the list is an entry for 'foxit pdf document' and alongside that is the application plugin drop-down listbox. This offers possibly several different registered plugins, and also 'use other...."

    Selecting that 'use other' opens a large selection of helper applications on your PC that can conceivably open the document type you are referencing. Plus a browse button.

    Good luck with finding something to use. Of course, firefox has an enormous range of available add-ons which you can peruse by selection menu option Tools / Add-ons
  3. Rabbit01

    Rabbit01 TS Evangelist Posts: 787   +58

    If you reinstall/update Acrobat Reader, it should add a plugin for Firefox. There's this entry when I type "about:plugins" (w/o quotes) in the address bar.

    Adobe Acrobat
        File: nppdf32.dll
        Adobe PDF Plug-In For Firefox and Netscape 10.1.1
    MIME Type 	Description 	Suffixes
    application/pdf 	Acrobat Portable Document Format 	pdf
    application/vnd.adobe.pdfxml 	Adobe PDF in XML Format 	pdfxml
    application/vnd.adobe.x-mars 	Adobe PDF in XML Format 	mars
    application/vnd.fdf 	Acrobat Forms Data Format 	fdf
    application/vnd.adobe.xfdf 	XML Version of Acrobat Forms Data Format 	xfdf
    application/vnd.adobe.xdp+xml 	Acrobat XML Data Package 	xdp
    application/vnd.adobe.xfd+xml 	Adobe FormFlow99 Data File 	xfd
    note: it's "about:" and "plugins" with no space in between. Not a smiley w/ a tongue sticking out. For whatever reason, this editor isn't showing what I typed as I intened.
  4. Doug8765

    Doug8765 TS Booster Topic Starter Posts: 208

    That did it.

    Hi -
    Thank you both. I appear to be able to read PDFs in URLs now.

    I changed the Tools | Options | Applications tab - Adobe Acrobat Document entry to Use Adobe Reader (default). Then I closed the browser and rebooted and tried a URL that did not work before. It worked.

    Although that seems too easy, I'll point out that uninstalling the browser and reinstalling must have helped, because over a long period of time I've tried just this kind of modification multiple times.

    Not trying to sound ungrateful, just not stupid.

    Many thanks.

    Doug Roberts
  5. Rabbit01

    Rabbit01 TS Evangelist Posts: 787   +58

    Thanks for the update. Glad to hear problem is resolved.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...