Flash drive problem

By trdr ยท 7 replies
May 16, 2009
  1. first time install of a new Lexar JD FireFly 4gb flash drive
    old computer with w2k sp4, plugged flash in, driver installs and it's assigned
    F. open explorer, click on F, drag and drop or copy/paste and get this msg:
    'Cannot copy 'file': Cannot find the specified file. Make sure you specify the
    correct path and filename.'

    in Administrative Tools/ComputerManagement/Storage
    /Removable Storage/Physical Locations the usb device has a red disk with
    white X displayed on the listing

    also the drive doesn't appear in the disk management utility

    have you any ideas what might be causing the above and how to fix it ?
  2. Lanarkshire IT

    Lanarkshire IT TS Rookie Posts: 46

    hi there

    does it work ok in another pc? also has it been formatted?

  3. trdr

    trdr TS Rookie Topic Starter

    hi Lanarkshire IT, tested the flash with a small utility program [attached]
    and it works so must be formatted

    the problem isn't the flash but somewhere in my computer

    Attached Files:

  4. NetCablesPlus

    NetCablesPlus TS Maniac Posts: 228

    I am not sure for Win2k, but for win98 you need the specific driver installed on the PC for the device. USB alone is not enough. Go to the manufacturer's site and see if they offer a download of drivers for the device on win2k and apply that.
  5. trdr

    trdr TS Rookie Topic Starter

    hi NetCablesPlus, don't think it's Lexar driver

    i was online-chat with Lexar Support on Monday, even had a supervisor come on
    and neither suggested a Lexar driver but i do have a problem with a PCI device -
    a TelDrive ES56T-PI family V.90 PCI modem

    at first it was marked in the Device Manager with a yellow ?, so i copied the Drivers
    folder from Win98 to the desktop - the computer was originally installed with w98
    and used the Update driver to search through the drivers and it found 2 tho neither
    were the correct driver tho better than the one that loaded with w2k, but the Lexar
    still wouldn't work after testing both drivers; the yellow ? has changed to a !
    don't know the modem ever worked or had the correct driver as it was never used
    but think that's the cause of the flash drive problem

    i should search some more to see if i can find the TelDrive driver but the vendor
    ESS Technology doesn't list anything on it's site, maybe i'll email them and see if
    they can send me the driver
  6. trdr

    trdr TS Rookie Topic Starter

    hi NetCablesPlus, i found and loaded what appears to be the TelDrive driver,
    losing the yellow ! but the Lexar was still disabled so i went to the Lexar chat and
    all they could say was the flash drive was plug-and-play and didn't require a driver

    don't know what else to try, seems to be a lot of people have problems with usb
    devices and don't find solutions . . .
  7. xehqter

    xehqter TS Rookie

    #1. Does the flash drive work in another computer?

    #2. Does a different flash drive work in your W2K SP4 computer?
  8. trdr

    trdr TS Rookie Topic Starter

    hi xehqter, problem solved - bought a new computer

    didn't buy of course to run the thumb drives, my old one was really old -
    bought in 2000, friday nite the cds wouldn't work so that was the last straw
    am now speeding along with an e5200 dual core 3 gig mem xp pro system
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...