Funky issues with Razer Deathadder

By Steelseries ยท 4 replies
Jun 15, 2010
  1. Hello everyone

    First I would like to point out that I didn't really had a clue where to put this question, but I figured since I'm using my mouse to play games with (mostly), I thought I would put it here.

    Since a few days, my mouse is really acting strange. It happens to be that I can't hold down the Left mouse button. For instance: I'm quiet the counterstrike player and when I'm holding down my left mouse button in order to 'spray', it stops after a few shots. Another example: when I want to drag a file from one folder to another, I keep 'dropping' the file. Or when scrolling on a website using the left mouse button, it stops after a few secs. It's really weird, never had this problem before.

    I'm not sure it this has anything to do with it, but I'm having this problem more and more often since I installed a game on my pc, a couple of days ago.

    I'm using a Razer Deathadder.

  2. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Can you tell us the computer and configuration on which you are working?
    What is the brand and model of mouse ? What has happened when you have trieds using an alternate mouse?
  3. Steelseries

    Steelseries TS Rookie Topic Starter

    Yep, sorry I didn't include this information.

    - Windows Vista 64 bit
    - Intel Core 2 Duo CPU 3.00 GHz
    - 4 GB RAM
    - MSI Motherboard
    - Grapiccard: ATI Radeon 9600

    The mouse I'm using is from the brand Razer, model Deathadder.

    I've already reinstalled the drivers, which were included. I've tried to install certain firmware, which the website of Razer offers, but it fails every attempt. I've read the guide that was included with the mouse on how to clean it, but they only suggest to clean the lens once in a while (which I do, but I don't think the lens is the problem).

    I've tried using a different mouse and it works fine.

    I've been looking on the internet for people who experience the same problem like me, but nothing precisely like this. Though, some people have other problems with this mouse.

    I've bought this mouse 3 years ago, so maybe the quality is coming to its end (?).

    Thanks for the reply!
  4. raybay

    raybay TS Evangelist Posts: 7,241   +10

    You have already worked out the answer to the problem... The unknown brand Razer doesn't work, but another mouse does... Contact the seller or the Razer maker and insist upon a replacement.
  5. hellokitty[hk]

    hellokitty[hk] Hello, nice to meet you! Posts: 3,448   +145

    Or you could try and flash the firmware, should be able to by clicking update on the driver utility.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...