Geforce 7600 GS, OpenGL help

By sprandel17 ยท 7 replies
Jun 28, 2008
  1. I have a Geforce 7600 GS card installed in my PC that says its capable of OpenGL 2.0 if I'm not mistaken. I tried to play World of Warcraft one night on GL and it said it couldn't load the GL drivers, install new ones. I did, and it didn't help so I went with DX instead, but now trees and characters and everything were disappearing at random, so I'd much rather play on GL if it's at all possible. ANother game I tried says I don't have the OpenGL drivers (1.5 required), but I think I do... and the DX is doing the same thing. I can play it on GL but it's extremely choppy and just unbearable. Am I supposed to install something for OpenGL or what? I'm good when it comes to DX but OpenGL is a whole new world to me, anything at all is appreciated. :cool:
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    I got all this from forums.worldofwarcraft
    I've just copied and pasted the relevant ones
    Please let me know which one possibly fixed it

    I found 81.98 works great displaying videos & DVD's in windows, and running WoW
    Uninstall Nvidia display driver through add/remove programs in the control panel.
    Make sure to run Driver Cleaner Pro to remove all of the NVIDIA garbage left behind after the uninstall:
    Download install the following driver: Geforce 81.98

    Set Performance and Quality settings
    Antialiasing and Anistropic settings to application controlled

    Go to your desktop properties (XP) and then the settings tab, click on advanced then the troubleshoot tab and click off 'Enable Write Combining'.

    Turn ON Vertical sync and lower all other video settings in video settings in the game.

    I think that the fix lies within the file in the World of Warcraft folder in c:/program files/world of warcraft/ WTF
    You can open it with a text editor (wordpad), and then type in...
    SET gxApi "opengl"
    See if that helps.
    If not, try
    SET gxApi "direct3d" instead

    It seems to be a major problem with all 7600 seriers cards and only in World or Warcraft.
    It's a problem with wow imo, not the card.
  3. sprandel17

    sprandel17 TS Rookie Topic Starter Posts: 45

    I did everything up to installing 81.98 and when I started to install it said "The NVIDIA Setup Program could not find any drivers compatible with your current hardware. Setup will now exit."
  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Remove the card
    Start Windows with your onboard video
    Confirm your onboard video drivers are up to date

    Just a note here:
    It may be better at this point to remove all video drivers (from everywhere)
    Then download and install the updated, onboard, video drivers
    Confirm the onboard video drivers are perfect!

    Then install the addon video card
    Then update the drivers (well use the 81.98 actually)

    That's about it
  5. sprandel17

    sprandel17 TS Rookie Topic Starter Posts: 45

    I don't think that is at all possible. It gave me a Found new hardware Video controller (VGA) or something, everything in dxdiag was unkown, it has no idea what kind of card it is... It's now fully detached from my PC and sitting in my hand, the Pc running on the MoBo video and it says Found new hardware, Video controller (VGA) but its still all unknown... I'm just very confused right now, I don't know where to go from here.

    Edit: SiS 741 Now Installed. Now I just have to get the other one down.
  6. Tha General

    Tha General TechSpot Paladin Posts: 1,106

    The 81.98 are great drivers. But i don't know if they are for the 7600GS. I never even heard of a 7600GS card.

    I hope everything works out tho :)
  7. Rage_3K_Moiz

    Rage_3K_Moiz Sith Lord Posts: 5,443   +38

    Your PC is probably running the game on the onboard video. There should be an option in the BIOS to disable it. This happens sometimes with old motherboards, where even if the card is installed, the PC will still boot off the onboard video.
  8. Tha General

    Tha General TechSpot Paladin Posts: 1,106

    I was thinking that was doing that with my radeon 2400 pro pci card, but there is no option in my bios to disable the onboard, i just disable it in the system control panel area
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...