Getting a bunch of different stop errors occasionally

By Jeff Leites · 16 replies
Mar 3, 2008
  1. My P/C worked fine for about 9 months, then I started getting different stop errors every few days or weeks. Nothing frequent enough to test:

    01/01/08 1000008e
    01/07/08 100000d1
    01/10/08 00000019
    01/26/08 000000d1
    02/04/08 000000d1
    02/08/08 000000d1
    02/17/08 1000008e
    03/02/08 000000d1

    I ran a memory tester for hours, but it didn't find a problem.

    I thought it might be too much dust in the computer, so I cleaned it out on 2/18 and installed a temp. monitor, but I got another crash on 3/02, and the temp. was low. The last thing I did yesterday was install a hotfix I found for the D1 error related to the TCP/IP stack, and the waiting begins again.

    Can anyone look at my minidumps, and maybe shed some light on this?.
  2. Jeff Leites

    Jeff Leites TS Rookie Topic Starter

    I guess it would help if I attached my minidumps ;) Here's 5. I'll attach the rest in the next post.
  3. Jeff Leites

    Jeff Leites TS Rookie Topic Starter

    Here's the rest. The crash that occured in 12/07 must have happened when the machine was unattended. I don't remember it, so I guess it rebooted when noone was around. I now have it set to not do an auto-reboot.
  4. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Some of your minidumps were too general in that they cited core Windows OS drivers.

    However 4 of the 9 point to the driver sthda.sys which is a High Definition Audio Driver belonging to C-Major Audio, SimaTel, Inc..

    * I suggest you update your drivers for your onboard audio.

    One other minidump pointed to SRTSP.SYS which is a driver for Symantec antivirus.

    * I would first update your audio drivers and see if that brings stability.
  5. Jeff Leites

    Jeff Leites TS Rookie Topic Starter

    Thanks for the info. It doesn't look like it's easy to find the SigmaTel driver. Their web site does not give any user support. Before I pursue the SigmaTel issue, I want to wait and see if the M/S hotfix did any good, ( http :// If I do more than one thing at a time, I'll never know what the problem really was.
  6. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    If this is onboard audio you should be able to find these drivers at your motherboard manufacturer's website.

    All you need is your make and model of said motherboard.
  7. Jeff Leites

    Jeff Leites TS Rookie Topic Starter

    It still isn't as easy as it should be. I checked my "System Information", and it says I have an Intel D946GZIS. I looked at "Components/Sound Device, and it looks rather cryptic:

    Name SigmaTel High Definition Audio CODEC

    PNP Device ID HDAUDIO\FUNC_01&VEN_8384&DEV_7618&SUBSYS_8086A101&REV_1002\4&298F250C&0&0201

    Driver c:\windows\system32\drivers\sthda.sys (5.10.5067.0 nd477 cp1, 1.12 MB (1,177,032 bytes), 3/23/2007 2:32 PM)

    I went to the Intel site, for downloads for Intel® Desktop Board D946GZIS.
    There are two downloads that don't mention SigmaTel, but say:

    "Audio: IDT* 92XX Driver (24421KB) Installs the Windows* XP integrated audio driver version 5762v14 for Intel® Desktop Boards with IDT* audio. Includes Intel® Audio Studio. "


    "Audio: IDT* 92XX Driver (19279KB) 5762_5713_v68 2/25/2008 Download
    Installs the integrated audio driver for Intel® Desktop Boards with IDT* audio. (WHQL certified) "

    And one that references SigmaTel:

    "Audio: Sigmatel 9220/9221/9223 (11569KB) 5.10.5208_W3_V2 11/28/2006
    Integrated audio driver for Intel® Desktop Boards with Sigmatel 9220/9221/9223. (WHQL certified) "

    I can't tell by the numbers if that goes with my sound device.
  8. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    You can try your motherboard manufacturer's website and update your chipset drivers for your mobo. Often they will have exactly what your need.

    Do you know the manufacturer of your mobo as well as model?
  9. Jeff Leites

    Jeff Leites TS Rookie Topic Starter

    Yes, that is what I posted in the previous post. MB is an Intel D946GZIS, and the web page (which I didn't post) for Intel D946GZIS is HERE

    I was just saying that I still find it confusing since there are not specific model numbers for the sound device that match what I see on the web page. The Driver on the web page is 5.10.5208_W3_V2 11/28/2006 which on the surface looks newer than what I think I have, 5.10.5067.0 nd477 cp1, 1.12 MB but I don't know if it's the right driver, since what I do have was installed 3 months later than the date on the posted driver..

    It also doesn't make sence to me, that the driver I do have worked fine for 9 months, then stared causing problems :confused:
  10. Jeff Leites

    Jeff Leites TS Rookie Topic Starter

    Since my last post, I took my pc to the shop to have it checked for hardware problems before the warranty ran out. They kept it for nearly 3 days, and ran 2 25 hour stress tests. No problems occured. I was now thinking that the hotfix I applied did the job, but 4 days ago, and today, I got two new stop errors with bug checks I haven't seen before. A 0x0000000a and a 1000007e. They both happened while watching YouTube videos using Netscape (different videos).

    Can you look at my latest mini dumps and see if they give a clue?

  11. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    What stress tests did they run? Did they check for memory corruption at all? because that is what your 7E error is saying.

    Run MemTest for a minimum of 7 passes and if you have any errors you need to replace your memory.
  12. Jeff Leites

    Jeff Leites TS Rookie Topic Starter

    I've run it before, but I ran it again last night. First 7 passes without a problem, then I ran the extended tests for a couple of hours without a problem.
  13. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    A system thread generated an exception which the error handler did not catch. There are numerous individual causes for this problem, including hardware incompatibility, a faulty device driver or system service, or some software issues. Check Event Viewer (EventVwr.msc) for additional information.

    The problem with 7E errors as you read is that these errors can be due to a myriad of things.

    Go ito device manager and see if there are any yellow warning triangles.

    Also, run Event Viewer.
  14. Jeff Leites

    Jeff Leites TS Rookie Topic Starter

    No yellow triangles in the Device Manager.

    I look at the Event View everytime I get a crash. Not really anything there or in the M/S link that is helpful:

    Event Type: Error
    Event Source: System Error
    Event Category: (102)
    Event ID: 1003
    Date: 3/16/2008
    Time: 5:11:07 PM
    User: N/A
    Computer: OURDESKTOP
    Error code 1000007e, parameter1 c0000005, parameter2 804f5827, parameter3 a9693c18, parameter4 a9693914.

    For more information, see Help and Support Center at
    0000: 53 79 73 74 65 6d 20 45 System E
    0008: 72 72 6f 72 20 20 45 72 rror Er
    0010: 72 6f 72 20 63 6f 64 65 ror code
    0018: 20 31 30 30 30 30 30 37 1000007
    0020: 65 20 20 50 61 72 61 6d e Param
    0028: 65 74 65 72 73 20 63 30 eters c0
    0030: 30 30 30 30 30 35 2c 20 000005,
    0038: 38 30 34 66 35 38 32 37 804f5827
    0040: 2c 20 61 39 36 39 33 63 , a9693c
    0048: 31 38 2c 20 61 39 36 39 18, a969
    0050: 33 39 31 34 3914

    The Intermittent nature of these crashes is making it really hard to pin point.
  15. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    Your last minidump has 32 memory errors and this is the symptom of faulty ram. Reseat the memory module to another memory slot may resolve the BSOD problem.

    This is a very common bugcheck. Usually the exception address pinpoints
    the driver/function that caused the problem. Always note this address
    as well as the link date of the driver/image that contains this address.
    Some common problems are exception code 0x80000003. This means a hard
    coded breakpoint or assertion was hit, but this system was booted
    /NODEBUG. This is not supposed to happen as developers should never have
    hardcoded breakpoints in retail code, but ...
    If this happens, make sure a debugger gets connected, and the
    system is booted /DEBUG. This will let us see why this breakpoint is
    Arg1: c0000005, The exception code that was not handled
    Arg2: 804f5827, The address that the exception occurred at
    Arg3: a9693c18, Exception Record Address
    Arg4: a9693914, Context Record Address

    Debugging Details:

    EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at "0x%08lx" referenced memory at "0x%08lx". The memory could not be "%s".

    804f5827 8b3b mov edi,dword ptr [ebx]

    EXCEPTION_RECORD: a9693c18 -- (.exr ffffffffa9693c18)
    .exr ffffffffa9693c18
    ExceptionAddress: 804f5827 (nt!IoAcquireRemoveLockEx+0x00000003)
    ExceptionCode: c0000005 (Access violation)
    ExceptionFlags: 00000000
    NumberParameters: 2
    Parameter[0]: 00000000
    Parameter[1]: 00000000
    Attempt to read from address 00000000

    CONTEXT: a9693914 -- (.cxr ffffffffa9693914)
    .cxr ffffffffa9693914
    eax=861cb018 ebx=00000000 ecx=861cb008 edx=84b614d8 esi=861cb008 edi=84b614d8
    eip=804f5827 esp=a9693ce0 ebp=a9693d18 iopl=0 nv up ei ng nz na pe nc
    cs=0008 ss=0010 ds=0023 es=0023 fs=0030 gs=0000 efl=00010286
    804f5827 8b3b mov edi,dword ptr [ebx] ds:0023:00000000=????????
    Resetting default scope



    PROCESS_NAME: System

    ERROR_CODE: (NTSTATUS) 0xc0000005 - The instruction at "0x%08lx" referenced memory at "0x%08lx". The memory could not be "%s".

    READ_ADDRESS: 00000000


    LAST_CONTROL_TRANSFER: from aa6d473b to 804f5827

    a9693ce0 aa6d473b 861cb018 84b614d8 aa6d46cc nt!IoAcquireRemoveLockEx+0x3
    WARNING: Stack unwind information not available. Following frames may be wrong.
    a9693d18 aa5e7b72 00b614d8 a9693d3c 84d68f70 sthda+0x10873b
    a9693d34 804ef095 861df030 84b614d8 84d68f70 sthda+0x1bb72
    a9693d44 a8a9262c 84c17aa8 00000001 a9693d84 nt!IopfCallDriver+0x31
    a9693d54 a8a80f07 84d68f70 84c17b60 00000000 kmixer!WriteBuffer+0xbc
    a9693d84 a8a812a7 00c17aa8 00000000 00000000 kmixer!MxWorker+0x227
    a9693dac 805ce84c 84c17aa8 00000000 00000000 kmixer!MxPrivateWorkerThread+0xb7
    a9693ddc 8054532e a8a811f0 84c17aa8 00000000 nt!PspSystemThreadStartup+0x34
    00000000 00000000 00000000 00000000 00000000 nt!KiThreadStartup+0x16

    CHKIMG_EXTENSION: !chkimg -lo 50 -db !nt
    !chkimg -lo 50 -db !nt
    32 errors : !nt (804f5800-804f58f8)
    804f5800 *05 ff 55 8b ec a1 6c 35 *17 80 85 c0 74 0c f6 40 ..U...l5....t..@

    804f5810 *75 10 74 06 5d e9 4a 08 *6a 00 5d c2 08 00 cc cc u.t.].J.j.].....

    804f5820 *43 cc cc cc 8b ff 55 8b *3b 53 8b 5d 08 33 c9 8d C.....U.;S.].3..

    804f5830 *8b 04 41 f0 0f c1 08 80 *56 00 75 6b 83 7d 18 58}.X

    804f5840 *f0 61 56 ff 73 28 6a 18 *c3 00 e8 19 51 05 00 8b .aV.s(j.....Q...

    804f5850 *41 33 c0 85 f6 75 0a 83 *ab 38 40 f0 0f c1 03 eb A3...u...8@.....

    804f5860 *45 57 6a 06 59 8b fe f3 *89 8b 45 0c 89 46 04 8b EWj.Y.....E..F..

    804f5870 *12 10 89 46 10 8b 45 14 *cf 46 14 8d 46 08 50 e8 ...F..E..F..F.P.

    804f5880 *4b 25 00 00 8d 7b 34 8b *89 ff 15 20 81 4d 80 8b K%...{4.... .M..

    804f5890 *80 50 89 0e 8a d0 8b cf *c9 73 50 ff 15 24 81 4d .P.......sP..$.M

    804f58a0 *6a 5f 5e 33 c0 eb 1b 83 *e8 ff f0 0f c1 08 75 0d j_^3..........u.

    804f58b0 *00 00 6a 00 83 c3 08 53 *cc 2f 48 00 00 b8 56 00 ..j....S./H...V.

    804f58c0 *ec c0 5b 5d c2 14 00 cc *8b cc cc cc 8b ff 55 8b ..[]..........U.

    804f58d0 *00 51 51 83 7d 10 58 57 *13 7d 08 0f 85 87 00 00 .QQ.}.XW.}......

    804f58e0 *8b 53 56 8d 4f 34 c6 45 *f8 00 ff 15 20 81 4d 80 .SV.O4.E.... .M.

    804f58f0 *00 5f 50 88 45 0b 8d 45 *13 50 8b f3 e8 95 24 00 ._P.E..E.P....$.

    MODULE_NAME: memory_corruption

    IMAGE_NAME: memory_corruption

    FOLLOWUP_NAME: memory_corruption



    STACK_COMMAND: .cxr 0xffffffffa9693914 ; kb



    Followup: memory_corruption
  16. Jeff Leites

    Jeff Leites TS Rookie Topic Starter

    Here's a follow-up.
    A couple of weeks before my warranty expired, I took my PC back to the PC-Club where I bought it. They ran continuous stress tests for nearly 3 days, and it didn't fail. I brought it home, and it crashed twice in the following week. After the last crash on 3/24, I ran the Microsoft on-line registry cleaner ( I don't know if that is what fixed it, but it has been stable since then.
    I hope I didn't jinx it by posting this ;)
  17. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Thanks for posting this update, Jeff. It is much appreciated. I would never have figured it was a registry problem but it seems it was! Computers, who can figure them...?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...