1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

IDE slots not working

By Dan005 ยท 4 replies
Apr 30, 2009
  1. Hi people, my motherboard seems to have this really annoying problem that I just have no clue to solve.

    basically, the IDE slots seem to be totally screwed up, IDE0 doesn't seem to work at all, and IDE1 occasionally works but 80% of the time doesn't either, the post screen says "detecting IDE" drives but freezes out while displaying results (which are none with them connected), usually half way down, the pc from this point is totally unresponsive and you can't enter the bios, ctrl-alt-del seems to work and restart the pc though.

    also the ide post results sometimes overwrites the top part of the screen and cover the other parts, like "IDE 0 = NONE lon 64 processor 2.4GHz"

    Removing all devices from the IDE ports results in the PC behaving normal and they just don't detect nothing obviously.

    What is the cause of this? corrupted bios? I've tried different ribbons and still the same problem, I did boot my hd's from IDE1 for a few days and worked fine but now it's just stuck in POST.

    Any help would be greatly appreciated.

    I've got a raid so i can use that but i'd like to see whats causing this, the mobo is a KN1SL1 Extreme with a Athlon 64 3500+ processor and 1.5GB of DDR RAM.
  2. mailpup

    mailpup TS Special Forces Posts: 7,102   +419

    You didn't mention the jumper settings you used. Make sure you have two IDE devices on the same cable set to master and slave or both to cable select.
  3. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,729   +409

    Provided you didn't mess with the jumpers since when it last worked normally, and you have good cables I'd say that it is a fairly old board, probably just dying. I had a very similar thing happen to an Asus A7V board a few years back. I suppose if you are set on still using it you could get a PCI IDE Controller card.
  4. Dan005

    Dan005 TS Rookie Topic Starter

    Both have the correct jumper settings, one is on master with slave present and the other is on slave.

    Granted it's not exactly cutting edge and a few years old, but it's still a nice board, got SLI, upgradable to dual core, sata ports, the only thing I can see that's old about it (apart from it's phyiscal age) is DDR Ram, but it runs Vista and everything else like it's nothing, it's just a shame.

    IDE Raid it is then, and maybe get some Sata drives soon.

    Thanks anyway :)

    Well I did a BIOS flash and now they appear to be working, BIOS must of corrupted, I speculate that at first but BIOS flashes are pretty risky and I didn't want to brick my board, as the last resort, I did it and it was the culprit after all, phew.
  5. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,729   +409

    Good to hear. I should have suggested that but I just went with the dead controller issue since a flash didn't fix mine.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...