1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Integrated webcam just will not work

By j4g3d · 46 replies
Oct 23, 2011
Post New Reply
  1. I hope someone on here can help me.

    I bought a brand new Lenovo SL510 about 8 months ago and till this day i cannot get the integrated web cam working. It doesnt pop up in device manager, ive installed the drivers for it from the lenovo site. Just wont work.

    If you google the issue many others have the same problem with no real solution found to solve the issue so far....

    Heres a task for someone on here?
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    Is there possibly an on/off switch for the webcam? Make sure it's on
    Also look through all pages of your BIOS setup menu on the off chance it might be an option that can be disabled (if you see it, make sure it's enabled) Then

    1. List any Problem Devices
    • Make sure devices are connected and powered on
    • Click Start->Run, enter: msinfo32. Click the + sign next to Components to expand it
    • Click Problem Devices. Anything appear?
    • If yes, click on it, Ctrl-A to select all, Ctrl-C to copy it, Ctrl-V to paste into next post
    • On the other hand, if no devices are listed, tell me so

    2. See [post=939115]How To Report Your Computer's Device Manager Data[/post]
    > Be sure that when you Save As, you do so as Tabular Text (.txt)
  3. j4g3d

    j4g3d TS Rookie Topic Starter Posts: 17

    Thanks for the reply. I have some problems devices (below.) But they dont seem to relate to a webcam. Its listed bluetooth (works fine) also my printer (works fine) and some wifi adaptor. Oh and its not listed in the BIOS i already tried

    Bluetooth Peripheral Device BTHENUM\{426C6163-6B42-6572-7279-427970617373}_LOCALMFG&000F\7&48A653B&0&A06CECB3E7C5_C00000000 The drivers for this device are not installed.
    Bluetooth Peripheral Device BTHENUM\{426C6163-6B42-6572-7279-44736B746F70}_LOCALMFG&000F\7&48A653B&0&A06CECB3E7C5_C00000000 The drivers for this device are not installed.
    Bluetooth Peripheral Device BTHENUM\{00001132-0000-1000-8000-00805F9B34FB}_LOCALMFG&000F\7&48A653B&0&A06CECB3E7C5_C00000000 The drivers for this device are not installed.
    Microsoft Virtual WiFi Miniport Adapter {5D624F94-8850-40C3-A3FA-A4FD2080BAF3}\VWIFIMP\5&5D34253&0&01 This device is disabled.
    Photosmart C7100 series ROOT\MULTIFUNCTION\0000 The drivers for this device are not installed.
    Photosmart C7100 series ROOT\MULTIFUNCTION\0001 This device is disabled.

    PS cannot upload file of my laptop as you suggested as it is bigger than the file size allowed
  4. j4g3d

    j4g3d TS Rookie Topic Starter Posts: 17

  5. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    Please run the Device Manager report again. You need to Save As using the pull down option to save as Tabular Text File (NOT simply as text file)
    > The report text may look jumbled and hard to read but "Tabular Text" creates a file i can import to Excel (which makes it easy, columnar and then easy for ME to read and sort by columnar data as i need)
    > And report size should be MUCH smaller when you save as Tabular Text
  6. j4g3d

    j4g3d TS Rookie Topic Starter Posts: 17

    Sorry about that.

    I have saved as the tabular text file now like you said but again the forum says it exceeds the limit. The file now is 327kb and the forum only allows 200kb

    Tabular tet file saved below
  7. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    Oh. I guess it's still too large a file to attach (so now I'm the one sorry about THAT :p) but otherwise the file format is good :) I can import it to Excel

    On quick glance, I can see that your cam was at least detected at least at sometime in the past. Will take a closer look at the data and get back to you when i can
  8. j4g3d

    j4g3d TS Rookie Topic Starter Posts: 17

    No no need to say sorry i appriciate your help!

    By the way the info you listed above is the date when i reinstalled the drivers again
  9. mike1959

    mike1959 TS Evangelist Posts: 1,020   +55

  10. learninmypc

    learninmypc TS Evangelist Posts: 8,452   +546

    IF its still under warranty, take it back & make them fix it before you void your warranty:(
  11. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    Learninmypc may have the best advice. I missed the fact it's only 8 months old. Is it still under warranty?

    That said, I can explain more later, but this is how I interpret your data (to the best i know). Your Device Manager data indicates the web cam hardware is no longer being detected by Windows which means either
    1. The cam is turned off
    2. The cam is disabled in BIOS
    3. Or the cam hardware has failed :dead:

    And it sounds like you already checked 1) and 2)

    fyi... Briefly.... By default when you look in Device Manager on your PC, it only displays devices that are connected, powered on and currently DETECTED by Windows
    > Windows doesn't need drivers to detect plug and play (pnp) hardware (like your cam)
    > In fact, thats how PnP works in the first place. Windows first detects hardware, the h/w sends Windows those cryptic looking Hardware IDs (your cam's Hardware ID is USB\VID_17EF&PID_0481. DevManView drops the leading zero in the PID and displays it as USB\VID_17EF&PID_481)
    > Windows finds drivers based on the IDs

    DevManView displays all Device Manager data still in the registry (even for devices not currently detected but detected at least once in the past and their drivers are still loaded). If you look in DevManView tool output on your PC, you can click the Device Instance ID column header to sort by ID. Then you'll see for each instance of your cam ID USB\VID_17EF&PID_481, look under the Connected column. They all say NO :(
  12. j4g3d

    j4g3d TS Rookie Topic Starter Posts: 17

    It is under warranty still till next year. I did go on the lenovo website to work out how i return it for a repair but the site gave me a list of service centres. I called the 2 local ones and they both said they do not offer repairs, there only a reseller of lenovo.

    Also the power jack is wobbly (still charges) so i think thats covered under warranty too. Also one USB port is damaged and a couple of keys stick. Not sure if they would repair the latter 2 under warranty?.
  13. learninmypc

    learninmypc TS Evangelist Posts: 8,452   +546

    I'd suggest you read thrir Terms of Service to see if they have to fix it or if you're out of luck. I wish you the best.
  14. j4g3d

    j4g3d TS Rookie Topic Starter Posts: 17

    I have contacted a local lenovo service centre and i took the laptop to him. He checked it quickly and confirmed its not showing in device manager. He then said he will order a new cable and also a charging jack. I also have a damaged usb port and he said that may not be under warranty but he can sort it for about £15.
  15. ali kareem

    ali kareem TS Rookie

    hello, I've just formatted my pc I'm using msi notebook it has a web cam but I cant even see it's driver in device manager to download the driver for it. though I know it's manufacture driver is bison so I downloaded and installed bison webcam it came with certain program still I couldnt see the driver nor use my webcam. I uploaded my devices from device manager as you instructed hope you can help me. model number for my laptop is "ms-1719"

    Attached Files:

  16. mike1959

    mike1959 TS Evangelist Posts: 1,020   +55

    Hi Ali, The MSI website has an automatic scanner/updater for their PC's, which should find and download the missing files for your PC.
    It's at; http://uk.msi.com/service/download/
  17. Lee Donghae

    Lee Donghae TS Rookie

    Help me please, I have the same trouble

    Attached Files:

  18. Kathy lee

    Kathy lee TS Rookie

    I looked through the trend and another similar one before asking. I don't want to be an inconvenience but the things I tried through this trend and the other one did little to help. Perhaps I'm not doing it right?

    My built-in camera for my laptop suddenly stopped working some time back. I found out when I was using this one website to take pictures like I always do and it told me camera not detected. It told me on Skype as well. I ran problem devices and it only detected printer problems; it does not detect problems with my cam.

    I have Windows 7 Home Premium, 64-bit.
    6.1.7601 Service Pack 1, Build 7601
    System Model AO756

    I am at my wits end and have been trying to fix it for two months. Thank you beforehand for taking your time to read.
  19. mike1959

    mike1959 TS Evangelist Posts: 1,020   +55

    Hi, The first and main approach I would take would be to go the the Acer site;
    Your AO756 is in the 'Netbook, Chromebook' family group, select that and continue.
    Then you will see an option to download a program in the link 'Need to know the hardware in your pc to download the correct drivers?' ; so that might be worth a try if you haven't done so already.
    If a driver is available from Acer, might be a good idea to uninstall the existing one first.
    Otherwise, there are a couple of programs that will scan your pc and might find the drivers you need.
    I have had good results with : http://drivereasy.com/
    which really does not charge you for the service of finding free drivers. Many programs will offer to sort out the drivers, at a cost, which is obviously not the best idea.
    *There is a chance that the camera really isn't working, and not a driver problem, in that case a separate USB webcam could be used.
    Kathy lee likes this.
  20. Kathy lee

    Kathy lee TS Rookie

    Oh my gosh, thank you so SO much. I'm going to try it right now, thank you.
  21. Dimitriusharo

    Dimitriusharo TS Rookie

    I got an HP in September and my Hp Truevision HD webcam cannot be detected or turned on.
    Lexmark X422ROOT\IMAGE\0002This device cannot start.
  22. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    I hope it's still under warranty. Alot of people with HP laptops report it not being detected. The Hardware ID you posted is not your webcam. Is very most likely web cam hardware failure :(
  23. onlymy2cents1

    onlymy2cents1 TS Rookie

    If you recently installed Windows 8 on a computer that had a different operating system on it and you can get your webcam to work on the desktop side of Windows 8 but not in the Metro side of Windows 8, this may solve your issue.
    Follow these steps to get your webcam working in both desktop and metro sides of Windows 8.
    1. Go Settings/Control Panel/Hardware and Sound/Devices and Printers/Device Manager
    2. Go to the Imaging Devices and Disable the webcam
    3. Go to Control Panel/Program and find your webcam's DRIVER and uninstall the DRIVER, not the webcam.
    4. Shut down your computer; wait 30 seconds and turn it back on. Login and go back to the Device Manager (see steps 1 and 2 above) and then ENABLE the webcam.
    This worked like a charm for me on my Fujitsu T5010 built-in webcam. I hope it works for you too.

    On a Lenovo, there is no webcam app. It should automatically find your webcam with whatever app you use if you have successfully installed the drivers from the Lenovo website. On Windows 7 systems, there is usually a keyboard combo that invokes the settings of the webcam once the drivers are installed. On my Lenovo T410, that key combo is FN+F6. It may be different on your system, but don't look for a webcam app with Lenovo at all, it doesn't exist (at least not on Win7)

    If you just have to have an app, there is an okay generic webcam app out there that works in Vista/Win7 and Win8 called MyCam. It is easy to install and gives you the ability to change settings and use all of your webcam's features (most any webcam works with it).
    RICO GOLDSTAR likes this.
  24. jitendra g33

    jitendra g33 TS Rookie

  25. jitendra g33

    jitendra g33 TS Rookie

    I have same problem of web cam::I open msinfo32 and it seems like this:
    Lexmark X422ROOT\IMAGE\0000This device cannot start.
    I have lenovo core2deo

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...