Limited wifi acces at home, but not at other places


Hi jobeard,

In the beginning of the month you seemed to have solved this issue

You (or someone else) might be a great help for me as well since I have a similar issue. At home I don't have access to wifi (it says limited access) although the internet is working fine by an ethernet cable at home. In addition I do have access to wifi at work or in public places like a hotel.

I have already browsed the web but I still cannot figure it out. An TCP/IP reset did not work, the drivers of my wifi adapter should be fine, ...

My system information:
- HP Elitebook
- Windows 8 Enterprise Edition (64bit)
- wifi router: DrayTek Vigor AP 800 (this device acts as an access point that broadcasts wifi, it is not the actual modem)

If you have any advice for me, please let me know :) it is strange that I only have this wifi probem. Is it maybe because there is an homegroup (actually I don't know whether there is one)? Is it maybe because of the AV program (I have McAffee, but since it this the laptop from work I can't uninstall it)?

I really don't know anymore. I have included 6 files with the output of the commands IPCONFIG /ALL and ROUTE PRINT.

Thank you in advance!


Hello maarten747 ,

As far as I can see from the ipconfig output your laptop doesn't seem to obtain IP address.
You could try configuring one manually to test this theory. Something like: IP address, Subnet mask:, Gateway:, DNS1:, DNS2: . Just keep in mind that the details listed here are just a guess as I'm not fully aware of the specifics of your home network and a static IP configuration for the wifi adapter is not a good idea actually, so once done testing change it back to obtain IP address automatically.

Also in what wireless operation mode is your DrayTek configured?
Do you have any other wireless devices that are connecting to the same DrayTek ?
When you connect your laptop with ethernet cable, is the ethernet cable connected to the same DrayTek or a different device?
You could try connecting the laptop directly with the ethernet cable and see if that works.

If it doesn't even then, one can suspect it's a network card problem.

If it does, then we can assume, that it's either wifi drivers or wifi settings themselves.

Have you tried that?


Posts: 1,020   +56
Might be worth trying a USB wireless adapter, if available.
You wouldn't have to install any software anyway, and it would prove if the built in wifi board is good or not.
I have had good results on 2 different pc's by changing to a TP-Link USB wireless adapter, plug in and connection to router. One pc was Windows 7, another Linux operating system. Neither needed extra drivers to be installed.
Also I would say to try to update the wifi drivers in device manager, but you say it's a works pc, so that's not likely to be possible regarding admin rights.
  • Thread Starter Thread Starter
  • #6
Now, ten days later, the wifi at home is working fine for my laptop. A few days ago I still had limited access.. This is the first time that I can join the wifi network at hom on this laptop. And I did not change any of the router settings or of my laptop settings. I hope it will keep on working

Thank you for your reply! I had already tried to configure my IP manually with a similar set of IP addresses as you provided. However, it had no effect. After that test I changed it to the automatic configuration again (as you suggested).

Regarding your other questions:
  • the wireless operation mode of the DrayTek is in AP (Access Point) mode and it is in WEP security mode
  • there are indeed a few other laptops, a smartphone and a tablet that connect to the same DrayTek (but usually not at the same time)
  • while connecting my laptop with the ethernet cable, the cable is indeed connected to the same DrayTek device that broadcasts the wifi signal
Thank you for you reply as well! Although the pc is of my employer I have admin rights to update and even re-install the wifi drivers. I had already tried that but without success..

So for the moment my issue is solved but I have no clue why exactly. I did not change any setting since I started this post. Anyway, thanks for the replies :)