Microsoft Security Essentials install problem

By SNGX1275
Jun 16, 2011
Post New Reply
  1. I'm working on a computer that had MSE installed and running at one point. But then something happened and it wouldn't launch on startup. Manually trying to start it threw some error about it needing to be reinstalled.

    Windows update indicated there was an update for it so I ran Windows Update and it seemed to update properly. Well at least the Malicious Software Removal Tool updated successfully.. The program still would not launch, same error as before. So I manually downloaded it from Microsoft, on trying to install I got an error that it can't find some file (appeared to be a temp file unpackaged by the installer app), I hit Ok, at this point the install quit unsuccessfully.

    Now I decided that maybe what I downloaded was some upgrade that MS decided I needed (because I used IE9, thought maybe it could tell what I had) rather than a full install. So I thought I'd just uninstall it and reinstall it. When uninstalling I got an error before the typical uninstall window came up. I think it said that it was already uninstalled and did I want to remove it from the list of installed applications. I told it no. I then downloaded and installed Revo Uninstaller and let it do its big scan on it. From there I removed everything related to it.

    Then I redownloaded it and on the install I get the same dialog that I had before, where it is missing a file. This time I wrote down the file, its looking for mp_ambits.msi. It thinks its in c:\ddc3450.... (so a temp dir). When I hit Ok it says it can't be found and to verify I have access to this location and try again. Or try to find the installation package 'mp_ambits.msi' in a folder from which you can install the product Microsoft Antimalware.

    I did eset's online scan and came up with nothing, so I don't think there is any malware preventing the installation.

  2. Mizzou

    Mizzou TS Enthusiast Posts: 823

    Not sure if this will help, but found this on the MSE Answers page at the link below, looks like it might be worth a shot.
  3. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 10,742   +422

    I did some googling and after trying and failing on a few things I did find a solution.

    I had to get the Windows Installer Cleanup tool from majorgeeks (Microsoft doesn't distribute it anymore because it can sometimes damage other components when removing something). Then I removed Microsoft Antimalware from within the cleanup tool.

    Next I closed MSIExec.exe from task manager (although apparently MsMpENG.exe and MSSecEs.exe can also be running and need to be closed).

    Then I launched the Security Essentials installer through the Run dialog box (Win + R). I'm not sure how important that part was, but it was suggested and I didn't want to go through the whole process again if it failed. Install seemed to take longer than I thought it should, but it installed.

    Edit: Yeh I tried that too Mizzou, didn't work. Although I may have not properly read those instructions, I just browsed there through the open dialog box, so I didn't see a setup.exe and see what packages it unpacked...

    Edit 2: Problem has evolved. On the update (because definitions are out of date) I got "An unexpected problem occured. Install any available updates, and then try to start the program again."

    Edit 3: Rebooted, launched MSE and saw it says the definitions were up to date, I ran the update again just to make sure. Everything looks good.
  4. Mizzou

    Mizzou TS Enthusiast Posts: 823

    Glad you got it sorted out.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...