Microtek filmscan 1800

By Reem
Apr 12, 2016
Post New Reply
  1. Hello,

    I've been searching for ways to make this old slide scanner work.

    The official driver only supports up to WinXP and is also totally lost forever, never to be found.

    The device is properly recognized in Windows 10 x64 as FilmScan 1800.

    I've tried Vuescan but to no avail, simply says:
    'VueScan found a PIE PF1800AFL, but no PIE software for this scanner was found'

    I tried to install winxp, see if it would automatically install when searching with windows update.
    Thing is, I tried 2 custom winxp images (that work in a virtual machine) but all 4 pc's wont show the
    message 'press any key to boot from cd or dvd' (booted from USB stick and CD/DVD), searched for a solution
    but it seems this stuff is just too damn old :p.

    So now I'm stuck :(.

    As princess leia would have said " you're my only hope" :D.
  2. ppiper

    ppiper TS Rookie Posts: 20

  3. Reem

    Reem TS Rookie Topic Starter

    Thank you for replying.

    This was one of the first things I tried.
    They have taken the FTP server down containing said drivers.
  4. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

    Try the HTTP interface (if there is one)

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...