Mouse Wheel problem

By M_Jones ยท 7 replies
Dec 20, 2009
  1. I'm having a very unusual problem with one of our computers.

    We have 3 computers which all have the same hardware in but for some reason one of them is having an odd mouse wheel scrolling issue where it basically wont stop scrolling. I have tried lots of combinations of mice and keyboards and still having the issue.

    I decided to reformat and it seemed fixed, after installing the ATI drivers for my ATI 3870 it started doing it again. So I unistalled them, t started working, and then installed the Omega ATI drivers just incase and it started scrolling again by itself.

    Would appreciate any ideas on this!

    Thanks, Martin
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    On a clean install of Windows only the mouse or the connection to the computer for the mouse can do this
    Are you using USB mice?
  3. M_Jones

    M_Jones TS Rookie Topic Starter Posts: 52

    I've used both types, PS/2 and USB.

    EDIT: I've disabled the mouse wheel which solves some of the problem, obviously only as a temp fix but I discovered that now that the mouse wheel doesn't scroll when I use the run command box its constantly flicking through my past commands. As if I was pressing down on the keyboard.
  4. M_Jones

    M_Jones TS Rookie Topic Starter Posts: 52

    Sorry for the shameless bump but I'm still having problems with this. Can anyone offer any ideas?
  5. tipstir

    tipstir TS Ambassador Posts: 2,473   +126

    Desktop or Laptop? If laptop you can go into the bios and Disable the touch-pad mouse. if it's a desktop remove all the drivers for the mouse and run Ccleaner for junk and registry repair. Reboot the System then install the new drivers for the mouse and attach the mouse to the system. If it still doesn't it, then replace the mouse with another brand or same.
  6. M_Jones

    M_Jones TS Rookie Topic Starter Posts: 52

    It's a desktop. I've tried a few different mouse brands so I presume its a hardware issue. I'll try what you suggest though and see if it helps.
  7. tipstir

    tipstir TS Ambassador Posts: 2,473   +126

    You might have to go into the device manager and and remove all Universal Serial Bus) USB controller and reboot the system. When you login back the OS will rebuild USB Controller drivers. Some times these drivers get corrupted. Now re-install the drivers for your mouse. At this point if it still doesn't work then could be three things USB controller is faulty, the port of USB is bad or just a plain defective mouse.
  8. M_Jones

    M_Jones TS Rookie Topic Starter Posts: 52

    I think I've fixed it. I went into device manager and looked through all the settings, everything seemed fine. I did a scan for changes and a second mouse appeared under Mice which I disabled, hey presto it seems fixed.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...