My computer fails to display external HDDs

My problem:

I have several 2 ext hard drives of different sizes (1TB - independently powered, 120GB) and the same problem occurs with all of them.

When I start up my laptop, the drives will appear in My Computer. I am able to Explore them, everything works perfectly. However, when any of them become disconnected, be it accidentally or through Safely Remove Hardware, they will not be displayed in My Computer upon reconnection. The sound will play confirming that the computer has recognised that a device has been connected, but I am not able to use the drive(s) because Windows Explorer does not show they are there.

I then went to Computer > Manage > Disk Management. None of the devices are listed. I also looked in Device Manager > Disk Drives and all the drives connected to the computer are listed.

I was not sure whether this was a "partition problem" (put in brackets because I don't know what partitions are!) because the devices DO work initially when I start up. It is only when I reconnect that the problem occurs.

It would not be too much hassle to reboot every time this happens, but one of the hard drives has a temperamental cable and gets accidentally disconnected quite frequently.

Additional notes:
- All drives work perfectly on other computers, both upon start-up and reconnection
- The makes of the drives are WD and Toshiba

If there is any other information that I should provide, please ask. Any help would be greatly appreciated. Many thanks.


Posts: 6,429   +186
What version of Windows and Service Pack level is installed? Have you applied all Windows Updates? Are you using a desktop or laptop?

Also see if this might help [post=875300]How to Cleanup and Remove old USB Storage Drivers[/post]
I'm using Vista with SP2, fully updated. I'm on a laptop.

I tried what was suggested in that thread and it seemed to work for a time but the problem has re-occurred when one of the drives became disconnected accidentally.


Posts: 6,429   +186
Can you repeat the problem at will? Try in Safe Mode, curious if it might make any difference for your case

You might also try reinstalling the USB Controllers and Chipset drivers (and make sure you're using the latest chipset)

Take a read through here See [post=720762]Troubleshoot: Windows Won't Recognize Your USB Hard Drive[/post]
No, the problem only seems to occur when the devices become disconnected
- after the laptop has been on for some time
- and/or I have used other USB ports for other things such as charging my iPhone during my session

I tried to see if the problem occurred in Safe Mode as you suggested but, as I said in my first post, the devices will function properly whenever I reboot, so it is un-testable.

I will try your other suggestion and let you know my results.

Sorry it's taking so long to fix this. I'm not sure of the exact conditions under which the devices will stop working so it's just a waiting game until it happens the next time.

Many thanks again.


Posts: 6,429   +186
OK. One more thing you might keep in the back of your mind as i'm inclined to think this is a Windows (vs. a hardware issue) which if all else fails might be fixed if you decide to do a Vista repair or even a full reinstall at some point if you so choose

See [post=766270]How to recover your folders/files when Windows won’t boot[/post]. Section 2 describes how to create a Knoppix bootable CD. If you boot into Knoppix and check your USB drives (plugging/unplugging) and they work then we know it;s a Windows corruption issue.

Is also handy to have a Knoppix boot CD handy if you should ever need a rescue CD in the future - so by creating one you can also kill 2 birds with one stone :)
Looks like reinstalling the USB controllers hasn't worked either! It seemed to have worked fine for about a day or so (just like when I used the DriveCleanup) and I plugged and unplugged my devices at will and they all functioned normally. But after a while, same problem. It seems like those two solutions did fix the problem but only temporarily. Funny thing is that it can recognize and access my iPhone no matter how many times i plug and unplug. Any ideas why this only happens with external hard drives and not other things using USB ports?

I've tried all the fixes and none of them have seemed to solve the problem. The only way to fix it is to do a full reinstall?