My internet will only work through ethernet cable not wireless

Hi there, my internet was running fine until yesterday, when I tried to connect to the internet, the message "windows can't communicate with the device or resource (primary dns server)" came up.. I followed all 4 methods on this website: http://answers.microsoft.com/en-us/w...3-b5d1ec46fae5 but none of them worked for me, I then returned my laptop to factory settings in the hope it will work, but that didnt not work, I then realised it works through the ethernet cable but not wireless..

I ran ipconfig/all with my ethernet cable in and this is the result..

Windows IP Configuration

Host Name . . . . . . . . . . . . : Nida-TOSH
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek RTL8188CE Wireless LAN 802.11n PC
I-E NIC
Physical Address. . . . . . . . . : D0-DF-9A-EB-80-B8
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::55d0:fccc:9e2c:eb38%13(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.0.4(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : 13 October 2013 11:35:44
Lease Expires . . . . . . . . . . : 13 October 2013 12:35:50
Default Gateway . . . . . . . . . : 192.168.0.1
DHCP Server . . . . . . . . . . . : 192.168.0.1
DHCPv6 IAID . . . . . . . . . . . : 433119130
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-19-EB-5A-4A-B8-70-F4-D1-27-E…

DNS Servers . . . . . . . . . . . : 194.168.4.100
194.168.8.100
NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek PCIe FE Family Controller
Physical Address. . . . . . . . . : B8-70-F4-D1-27-EF
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{88627EEB-B140-486C-AC16-9CEB7F46…

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 9:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2001:0:5ef5:79fb:1430:3715:affc:eb21(Pre…
erred)
Link-local IPv6 Address . . . . . : fe80::1430:3715:affc:eb21%11(Preferred)
Default Gateway . . . . . . . . . : ::
NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter isatap.{DF25D7AB-80BF-4FA1-9CB1-DFA12C88…

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
 

Jad Chaar

Posts: 6,482   +976
There may be an issue on the ISP side or router side since restoring to defaults didnt help. Or it could be an issue with the network adapter. Or it could be an issue with the firewall.

Try downloading running these tools (download via ethernet, run on wireless): Network Fix-It Tool (right click on the internet bars on the task bar in the bottom right hand side of the screen, and click "troubleshoot network...") and Firewall Fix-It Tool.

Did you install anything on your PC before this happened? Did Windows install any updates?

Try disabling your AntiVirus. That may be the issue. I doubt it though.

Tell me if any of these solutions help.
 

St1ckM4n

Posts: 2,887   +628
  • [SIZE=15px]Can you [/SIZE][SIZE=15px]ping 194.168.4.100[/SIZE][SIZE=15px] ?[/SIZE]
  • [SIZE=15px]You said this is the result with you plugged in via cable, but the result shows that cable is unplugged and you are connected via wifi. [/SIZE]
 

learninmypc

Posts: 9,277   +684
[SIZE=13px][FONT=arial]hi there, my internet was running fine until yesterday, when I tried to connect to the internet, the message "windows can't communicate with the device or resource (primary dns server)" came up.. I followed all 4 methods on this website: http://answers.microsoft.com/en-us/w...3-b5d1ec46fae5 but none of them worked for me, I then returned my laptop to factory settings in the hope it will work, but that didnt not work, I then realised it works through the ethernet cable but not wireless..[/FONT][/SIZE]
[SIZE=13px][FONT=arial]I ran ipconfig/all with my ethernet cable in and this is the result.. SOMEONE PLEASE HELP ME THANKYOU [/FONT][/SIZE]
[SIZE=13px][FONT=arial]Windows IP Configuration[/FONT][/SIZE]

[SIZE=13px][FONT=arial]Host Name . . . . . . . . . . . . : Nida-TOSH[/FONT][/SIZE]
[SIZE=13px][FONT=arial]Primary Dns Suffix . . . . . . . :[/FONT][/SIZE]
[SIZE=13px][FONT=arial]Node Type . . . . . . . . . . . . : Hybrid[/FONT][/SIZE]
[SIZE=13px][FONT=arial]IP Routing Enabled. . . . . . . . : No[/FONT][/SIZE]
[SIZE=13px][FONT=arial]WINS Proxy Enabled. . . . . . . . : No[/FONT][/SIZE]

[SIZE=13px][FONT=arial]Wireless LAN adapter Wireless Network Connection:[/FONT][/SIZE]

[SIZE=13px][FONT=arial]Connection-specific DNS Suffix . :[/FONT][/SIZE]
[SIZE=13px][FONT=arial]Description . . . . . . . . . . . : Realtek RTL8188CE Wireless LAN 802.11n PC[/FONT][/SIZE]
[SIZE=13px][FONT=arial]I-E NIC[/FONT][/SIZE]
[SIZE=13px][FONT=arial]Physical Address. . . . . . . . . : D0-DF-9A-EB-80-B8[/FONT][/SIZE]
[SIZE=13px][FONT=arial]DHCP Enabled. . . . . . . . . . . : Yes[/FONT][/SIZE]
[SIZE=13px][FONT=arial]Autoconfiguration Enabled . . . . : Yes[/FONT][/SIZE]
[SIZE=13px][FONT=arial]Link-local IPv6 Address . . . . . : fe80::55d0:fccc:9e2c:eb38%13(Preferred)[/FONT][/SIZE]
[SIZE=13px][FONT=arial]IPv4 Address. . . . . . . . . . . : 192.168.0.4(Preferred)[/FONT][/SIZE]
[SIZE=13px][FONT=arial]Subnet Mask . . . . . . . . . . . : 255.255.255.0[/FONT][/SIZE]
[SIZE=13px][FONT=arial]Lease Obtained. . . . . . . . . . : 13 October 2013 11:35:44[/FONT][/SIZE]
[SIZE=13px][FONT=arial]Lease Expires . . . . . . . . . . : 13 October 2013 12:35:50[/FONT][/SIZE]
[SIZE=13px][FONT=arial]Default Gateway . . . . . . . . . : 192.168.0.1[/FONT][/SIZE]
[SIZE=13px][FONT=arial]DHCP Server . . . . . . . . . . . : 192.168.0.1[/FONT][/SIZE]
[SIZE=13px][FONT=arial]DHCPv6 IAID . . . . . . . . . . . : 433119130[/FONT][/SIZE]
[SIZE=13px][FONT=arial]DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-19-EB-5A-4A-B8-70-F4-D1-27-E…[/FONT][/SIZE]

[SIZE=13px][FONT=arial]DNS Servers . . . . . . . . . . . : 194.168.4.100[/FONT][/SIZE]
[SIZE=13px][FONT=arial]194.168.8.100[/FONT][/SIZE]
[SIZE=13px][FONT=arial]NetBIOS over Tcpip. . . . . . . . : Enabled[/FONT][/SIZE]

[SIZE=13px][FONT=arial]Ethernet adapter Local Area Connection:[/FONT][/SIZE]

[SIZE=13px][FONT=arial]Media State . . . . . . . . . . . : Media disconnected[/FONT][/SIZE]
[SIZE=13px][FONT=arial]Connection-specific DNS Suffix . :[/FONT][/SIZE]
[SIZE=13px][FONT=arial]Description . . . . . . . . . . . : Realtek PCIe FE Family Controller[/FONT][/SIZE]
[SIZE=13px][FONT=arial]Physical Address. . . . . . . . . : B8-70-F4-D1-27-EF[/FONT][/SIZE]
[SIZE=13px][FONT=arial]DHCP Enabled. . . . . . . . . . . : Yes[/FONT][/SIZE]
[SIZE=13px][FONT=arial]Autoconfiguration Enabled . . . . : Yes[/FONT][/SIZE]

[SIZE=13px][FONT=arial]Tunnel adapter isatap.{88627EEB-B140-486C-AC16-9CEB7F46…[/FONT][/SIZE]

[SIZE=13px][FONT=arial]Media State . . . . . . . . . . . : Media disconnected[/FONT][/SIZE]
[SIZE=13px][FONT=arial]Connection-specific DNS Suffix . :[/FONT][/SIZE]
[SIZE=13px][FONT=arial]Description . . . . . . . . . . . : Microsoft ISATAP Adapter[/FONT][/SIZE]
[SIZE=13px][FONT=arial]Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0[/FONT][/SIZE]
[SIZE=13px][FONT=arial]DHCP Enabled. . . . . . . . . . . : No[/FONT][/SIZE]
[SIZE=13px][FONT=arial]Autoconfiguration Enabled . . . . : Yes[/FONT][/SIZE]

[SIZE=13px][FONT=arial]Tunnel adapter Local Area Connection* 9:[/FONT][/SIZE]

[SIZE=13px][FONT=arial]Connection-specific DNS Suffix . :[/FONT][/SIZE]
[SIZE=13px][FONT=arial]Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface[/FONT][/SIZE]
[SIZE=13px][FONT=arial]Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0[/FONT][/SIZE]
[SIZE=13px][FONT=arial]DHCP Enabled. . . . . . . . . . . : No[/FONT][/SIZE]
[SIZE=13px][FONT=arial]Autoconfiguration Enabled . . . . : Yes[/FONT][/SIZE]
[SIZE=13px][FONT=arial]IPv6 Address. . . . . . . . . . . : 2001:0:5ef5:79fb:1430:3715:affc:eb21(Pre…[/FONT][/SIZE]
[SIZE=13px][FONT=arial]erred)[/FONT][/SIZE]
[SIZE=13px][FONT=arial]Link-local IPv6 Address . . . . . : fe80::1430:3715:affc:eb21%11(Preferred)[/FONT][/SIZE]
[SIZE=13px][FONT=arial]Default Gateway . . . . . . . . . : ::[/FONT][/SIZE]
[SIZE=13px][FONT=arial]NetBIOS over Tcpip. . . . . . . . : Disabled[/FONT][/SIZE]

[SIZE=13px][FONT=arial]Tunnel adapter isatap.{DF25D7AB-80BF-4FA1-9CB1-DFA12C88…[/FONT][/SIZE]

[SIZE=13px][FONT=arial]Media State . . . . . . . . . . . : Media disconnected[/FONT][/SIZE]
[SIZE=13px][FONT=arial]Connection-specific DNS Suffix . :[/FONT][/SIZE]
[SIZE=13px][FONT=arial]Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2[/FONT][/SIZE]
[SIZE=13px][FONT=arial]Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0[/FONT][/SIZE]
[SIZE=13px][FONT=arial]DHCP Enabled. . . . . . . . . . . : No[/FONT][/SIZE]
[SIZE=13px][FONT=arial]Autoconfiguration Enabled . . . . : Yes[/FONT][/SIZE]
Your link didn't work for me.
Do you havve a switch on the laptop that might of been accidently turned off.
 
  • Thread Starter Thread Starter
  • #5
Sorry to make things clear I have taken the ethernet cable which is usually attached to the wifi box to my laptop, which is why it says im connected however when I try to connect to the wifi without anything it will not work, it still says windows can't communicate with dns server. and I will attach ping 194.168.4.100 now, but I have the ethernet cable in :)

PING 194.168.4.100

Pinging 194.168.4.100 with 32 bytes of data:
Reply from 194.168.4.100: bytes=32 time=6ms TTL=253
Reply from 194.168.4.100: bytes=32 time=7ms TTL=253
Reply from 194.168.4.100: bytes=32 time=8ms TTL=253
Reply from 194.168.4.100: bytes=32 time=8ms TTL=253

Ping statistics for 194.168.4.100:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:

Minimum = 6ms, Maximum = 8ms, Average = 7ms
there you go, thankyou
 

jobeard

Posts: 13,973   +1,778
Use one or the other but don't try both Ethernet + WiFi at the same time. The DHCP for the wifi gets lost due to the active ethernet connection.
 

jobeard

Posts: 13,973   +1,778
BTW: If the Ethernet wired connection gets configured correctly (as you have shown), then there's absolutely nothing wrong with the TCP settings and you don't need ANY fixit :)

You *may* need a better WiFi driver however.
 
G

Guest

I have solved the problem by myself. To do this, first you have to disconnect your Ethernet cable from your laptop and follow the steps: Start>Control Panel>Network and Sharing Center>Manage Wireless Networks and remove all wireless connections by right click on it and select Remove network from the drop down menu. After doing this, close the windows and scan for the Wi-Fi networks. Click on the available network and select connect. After a while, you will be asked to give a password for your Wi-Fi connection. Type the password and click on connect button. And now will be connected to your Wi-Fi network via wireless.

May be it will help you.
Regards
MD. MAHMUDUL HASAN
 
  • Like
Reactions: HamzaS
I have solved the problem by myself. To do this, first you have to disconnect your Ethernet cable from your laptop and follow the steps: Start>Control Panel>Network and Sharing Center>Manage Wireless Networks and remove all wireless connections by right click on it and select Remove network from the drop down menu. After doing this, close the windows and scan for the Wi-Fi networks. Click on the available network and select connect. After a while, you will be asked to give a password for your Wi-Fi connection. Type the password and click on connect button. And now will be connected to your Wi-Fi network via wireless.

May be it will help you.
Regards
MD. MAHMUDUL HASAN






Thanks dude! This was the only way to fix it<3