My laptop cannot connect to the internet, even though wireless and ethernet are working

When I try and access the internet through any of the main browsers (I.e. Internet Explorer, Google Chrome, Firefox and Safari) they tell me along the lines of 'unable to access the network' and 'this page can't be displayed' after taking a while attempting to load. I also cannot access it through any of my Windows 8 apps. I know it's not an issue with the home broadband itself and is something to do with my laptop as it is running fine both wirelessly and through using an Ethernet cable on all other devices. I would really appreciate some help with trying to fix this asap as I have spent a lot of time researching this issue and trying most things to resolve it without success, I also need to use the internet for loads of coursework over the summer hols and cannot afford to be taking it to a pricey IT technician. Please helppp :D
 

jobeard

Posts: 13,818   +1,741
Take a look at the file
\windows\system32\drivers\etc\hosts​
there MUST be at least a line reading 127.0.0.1 LOCALHOST
but the question is there anything other than comments in it?
If so, leave the comments and the localhost line and delete everything else.

If you modify the hosts file, then you also need to
  • ipconfig /flushdns
  • net stop "dns client"
  • net start "dns client"
 
  • Thread Starter Thread Starter
  • #3
Thanks for your help, I've had a look in that file and this is what it says (see picture), I'm not sure what further action to take.1376066791498.jpg
 
  • Like
Reactions: Miguelmevo

jobeard

Posts: 13,818   +1,741
Hmm - - all lines with a '#' as the first character are comments, so
# 127.0.0.1 local host
is a comment and not active :(

remove the leading # on that line and the next one, save the file (you will need admin privs).
 
  • Thread Starter Thread Starter
  • #5
Okay :) I've managed to remove the two # from the last two lines, but this is my current situation, do I need to change the modified one (the text document) into a 1376092689695.jpg normal file or something?
 

tipstir

Posts: 2,854   +197
Hosts can't be a hosts.txt it has to be a host rename the old one to hosts.old and change the hosts.txt to hosts

Be-care with hosts file too.
 
  • Thread Starter Thread Starter
  • #8
A couple of days later and it's stopped working again, so extremely annoying, I've checked that hosts file and that looks okay so I don't have any idea why it's unable to connect again urghh
 

tipstir

Posts: 2,854   +197
Download spyware blaster from here you use the free one. That will help protect the host. What are you using for protection.

Download Super Anti-Spyware Free
Download Malware Bytes Free

Run both in safe mode.
Tell me what are you results from each?
 
  • Thread Starter Thread Starter
  • #10
Thanks for the response, I'm having to use my tablet because the internet on my laptop isn't working, how can I download it onto my laptop without internet?
 

tipstir

Posts: 2,854   +197
Which tablet are you using iPad, Android or Windows? You never said. Do you have Box.com, Dropbox or SkyDrive? You could download to those cloud storage and then slide load the files to the laptop.

Can you do this on your laptop:
Click on Start or the Orb
Or press flag key and R on the keyboard at the same time
type: cmd
type: ipconfig > mynet.txt


Windows IP Configuration


Ethernet adapter Gigabit LAN Connection:

Connection-specific DNS Suffix . :
Link-local IPv6 Address . . . . . : xxxxxxxxxxxxxxxxxx
IPv4 Address. . . . . . . . . . . : 192.168.x.xx
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.x.x

Tunnel adapter isatap.{xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Tunnel adapter isatap.{xxxxxxxxxxxxxxxxxxxxxx}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Tunnel adapter Teredo Tunneling Pseudo-Interface:

Connection-specific DNS Suffix . :
IPv6 Address. . . . . . . . . . . : xxxxxxxxxxxxxxxxxxxxxxxxxx
Link-local IPv6 Address . . . . . : xxxxxxxxxxxxxxxxxxxx
Default Gateway . . . . . . . . . : ::

This is mine above using that mynet.txt

What do you see when you type yours.

Another thing we can do for you is make you use static IP address instead of doing a DHCP.
This way you would force the PC in question to use a certain address.

IPv4 Address. . . . . . . . . . . : 192.168.x.xx (type in the address from what you had)
Subnet Mask . . . . . . . . . . . : 255.255.255.0 (match this to what you have on your tablet)
Default Gateway . . . . . . . . . : 192.168.x.x (this is from your router IP address)
 
  • Thread Starter Thread Starter
  • #12
I'm using an android tablet, but I don't think I'll be able to pull off the downloading on my tablet and using my skydrive etc. I don't know much about it because I never use them.
However I did that mynet.txt thing and this is what showed up...1376441245079.jpg 1376441309967.jpg
 

tipstir

Posts: 2,854   +197
Why are you using IPV6 with IPV4. You should really use one. I use IPV4 on Windows systems here. On the Android tablet go to play store and download: WiFi Analyzer This below is WiFi Fixer but you don't need that for your Android tablet.

 

tipstir

Posts: 2,854   +197
Okay your on IPV6 but there is no default gateway showing up. You need to go into the NIC configuration for your computer and change the default gateway to match your router IP address. That needs to be in there. It's missing. Why are you on IPV6 though? Is the tablet setup to use IPV6?
 

jobeard

Posts: 13,818   +1,741
Also appears that you have BOTH a wired and a WiFi connection and that will mess up the routing table.

use one or the other but not both at the same time :)
 

tipstir

Posts: 2,854   +197
OP is running VMware on PC then says they're having issues. If it was working then what's changed.
Yes you need to disable WiFi or Wired connections you can't run both setups there was a time you could but in your case you have VMware on the hardwired connections. It clearly shows that's what you have. IP for that is completely different for your WiFi. So if you using WiFi disable the VMware connection. Or whoever is running VMware on that system.
 
  • Thread Starter Thread Starter
  • #17
I wasn't aware that I was using IPV6 and IPV4, I'm not even sure what they are or what they mean. I'm also not sure what IPV my tablet is setup with. I never use an ethernet cable with my wifi so I don't know why it would appear so :( anyway, this is the result from the wifi analyser..View attachment 76769.

How do I disable the VMware connection so I can use the WiFi?
 

tipstir

Posts: 2,854   +197
1. Open the Network and Sharing Center
2. Change adapter settings
3. Disable the wired (aka local area connection) right click then click on disable

To get to the Open Network sharing center you should see either ||||| near the clock in the system tray or you see monitor with power line cord. Right click on these will give you the option to get too the Network and Sharing Center.
 

tipstir

Posts: 2,854   +197
Eek! Disable all of those and only keep the WiFi enabled. Is this a work PC or did you buy it like this. If your not using VMware you can remove those. Should only have Ethernet and WiFi. You'll need to go into the System Device Manager and see what you have for Networking. Those VMware would need to be removed. But before you do that make sure you don't have any VMware software installed.
 
  • Thread Starter Thread Starter
  • #21
I bought it like this, I only bought it in April so I don't know why everything is going wrong with it so soon :( I've disabled them, I don't know if the internet is supposed to be working at this point, but it's not. I've searched for VMware software on my laptop and found 'VMware player', not sure what that's all about?1376510324905.jpg
 

tipstir

Posts: 2,854   +197
Well is the laptop or desktop running okay now with the internet? That's the VMware Player allows you to run multi-OS on your system. If your not going to use it can remove it. If you plan on using it leave on their. That's up to you. I see you disable what I had mentioned! Good Job! ;)
 

tipstir

Posts: 2,854   +197
Go back to the adapter settings
Click on the WiFi
unchecked all This connection uses the following items:
Click okay
Reboot the laptop.
 
  • Thread Starter Thread Starter
  • #25
I've done that, thank you for your help, but still no luck unfortunately. When I unchecked the boxes and rebooted, it didn't even connect to the wireless, which it did before. So I checked the same boxes again that were previously checked and it's come back (but still with no internet) I was just wondering if what is being displayed about the WiFi and it's properties is how it should be (bearing in mind that the Ethernet cable wouldn't work either, so it's an issue with not just the wireless)...1376514021258.jpg