Need Help

By Xpekt ยท 14 replies
Mar 31, 2008
  1. Hello everyone, well my problem is that I jus bought a Genius HS-03U headset and my Windows XP SP2 says "unknown device" and after the first time I plugged the headset it worked for about 30 mins and since then I can't put them to work. I've tried to go to genius website to download the drivers but they don't have any for this model. It's a USB headset and no CD was in the package so would like to know what to do to resolve this problem. thanks
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Start -> Run -> devmgmt.msc

    Remove any yellow querried devices
    Unplug the USB headset
    Wait for all to load
    Re-insert headset
    Reply back
  3. Xpekt

    Xpekt TS Rookie Topic Starter

    Thanks for the quick response. I've uninstalled the yellow querries devices has you said but after restarting those devices come right away for installation again... and the windows didn't detect the headset after I plugged it in.
  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Did those querries come back, even before you installed the headset, or after?

    If it's before, you will need to go to your M/b support page and confirm all drivers are updated

    Actually what make and model is this computer?
  5. Xpekt

    Xpekt TS Rookie Topic Starter

    This headset as an USB device it's supposed to plug in and that's it.. actually the first time I've plugged it in it didn't required any installation... just put the re-direct the audio to the headset and that was it. My M/B is a ASUS A7n8x-x with a AMD athlon XP
    3000+ processor
  6. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    The only driver that Windows does not automatically find is the audio driver:

    The manual says USB2 X 4 (so that's ok)

    I would try Windows Update, and select "Custom" and load all driver updates
  7. Xpekt

    Xpekt TS Rookie Topic Starter

    I've updated Windows has you said it.. but it didn't have any drivers to update just Internet Explorer 7.0 etc.. it didn't had any hardware updates. Also already had installed the soundcard driver form asus website.
  8. kimsland

    kimsland Ex-TechSpotter Posts: 14,523


    Remove all external USB (ie the headset and any other, other than mouse/keyboard)

    Go back to Device Manager (then click on View-->Show hidden devices <--In Dev.Man. Toolbar)

    Then remove the querries again, and any other strange driver - not present.

    Then go to add/remove programs and remove sound driver

    Then restart

    You may need to re-download the sound driver (and install, it's small)

    Then when everything looks ok, in Device manager. Plug the headset back in
    Or remove the USB drivers too (ie Windows will find them)

    Then restart (Alt + F4 a few times on the keyboard if mouse support goes)
    Then restart, allowing USB to be re-installed
    Then re-check Device Manager
    If all is good, then plug in the headset again

    Yeah, that'll keep you busy (actually that's what I'd do- other than resetting the bios!)
  9. Xpekt

    Xpekt TS Rookie Topic Starter

    well after doing that the USB detected the headset... it appeared the windows installation assistant.. I ran and the message "The device is installed and ready to use" but I go to the sound options and nothing is there... and n sound is coming out of the Headset.
  10. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    God's sake! (now the sounds gone)

    Obviously you downloaded and installed the driver.

    I'll tell you what, use this:

    Please press the green button, and select your audio driver

    Sorry, it seems you must do this twice, once here, then when you get to Asus support, click it again. This button uses JavaScript (which is enabled by default on most browsers)
  11. Xpekt

    Xpekt TS Rookie Topic Starter

    I've downloaded the driver for the soundcard has you said it... but the headset doesn't appear anywhere even though the windows said it was installed and ready to use.
  12. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    And the sound ? It's back ? (cause you didn't exactly say)

    Anyway, pull out. Restart. Push back in

    If the same thing happens, I'm going to say, compatability issue with old computer and new device (that's an easy cop out )
  13. Xpekt

    Xpekt TS Rookie Topic Starter

    oh sorry, Yeah the sound its back... but the headset is "dead", maybe you're right my computer already has some years but the strangest thing is that it worked for about 30 mins and then it "died"... Update my BIOS is a possibility to correct this error??
  14. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Your computer may have killed it :(

    Maybe test on a newer computer, then sell it
    Go buy a real cheapo one ($5 - $10)
    Plug it into one of the four (back) USB 2 connectors

    I must log off now

    Just reply back one day with what happened
    I hope I helped a little bit, but not quite sure (seeming we're at the start again!)
  15. Xpekt

    Xpekt TS Rookie Topic Starter

    hmmm ok and thanks very much for the quick response... I'm a fan of this forum now :) take care.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...