New HDD not recognized

Hi,
My HDD recently died so I went out and got a replacement(Seagate ST1000LM048). After a few failed attempts to connect it from I don't even know what reason (it just wouldn't recognize it) I finally got it working and installed windows. When I downloaded graphics card drivers the whole laptop stopped responding and I shut it down. After restarting, the HDD was once again not recognized and I searched a few forums and found a bunch of repeated questions so here are the answers:
1. The HDD is recognized in BIOS and listed as Hard drive on legacy, and by it's name on UEFI boot.
2. Dell diagnostics gives me a NA sign in front of the hard drive, if I click on it it says all tests passed, even with thorough testing
3. Tried booting both in legacy and UEFI boot and failed miserably.
4. The Hard drive was 100% recognized at one point since I successfully installed Windows on it and it worked for a bit.
5. Booting in UEFI results in a dell with a loading logo and black screen, and booting in legacy results in the picture no.1 sometimes, sometimes even says hard drive not detected.
6. SATA operation is set to AHCI and I can't change it.
7. Tried an old faulty HDD and it's working fine up until the point where the bad sectors glitch the hell out of the Windows so the connectors are fine.
The new HDD is slim, but it fit well in the 7mm spot so I don't think that should be a problem since everywhere I read, it says that the only difference is size, and both should work just fine.
Could it be that the new HDD I bought is faulty?
Any help is deeply appreciated :D
 

Attachments

  • Screenshot_6.jpg
    Screenshot_6.jpg
    60.8 KB · Views: 1